3 Replies Latest reply on Sep 4, 2012 4:24 PM by mischaboender

    Problem with clienttask.run Parameter: comma-separated list of names, ip addresses or ID's

    rw89

      Hello

       

      I've just started to to work with the WebAPI, but unfortunately I have some problems with the method 'clienttask.run'. Maybe someone can help me or tell me what I am doing wrong.

       

      I'm trying to use the Agent-GUID as the first (id) parameter, but it fails everytime. (I'm using the ePO API Explorer 1.0.1.0 to check this methods)

       

      1. When I am trying to use the method 'clienttask.run ids' I get this error message then (Example-GUID: 8ae8d8d0-e6aa-11e1-aff1-0800200c9a66):

       

      Error 0 :

      For input string: "8ae8d8d0-e6aa-11e1-aff1-0800200c9a66"

       

      2. When I'm trying to use the method 'clienttask.run name' I get this error message:

       

       

      Error 0 :

      System Ids or names list is empty

       

      The scripting guide says that I have to use a comma-separated list of names etc. Although I have only one GUID, I've tried this with 2 and more (always separated by a comma) but it still didn't worked!

       

      PS: Only when I'm using the system-name instead of the Agent-GUID --> it works ! 

       

      So, what am I doing wrong?

       

      Thanks!