2 Replies Latest reply on Sep 26, 2012 4:50 AM by raiden24

    Reports generated with username filter fails

    rajjesh

      we currently use web reporter version 5.2. when i try to generate reports for a adding username in the filter "user name", it takes hours to get completed, also in the report results "no data matched the report criteria" is displayed. however when i add the ip address of the system used by the user whoes report is needed to be genrated leaving the username filter default i.e "User Name", the reports are generated successfully.

       

      can anyone tell me why is this happening ???

       

      Regards

       

      Rajjesh B.

        • 1. Re: Reports generated with username filter fails
          sroering

          1) How large is your DB? I'm looking for number of months of data in the database, and the record count for detail and summary tables. You can get all of this information from your last successful DB Maintenance job (Administration > Tools > Database Maintenance > Status)

           

          2) Do you have index maintenance enabled to run at least once a month?  (Administration > Database Maintenance)

           

          3) When you create the user filter, do you see the same names 2 times?  If so, add both of them to the filter. I can explain more later if necessary.

          • 2. Re: Reports generated with username filter fails

            Hi Sroering,

             

            We seem to have the same issue. We have Reporter 5.2 and everything running quite ok. Only when we drill down from the Quick View to the username and then try to query the sites he/she accessed it keeps on going eternally.

            Further more when I try to make a custom report with a query for the user, sites and hits, it always gives me the No Data found problem, although other builtin reports run fine.

             

            Also when I schedule that Quick view report, the results are there instantly and good.

             

            So I must be doing something wrong ...

             

            Could you give me the steps of creating a custom report, so that if we run we can enter the username and it gives us all the sites and hits per a given time period ?

            Could you also elaborate some more on the 'same names 2 times' ?

             

            Appreciate the response ...