1 Reply Latest reply on Aug 6, 2012 2:26 AM by asabban

    Migration 6.8 webwasher -> 7.1.0

    vdhuynh

      Hi,

       

      After the migration of web gateway 6.8 to 7.1.0, we can not do URL Filtering with URL WhiteList and BlackList. When I do URL Filtering with "Wildcard Expression", the Test isn't good. Ex: *.lemonde.fr et Test displays "no match". What's happened  ? Could you help me ? I don't  know the version 7.x of web gateway.

      Thank you.

       

      vdhuynh

        • 1. Re: Migration 6.8 webwasher -> 7.1.0
          asabban

          Hello,

           

          in 7.x you need to watch out which properties you use. There are multiple ways to do white or black list entries. In 6.x you were always working with the complete URL, so you only filled in "google.com" and this automatically matched entries like

           

          http://www.google.com

          http://google.com/index.htm

          https://mail.google.com/whatever

           

          In MWG 7.x this is much more granular. The first important thing is the property you use. Given you have a URL like

           

          http://www.youtube.com/watch?v=8lMxpDYA5Wg

           

          You could use the following properties:

           

          URL (matches the complete URL: http://www.youtube.com/watch?v=8lMxpDYA5Wg)

          URL.Host (matches ONLY www.youtube.com)

          URL.Path (matches ONLY /watch?v=8lMxpDYA5Wg)

           

          etc. Also important is the operator. You need to ensure not to mix up "equals" and "matches". For "matches" it is important that you add wildcard everywhere where they are necessary. In 6.x MWG automatically assumed an "*" at the beginning and end of your entries. In 7.x you have to add them yourself.

           

          You should share your rules to allow us to see what is goign wrong. Assuming you say:

           

          URL matches "*.lemonde.fr"

           

          This entry will almost never match. The URL does at least continue a "/" at the end and most likely more characters. In this case you would need to say URL matches "*.lemonde.fr/*" or something like URL.Host matches "*.lemonde.fr", which should work as expected.

           

          If you are not familiar with MWG 7.x I recommend to have a Training on the product. You could also start with some good demonstration videos we have, for example at

           

          http://www.youtube.com/watch?v=8lMxpDYA5Wg

           

          Best,

          Andre