3 Replies Latest reply on Sep 8, 2009 5:39 AM by dthompson76

    Adobe Reader and VS 8.7


      Has anyone else experienced the following? Sometimes when you click on a PDF file Adobe Reader it will load it within the browser but other times (when downloading from a webmail account for instance) it will give you the option to Open or Save the file. When you click on Open and On Access Scanning is enabled, Adobe will return the error "There was an error opening this document. Access denied", when disabled it will open the file in Adobe reader as expected.

      This appears to only occur in Internet Explorer and not Firefox. I ran Process Monitor and some ACCESS DENIED Results are shown for the Adobe Reader process as it is trying to write the PDF file to the Temporary Internet Files Folder.

      I have tried excluding *.pdf from scanning but it still refuses to open the file. I have added the Adobe reader executable to low risk processes but still the same problem. Is there any way to get this to work without obviously placing our systems at too much risk (e.g. by not scanning Temporary Internet Files)? I know you can just save the file and open it but a few users are complaining as they have to open many PDF files at a time.

      This behaviour has been seen on XP and Vista Machines, VS 8.7 Patch 1, with both IE 7 and IE 8.

      Any thoughts greatly appreciated. Thanks!
        • 1. RE: Adobe Reader and VS 8.7
          Check your access protection policies setting - sounds like it's a policy protecting the temp internet folder being written to.

          • 2. RE: Adobe Reader and VS 8.7
            the access protection logfile ( right click on access prot in vse console choose log) will shows the exact rule and files you are breaking, you can then create an exemption.
            • 3. RE: Adobe Reader and VS 8.7
              Thanks for the suggestions guys. I took a look at the Access Protection log but it didn't actually list anything related to Adobe reader but perhaps my logging isn't working properly. I did spot some older entries relating to other processes which sounded like they might be the culprit however.

              In the end it turned out to be the following setting that was causing it:

              Anti-virus Maximum Protection:Protect cached files from password and email address stealers

              Thanks again!