8 Replies Latest reply on Aug 1, 2012 9:38 PM by hem

    Mcafee EPO 4.5.0 Error

      Hello,

       

      Can anybody advise on this please? I have gone on quite few blogs and been advised that there could be msvcr.dll corruption, I have done the restore - still not working. Been advisd that it could be db communication error. checked the database connectivity - all ok .via https://localhost:8443/core/config. Only admin can login. DLP agent has gone corrupt.  We are using Mcafee EPO 4.5. the only change happen is sophos upgrade to new version. I have uninstalled sophos still no good. Thanks.

       

      MafeeEPO_error.jpg

        • 1. Re: Mcafee EPO 4.5.0 Error
          relayer77

          Some basics to cover down on just in case you overlooked them:

           

          1) if it's a split configuration (epo on one server sql on another) cycle the sql services and then cycle the epo services to try to restablish sql connectivity.

          2) check your db.properties file in:  <installdir>\program files x86\mcafee\epolicy orchestrator\server\conf\orion and make sure all the db info is correct and complete.

          • 2. Re: Mcafee EPO 4.5.0 Error

            Thanks for the reply.

            Its not a split configuration and i have checked the db.properties file. the details are correct. after digging into the files. I found this quite a few lines in EPOAPSRV.log files. Not sure about this info

             

            EPOJNI.... Getting License data...

            I have also attached error message log file with three different error messages .. please advise. Thanks.

             

            Message was edited by: sim on 30/07/12 08:29:42 CDT
            • 3. Re: Mcafee EPO 4.5.0 Error
              Sailendra Pamidi

              This line in the screen cap and log snippet seems to point to a missing configuration file named epo.properties.

               

              "Could not instantiate bean class [com.mcafee.epo.core.util.ServerConfiguration]: Constructor threw exception; nested exception is java.lang.RuntimeException: Could not find the epo.properties configuration file "

               

              This file is usually found under Program Files\McAfee\ePolicy Orchestrator\Server\conf\epo

               

              Please check if this file is present - if yes, attach it here for review.

              • 4. Re: Mcafee EPO 4.5.0 Error

                Yes, you are right the file is missing in Program Files\McAfee\ePolicy Orchestrator\Server\conf\epo. I managed to restore the file and restarted the SQL server services &  mcafee application, event and server services .. Could login ok and got DLP Policy and Monitor.. gr8.  however DLP Monitor is not working but DLP Policy is looking good. Please see the error  message.DLPMonitor_Error.jpg

                 

                Some more suggestions please. Thanks

                • 5. Re: Mcafee EPO 4.5.0 Error
                  Sailendra Pamidi

                  I am afraid my DLP knowledge is very limited. You may want to gather a full MER and open a Support ticket to get this addressed.

                  • 6. Re: Mcafee EPO 4.5.0 Error
                    hem

                    It looks that the issue is with SQL. Are you able to do a test connection in HDLP policy manager=>Tools=>options=>General=>Test connection?

                    • 7. Re: Mcafee EPO 4.5.0 Error

                      Yes Hem, I did the SQL test and it connected successfully ti http://localhost:8731/DLPWCF/ManagementConsoleWCFService.

                      • 8. Re: Mcafee EPO 4.5.0 Error
                        hem

                        If you change to machine name than localhost then are you still getting the error? If yes then please open a case with support as per the last suggestion.