1 2 Previous Next 11 Replies Latest reply on Aug 28, 2013 7:29 AM by SafeBoot

    External hard drive is not recognised

      Hello!

       

      I have a notebook that was given to me by my employer. It has McAfee Endpoint Encryption installed on it. A few days ago I connected an external HDD to it via eSATA. No messages or dialogs were presented to me, and at first, everything worked perfectly, drive was accessible and readable. Next day, the drive was totally inaccessible. When I attach it to the notebook, I see two new drives appear in my Explorer (that is correct, the drive has two partitions) but when I try to open them, a message "Drive is not formatted, do you want to format it?" appears. At first, I thought that I was unlucky to have a HDD failure, and tried to use several recovery tools. None of them produced any results, so that led me to conclusion that the drive might have been encrypted by McAfee fully (or partially) during the first session.

       

      I am attaching a screenshot of a window that appears after I click "Show Endpoint Encryption Status".

       

      Please help me understand what happened and get my data back.

        1 2 Previous Next