1 2 Previous Next 19 Replies Latest reply: Jul 2, 2012 2:16 PM by mrobert21 RSS

    McAfee says it is installing new updates, but it is not installing anything. Please Help!


      I am having an issue with McAfee.


      When I tell McAfee to check for updates when there are no new updates, it checks for updates, downloads something or the other, then skips the installing stage and tells me "Updates Installed Successfully". The McAfee "about" section clearly indicates that nothing actually has updated.


      I've uninstalled and reinstalled McAfee multiple times and the problem still returns. Malwarebytes and McAfee both detect no problem. MVT does not detect problems either (though today MVT found some security center registry error). My dad used to have this problem too on his laptop, but now he doesn't. How do I fix this?


      When there is an actual update, it updates fine, but otherwise I get this nonsense.

        • 1. Re: McAfee says it is installing new updates, but it is not installing anything. Please Help!

          I have been having this same exact problem since Monday (June 18, 2012) and I have seen the other threads on here about this issue, so I finally decided to join the community to add my input about how angry I am about this problem.  I have already spent over 10 hours doing McAfee support sessions with various Tier 1 and 2 support agents over this problem.  After at first denying any problem existed and then trying to blame the problem on my computer and product (though they checked everything on my product and computer, including reinstalling the product), McAfee finally admitted there was a problem and it has nothing to do with my computer (my showing them the other threads on here about this problem finally opened their eyes to this problem many users are facing).  I have been told there should be a patch out to fix this problem in 2 weeks and I am to call them back if it is not cleared up, which I sure will.


          Mysteriously, the problem stopped and updating was working normally for many hours yesterday (Friday, June 20, 2012), but then the same problem started again for no reason this morning and has been going on since then (I changed nothing on my product nor my computer to cause this problem at any time).  I am now also getting a subscription verification problem, which may be related to this update checking problem, because I get no subscription verification box or a box with a problem statement when I try to verify my subscription after checking for updates.  I am sick and tired of update checking taking twice as long as before, using more resources on my computer, and constantly giving me the false "Updates Installed Successfully" message when it did not install anything (McAfee Tier 2 technicians have confirmed McAfee is not downloading nor installing anything when it does this every time I check for updates and none are available).  McAfee better get off their butt and get this (as well as their subscription verification problem) fixed for good soon, so the updates resume checking normally without false downloading and installing, or else I will dump McAfee for Avast or AVG just like I dumped Norton for McAfee when their junk never worked no matter how long I spent talking to Norton's technical support Indians.

          • 2. Re: McAfee says it is installing new updates, but it is not installing anything. Please Help!

            I had subscription verification problems after uninstalling and reinstalling, but now they are gone.


            The really weird thing is both my laptops (which have no files transferred between the two) both have this issue in Florida, but my parents' laptops in California once had the problem but now no longer have it...

            • 3. Re: McAfee says it is installing new updates, but it is not installing anything. Please Help!

              Please post some system information so we know which products you have installed.

              Security Center version, is VirusScan installed? Firewall? Anti-Spam?


              Did you install Malwarebytes after you installed McAfee?


              If you want to "catch" your update before we apply it,


              You can set Updates to Notify you before installing.

              Open McAfee from the desktop icon or the system tray icon.

              Click Updates: Current

              To the right click Settings

              If you dont see any Options, expand the Options drawer by clicking on the down arrow

              Click the middle radio button "Download updates but notify me before installing"

              Click Apply.


              The next time you get an update, which actually has something to install you will get a message. At this point do not tell it to install.

              Instead go to C:\ProgramData\McAfee\msc\updates on Win Vista/7/8 or C:\Documents and Settings\All Users\Application Data\McAfee\MSC\Updates on XP


              If there are files inside the updates folder, the product has updates. This could be anything from missing files, Virus Updates, Spam Content Updates, Product Updates, patches.


              If the problem persists, you will need to give me the contents of the updates folder and the contents of MCLOGS which is located in the McAfee folder two levels back in the directory. For example: C:\ProgramData\McAfee\MCLOGS




              Message was edited by: dougr_t3_support on 6/22/12 2:11:36 PM PDT
              • 4. Re: McAfee says it is installing new updates, but it is not installing anything. Please Help!

                I am currently at work right now and my computer is off, but I'll tell you what I can


                I have no problem getting the updates to install when they actually exist, so my computer has the latest updates (as of yesterday night) for everything I've installed. I'll get you that information later tonight or tomorrow.

                I installed Malwarebytes after reinstalling McAfee.


                I do not have any problem actually updating McAfee. Normally I catch the updates before McAfee goes looking for them, since I am very particular about telling McAfee to update each time I start up my computer.


                The problem is, it pretends to update and install updates that don't exist instead of saying that my software is up to date like it should.

                • 5. Re: McAfee says it is installing new updates, but it is not installing anything. Please Help!

                  u3.pngu1.pngu2.pnghere is my version info, I have not pushed for the latest update yet

                  • 7. Re: McAfee says it is installing new updates, but it is not installing anything. Please Help!

                    Malwarebytes has NOTHING to do with this issue of the phantom downloading and installing of updates that do not exist.  As 1 of McAfee's own Concierge Platinum technical support people just told me, despite Malwarebytes being on McAfee's list of allegedly conflicting programs (just because McAfee does not want you finding something better than their junk to use), he has never in his life seen a conflict between Malwarebytes and McAfee.  I have the problem with the fake downloading and installing of updates that do not exist and I do not have Malwarebytes on my computer and I have not had it on my computer for over a month when it was last put on temporarilly by a McAfee Concierge Platinum agent to clean an infection, which was caused by an incompetent Tier 2 McAfee Indian agent who reinstalled Chrome on my computer using a bad, weird, ad supported link from Yahoo search (rather than just typing in the Google web site as I told him to) to fix a problem I had with Quick Clean not opening after a new build of Total Protection was released.  Norton used to do the same thing where they claimed there were non existant conflicts they could never prove to try to scapegoat away why their junk never worked and I am sad to see McAfee is the same way.


                    I have already been through hours of trouble shooting with McAfee Tier 2 and Concirge Platinum American agents about why checking for updates no longer works properly and they all admit it has NOTHING to do with my computer or my product.  I have been told it is a bug in the programming, which will be fixed some time in the future with a patch, though I highly doubt it.  They all say not to worry about it because updates are installing correctly when they are available, but checking for updates now takes twice as long as before and uses way more computer resources than it used to when no new updates were available.  I suspect the update problem has something to do with the newest 3.5 version of Site Advisor because when I just did a fresh reinstall of the product with Concierge Platinum support to try and fix my endless Subscription Verification issues, the updating resumed working normally when Site Advisor reverted to version 3.4 (the last time before that that updating worked normally version 3.4 was also on there), but once version 3.5 of Site Advisor was installed, updating went back to being goofy.


                    I am not sure if my Subscription Verification problems are related to this updating problem, but that is randomly not working too now ang gives me no message after running or a yellow or red warning message after running though I unfortunately have until next March left on my subscription.  I have been all through Tier 1 and Concierge Platinum trying to ge that fixed too and just with the updating problem they all agree nothing is wrong with my product or computer and the fault is on McAfee's end.  I can not get a Tier 2 agent to talk to about the subscription verification problem because I keep getting promised call backs, which never happen, and I can not get the Tier 1 Indians to transfer me to Tier 2 any more (they put me on hold for long times then transfer me back and forth between Tier 1 agents).  I want things fixed on McAfee's end  to go back to how they were a week ago where EVERY time I check Subscription Verification I get the grey box I should saying Verification Completed and EVERY time I check for updates it quickly checks (without ang fake downloading and installing) and says No Updates Available (NOT Updates Installed Successfully when NOTHING got installed) or else I will look for a new security provider (Norton screwed and cheated me, so I dumped them and will do the same to McAfee if I need to).

                    • 8. Re: McAfee says it is installing new updates, but it is not installing anything. Please Help!

                      This problem has got to me and bit too closely...

                      I had a dream it started working normally


                      I've message Doug about this, but sometimes now (post Doug's last comment) I get this message instead of the Updates Installed Successfully glitch



                      Update Problem

                      McAfee cannot update your software. Please check your internet connection. If the problem continues, please contact Technical Support


                      Also, I wonder if this is specific to certain McAfee accounts.

                      Both my laptops have the same McAfee account, but most of my parent's computers are on different accounts and no longer have the problem. My dad's desktop is on my McAfee account. He has busy work hours for the next couple days, but I'll have him see if that happens to the desktop still.


                      Message was edited by: leftisthominid on 6/23/12 10:01:13 AM CDT
                      • 9. Re: McAfee says it is installing new updates, but it is not installing anything. Please Help!

                        I uninstalled SiteAdvisor 3.5, and the problem is GONE!

                        The thing is though, my original installation from last week that SiteAdvisor 3.4 but had the problem


                        I am pretty sure my parents are on SiteAdvisor 3.4. I remember last week, my dad had the problem but no longer has it. I got rid of SiteAdvisor and the problem is gone for me. I will install Web of Trust for now


                        UPDATE: Reinstalling SiteAdvisor brought the problem back. Uninstalling it subsequently took it away again




                        Message was edited by: leftisthominid on 6/23/12 10:13:50 AM CDT


                        Message was edited by: leftisthominid on 6/23/12 10:33:43 AM CDT
                        1 2 Previous Next