4 Replies Latest reply on Jul 8, 2009 10:50 AM by JeffGerard

    Force VirusScan install from ePO

      Does anyone know if it's possible to force either an install or an uninstall of VirusScan 8.7 using a task in ePO? I've tried using the Command Line option in the task but can't seem to get it to work. All the options described in the documentation refer to using a command line from Windows and not the command line from within an ePO task. For example I've tried REINSTALLMODE=o in the command line box but no luck.

      In my rollout of 8.7 some machines are failing to install patch 1 and I think it's because 8.7 didn't install properly. I'm hoping that doing a force install or a force uninstall will fix the issue.
        • 1. RE: Force VirusScan install from ePO
          tonyb99
          I keep 2 groups in my directory with uninstall all VSE but leave agent and install version XXX set as deployment tasks. If a have problem machine ( eg after patch update not showing AV when its there etc) I drop it in and wake it up.
          • 2. RE: Force VirusScan install from ePO
            I follow your logic, but the agent log is giving me this error on some machines when doing an uninstall:

            Verifying VSE870Det.McS
            Uninstalling VIRUSCAN8700
            Error occurred while uninstalling VIRUSCAN8700

            This is happening on machines with 8.7 that are failing to install patch 1. Is there any way to do a force uninstall or force reinstall using the command line option from the epo task?
            • 3. RE: Force VirusScan install from ePO
              tonyb99
              there is a command line option you can add into the deployment task for each product

              i dont have copy offhand but at the back of the vse 8.5 install guide there are command line setup options have you checked the back pages of the vse 8.7 install guide?
              • 4. RE: Force VirusScan install from ePO
                JeffGerard
                You could also try a repair on the vse installation...I created a script that uses pstools (http://technet.microsoft.com/en-us/sysinternals/default.aspx) to remotely run a repair on vse using psexec.exe. You can also enable/start the telnet server on the remote side to get a remote command prompt.

                Then run this:
                psexec method:
                psexec.exe \\computername MsiExec.exe /f {147BCE03-C0F1-4C9F-8157-6A89B6D2D973} /qn

                telnet method:
                MsiExec.exe /f {147BCE03-C0F1-4C9F-8157-6A89B6D2D973} /qn


                Once you do the repair, Patch 1 should install fine.