5 Replies Latest reply on Oct 26, 2012 4:07 AM by luke.g

    Agent failed to communicate with ePO Server

      Hi Everyone,


      we have a big problem, we create a lot of computers images, but when we cloned the systems and put on production, mcafee agent display " Agent failed to communicate with ePO server"; according mcafee documentations we did this on each imaged created:

      " On the imaged system, locate the registry key for the agent and remove it. The registry keys are located at:
      HKEY_LOCAL_MACHINE\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent\AgentGUID"

       

      Now we have a lot of system whit this error.

       

      We are running Epo Sever 4.5 Patch 6
      Mcafee Agent 4.6 Patch 1
      VirusScan 8.8 Patch 1

       

      Any help Please...!!!

       

      Thanks,
      Wilfredy

       

      Message was edited by: wilfredy on 6/1/12 3:58:27 PM CDT
        • 1. Re: Agent failed to communicate with ePO Server
          Sailendra Pamidi

          Hello,

            I think you just need to delete the Registry value on the Original Gold Image before cloning. Then when you push the clones, they will not have any AgentGUID to start with. When the Framework service starts, it finds that there is no AgentGUID and will generate one.

           

          If you simply deleted the AgentGUID key from existing agents, please ensure you restart the Framework service (if you haven't already).

           

          An Agent_<machine>.log  file from affected system (found in the Documents and Settings\All Users\Application Data\McAfee\Common Framework\DB folder )along with Server.log file from ePO with matching timeline may help identify what is wrong.

          • 2. Re: Agent failed to communicate with ePO Server

            Hi, Sailendra

                 Thanks for reply.

                 Now I know was wrong, some images were created just removing the value data into the AgentGuid insted remove the AgentGuid Key.

                 How can i resolve this issue ?.  I know deploying Mcafee Agent resolve this problem, but  is there another way ? because some systems are remote place and could affect the network.

             

            Thanks..

            • 3. Re: Agent failed to communicate with ePO Server
              Sailendra Pamidi

              Unfortunately, there is no way the system will fix itself until the key is actually deleted. One possibile solution I can think of is to use a custom SuperDAT that will delete the registry key and restart the framework service. However, it will need to be deployed using third party tools such as PsExec from Sysinternals or by other means.

               

              Please log a case with support to request if such a SuperDAT could be created.

              • 4. Re: Agent failed to communicate with ePO Server

                Had the same error on an imaged computer. Delete they key and rebooted the system to refresk all services. Wil post back soon.

                • 5. Re: Agent failed to communicate with ePO Server

                  I had the same error, following the steps listed below on the affected clients solved the issue for me:

                   

                  • Click Start, Run, type regedit and click OK.
                  • Navigate to the following registry key:

                            [HKEY_LOCAL_MACHINE\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent\]

                  • Right-click the AgentGUID and select Delete.
                  • Click Registry, Exit.
                  • Restart the machine.

                   

                   

                  Source: https://kc.mcafee.com/corporate/index?page=content&id=KB56086

                   

                  Message was edited by: luke.g on 26/10/12 04:07:55 CDT