3 Replies Latest reply on May 11, 2012 5:58 AM by PhilM

    Problem with http crossing the firewall

    maitane

      Hello,


      We are having a problem with the navigation http crossing the firewall. As we are seeing in the log messages:

      May 10 9:54:32 HZKWSG-EJ10 Daemond: http will not be restarted due to possible startup errors
      May 10-EJ10 HZKWSG 9:56:05 kernel: pid 7156 (httpp), uid 0: exited on signal 6 (core dumped)

      Does anybody knows what's happening and what should we do?

      We have not rebooted the MFE yet. They have a clustered configuration active / active. Could you tell us what information would be needed to gather in case we have to open a case?

      Thank you very much.

        • 1. Re: Problem with http crossing the firewall
          PhilM

          There's a possibility that there's something wrong with the cluster and this is causing the http proxy service to restart. You may be better off raising a ticket with support so that they can work with you directly on this and they should also be able to advise you on what you should do, by way of information gathering, before you re-boot.

           

          The only other time I've come across the situation where a service is failing to start is because something else has been configured to use the same port (or that you have tried to change the port number on the http service and this is now clashing with a pre-existing service). However, I would have expected you to see an error in the GUI when you tried to save it.

           

          Sorry I couldn't be of more use to you, but it does sound like contacting support is your best (and fastest) option in this case.

           

          -Phil.

          • 2. Re: Problem with http crossing the firewall
            maitane

            Hi Phil,


            Thanks very much for your quick response.

             

            We haven´t changed anything, the cluster it´s been working this way since September 2011.
            We´ve already opened a ticket with support. Just one more thing you maybe could help us with,
            We´re trying to collect the http daemond logs. Could you tell us where can we find them?


            Thanks very much for your time and help.
            Best regards.

            • 3. Re: Problem with http crossing the firewall
              PhilM

              If you have created a ticket on the customer portal, there's nothing stopping you from then giving them a call in order to get things moving along.

               

              I don't know where in the world you are, but here in the UK there are two options - either the international toll free number 00800 6247 7463 or the direct US contact number +1 651 628 1500.

               

              Most of the log files are located in the /var/logs directory on the appliance, but as the detail you included in your original post suggested that the httpp process is core dumping, the .core file is probably going to be of greatest use to them.

               

              There is a "find" command that could be used, but it not one I've managed to master over the years.

               

              Another option (though not quite so elegant) is to cd back to the root directory and then run the following:-

               

              du -a | grep core

               

              The output includes all files and directories where the string "core" is included, but it will also find your .core files.

               

              Of course, you could subsitute "core" with any other string (e.g. httpp) if you wanted to search for anything else.

               

              -Phil.