5 Replies Latest reply on May 11, 2012 9:16 AM by PhilM

    Unexpected Inconsistency run fsck manually HELP!

      Hi...I am running an older version of Sidewinder 6.1.2.06.   Somehow a configuration change got corrupt and when I tried to reboot I receive the following error message.

       

      It boots to the # prompt and I get this....

       

      Unexpected inconsistancy run fsck manually

      The following File system had unexpected inconsistancy /dev/ramir0e

       

      I have run the ind Kern /sbin/fsck -p command... this does not work

      I have also tried to run fsck -y and it will not fix it.  Sometimes it tells me access denied.

       

      Can someone please help.

       

      Thanks

      Mike

        • 1. Re: Unexpected Inconsistency run fsck manually HELP!
          PhilM

          Mike

           

          I hate to be the bearer of unpleasant news, but there is the distinct possibility that the hard drive is close to the point of no return (if it isn't already so) and the age of your system is going to make obtaining official support somewhat tricky. 6.1.2.xx went end-of-life over 2 years ago (31st Dec 2009) and it is likely that because of the age of the software the physical hardware appliance is likely to be outside of the warranty window also.

           

          On the occasions where I have encountered this situation, I have found that it is necessary to run fsck more than once. I normally run the command with the "-y" option, which means you can leave it running while you get on with other things.

           

          It would sometimes take 4 or more cycles before the command reported no errors, and then I would run it a further time - just to be certain.

           

          However, if you run the command more times than that and you are still getting errors then, I'm sorry to say, you may have a failed unit.

           

          There are a couple of real-live McAfee support engineers on this forum (though as they are based in the US, they won't be around for another 4 or 5 hours) and they may be able to suggest something different.

           

          -Phil.

          • 2. Re: Unexpected Inconsistency run fsck manually HELP!

            Thanks Phil...

             

            When I ran fsck -y  it runs but does not change or fix anything.  Almost like it is read only.  Am I doing something wrong?

             

            I go into /dev  and then run it. Do I have to unmount?

             

            Thanks

            Mike

            • 3. Re: Unexpected Inconsistency run fsck manually HELP!
              PhilM

              Mike - it has been quite some time since I've needed to do this on a v6 appliance and the underlying architecture in v7 & v8 is different.

               

              Strictly speaking, because the system is failing I'd guess that it is booting into the administrative kernel, but maybe it isn't doing so in quite the right way in order to be able to run fsck. It's either that or, as I have mentioned previously, that the failure is just a little bit too catastrophic for you to recover from.

               

              The v6 Admin Guide has the following instructions for booting explicitly into the admin kernel:-

               

              You must be in the Administrative kernel to perform certain system

              maintenance tasks such as installing software or creating a full system

              backup. Follow the steps below to boot the system to the

              Administrative kernel when your Sidewinder G2 is powered OFF.

              Important: When you are in the Administrative kernel, all network connections are

              disabled and Internet services are not available. Type Enforcement is also disabled.

               

              1. Attach a keyboard and monitor directly to your Sidewinder G2.

              Note: If your system has multiple keyboard/monitor connection ports, you must

              attach the keyboard and monitor into the same keyboard/monitor connection port

              pair (that is, attach both items either to the front connection ports or the back

              connection ports).

               

              2. Turn the Sidewinder G2 ON by pressing the power button.

               

              3. When the “Booting Sidewinder Operational kernel” message appears,

              press any key (excluding Esc) to interrupt the boot sequence.

              The number sequence 4, 3, 2, 1, 0 is displayed as the Operational kernel

              is booting. Press any key before the 0 appears. A Boot: prompt then

              appears.

               

              4. Enter the following command:

              bsd.sw.admin -w

               

              5.Press Enter when asked whether to check and mount all file systems.

              The system prompt will appear. At the system prompt, you can perform

              any administrative tasks that require the Administrative kernel.

               

              Note: If you have enabled authentication for the administrative kernel, you will be

              prompted to log in before the system prompt appears.

               

              6. When you have finished working in the Administrative kernel, reboot or

              shut down the system.

               

              Note: See “Rebooting or shutting down using a command line interface” on page 3-

              4 to reboot or shut down the system from a command line interface.

               

              From here, try the fsck command again. I've found the following specific reference to it in the admin guide also:-

               

              What to do if the boot process fails

               

              Boot failure may be caused by the fsck command. This command is

              run as part of the system boot process. If this command fails, the

              Sidewinder G2 will not boot properly. If the boot process fails, you

              will need to attach a keyboard and monitor and repower the system.

              If you see a # prompt (indicating that the fsck command failed), type

              the following at the # prompt to fix any disk problems:

               

                   ind Kern /sbin/fsck -p

               

              Then restart the system by entering shutdown -r now at the

              command prompt.

               

              As previously mentioned, the advice I was always given was to run fsck over and over until I received two consequtive "everything is OK"-type responses. However, if after 6 or more iterations, the command is still coming back with errors then the hard drive may be too far gone for recovery to take place.

               

              -Phil.

              • 4. Re: Unexpected Inconsistency run fsck manually HELP!

                Thanks Phil!  I think I brought it back from the dead. It took 7 times but it seems to be stable for now. 

                 

                I just use this firewall on a test network and didn't want to have to shell out for support on something this old.

                 

                Thanks for your help and support.

                 

                Mike

                • 5. Re: Unexpected Inconsistency run fsck manually HELP!
                  PhilM

                  Glad you've made progress

                   

                  Might be a good idea to take a full config backup and re-image the appliance as this may help with stability.