8 Replies Latest reply on Jun 21, 2016 1:44 PM by ipatel18

    Can't remove Safeboot MBR during automated O/S refresh

      My organization's desired strategy for upgrading to Win7 is rather unique.  The process needs to be completely automated.  They want to kick off the O/S refresh process from within WinXP.  They have built a 64-bit WinPE ISO which includes the necessary Safeboot drivers to allow them to boot into WinPE without using an actual CD.  Here's where things get weird: They don't want to preserve the encryption or decrypt the drive; rather, they want to just format the disk and lay down the new O/S.  The problem is that when they do this, they're not overwriting the MBR, so when they try to boot into Win7, they get "MIssing Operating System".  They say they have tried many different 3rd party MBR-editting tools, but none have worked.  It is as if the Safeboot MBR is "locked" and cannot be overwritten.

       

      Do you have any advice on how we can get rid of the Safeboot MBR without using any interactive tools?  Keep in mind that we're using a 64-bit WinPE environment, so legacy utilities such as fdisk.exe are not an option for us.

       

      Thanks in advance!