4 Replies Latest reply on Dec 9, 2012 10:52 PM by Nishantha_R

    "Failed to get the product information." in McScript_error.log

    malware-alerts

      Running ePO 4.6.2 (repost)

      McAfee agent 4.6.0.2292

      VSE 8.7 Patch 5

       

      I seem to have a few endpoints constantly reporting the wrong DAT to ePO.

       

      For example, an endpoint will be up-to-date on DAT and engine (confirmed by looking locally at the avvscan.dat, avvclean.dat and avvnames.dat files as well as the "about" box in VSE.) but yet report an older DAT to ePO.

       

      When I run a product update task, the agent will report that the products are already running the latest engine/DAT (which also confirms the endpoint does have the latest DAT/Engine).

       

      In trying to fix this, I've tried:

       

      1- WakeUp call with "Full props"

      2- Delete the endpoint from ePO and let it repopulate when the agent connects again

      3- Uninstall/reinstall VSE 8.7 P5.

       

      Looked at the Mscript.log (and McScript_error.log) and see a lot of the following:

       

      2012-05-07 14:48:04          E          #8268          RcFile          Error trace:

      2012-05-07 14:48:04          E          #8268          Thread           [Main thread]->

      2012-05-07 14:48:04          E          #8268          SessMgr           [initialize]->

      2012-05-07 14:48:04          E          #8268          SessMgr           [loadResources]->

      2012-05-07 14:48:04          E          #8268          SessMgr           [loadResourceFile]->

      2012-05-07 14:48:04          E          #8268          RcFile           [LoadLibrary,1009/MueRes_InUse.dll]->

      2012-05-07 14:48:04          E          #8268          RcFile            error 126: The specified module could not be found.

      2012-05-07 14:48:04          E          #8268          RcFile          Error trace:

      2012-05-07 14:48:04          E          #8268          Thread           [Main thread]->

      2012-05-07 14:48:04          E          #8268          SessMgr           [initialize]->

      2012-05-07 14:48:04          E          #8268          SessMgr           [loadResources]->

      2012-05-07 14:48:04          E          #8268          SessMgr           [loadResourceFileUsingCurrentLocale]->

      2012-05-07 14:48:04          E          #8268          SessMgr           [loadResourceFile]->

      2012-05-07 14:48:04          E          #8268          RcFile           [LoadLibrary,1009/MueRes_InUse.dll]->

      2012-05-07 14:48:04          E          #8268          RcFile            error 126: The specified module could not be found.

      2012-05-07 14:48:08          E          #8268          ScrptExe          Error trace:

      2012-05-07 14:48:08          E          #8268          Thread           [Main thread]->

      2012-05-07 14:48:08          E          #8268          SessMgr           [SessionManager::runScript:C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\UpdateMain.McS]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Executing section ScriptMain]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [CallIf]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Executing section StartUpdateProcess]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Call]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Executing section DetectInstalledProductsAndUpdate]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Call]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Executing section GetDetectionScripts]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Call]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Executing section FindAndExecuteDetectionScripts]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [LoopIf]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Executing section EnumerateThroughProductIDList]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [LoopIf]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Executing section EnumerateThroughFile]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Call]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Executing section ExecuteDetectionScript]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Line 599:  RunScript dwRet = C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Current\VSCANDAT1000\V2datdet.mcs, ScriptMain]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Executing section ScriptMain]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [LoopIf]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Executing section EnumerateThroughProducts]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Call]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Executing section DoesProductNeedUpdate]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [CallIf]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Executing section SetInstalledVersionsUsingRegistry]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Call]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [Executing section SetInstalledVersions]->

      2012-05-07 14:48:08          E          #8268          ScrptExe           [GetProductInfo]->

      2012-05-07 14:48:08          E          #8268          ScrptExe            Failed to get the product information.  Setting usingEarlyRelDats to FALSE

       

       

      Did some digging around in the McAfee KBs as well as here and could not come up with a solution.

       

      Any help appreciated.