3 Replies Latest reply on Apr 29, 2013 8:01 AM by stuart153

    Webreporter and Java issues

    krmason

      Hi,

       

      We installed WebReporter with desktop Web Filtering and I am finding that the Webreporter product is using 60% of my server CPU with Java.exe.  It is very slow to respond and we have been having the same issue for 3 weeks.  Today, when I tried to launch the application it will not launch at all saying there are DLL files missing.

       

      It seems this product only works if there is a light load but as soon as you put any strain on it, it kills the server and crashes continually.  Anyone else experiencing this issue?

       

      Ken Mason

        • 1. Re: Webreporter and Java issues
          asabban

          Hi Ken,

           

          there are bigger installations of Web Reporter out there, so generally Web Reporter should be able to take more than only light load. Since this problem seems to be very specific for your installation I would like to recommend to file an SR with support to have them analyze the installation and environment to find out what is going on.

           

          Best,

          Andre

          • 2. Re: Webreporter and Java issues
            sroering

            Sometimes the java process with high CPU usage can occur if you are sending real-time data without a log source configured.  Examples of products that can send real-time log data is McAfee Firewall (Sidewinder), SmartFilter, and Bluecoat.  So if you are sending real-time log data, make sure you have a log source with the correct IP address for each device.

             

            You should make sure the Web Reporter server has at least 2 GB of RAM, and then give the Web Reporter process 1GB. Administration > Tools > Performance.  There is a noticable difference in the GUI responsiveness between 1GB and the default 512MB.

             

            Regarding the missing DLL files, that should never happen. I don't think the installer will give you a repair option if you try to install over the top. But you could follow this KB to backup all your data, then uninstall and reinstall. It is written for upgrade recovery, but the general idea is the same for you.

             

            https://kc.mcafee.com/corporate/index?page=content&id=KB69689

            • 3. Re: Webreporter and Java issues
              stuart153

              "You should make sure the Web Reporter server has at least 2 GB of RAM, and then give the Web Reporter process 1GB. Administration > Tools > Performance. There is a noticable difference in the GUI responsiveness between 1GB and the default 512MB."

               

              Our CPU was running at 100% and wasn't processing any logs and logging on to the Web Reporter console was ridiculously slow.  Checked the setting mentioned above and we were still running with the default value of 512MB.  Upped this to 2GB (we've got 8GB on a 64bit OS) and sat back for a couple of hours to let it process the backlog of events.

               

              All looking good now.  Logging on to Web Reporter console is fine, no lag at all now.  Checking the database statistics, our total log records have jumped from 11million to 42million !  After it worked its way through the big back log, the CPU usage on the server is pretty non-existent now - just ticking over nicely.