6 Replies Latest reply on Apr 4, 2012 2:36 PM by Aen

    Query to find Antispyware module

      I need to get a query to see what systems have AntiSpyware module and ones that do not.  Anyone got one?  Having a very hard time trying to get the module rolled out to all of my systems.  I got about 1000/4700 nodes

       

      I can set it to try all machines, but it has a cap of 999, and most of those already have it.  So i need to narrow down my deployment.

        • 1. Re: Query to find Antispyware module

          Anyone?

          • 2. Re: Query to find Antispyware module
            andrep1

            I've made this up for you. ASE version less than 8.7, system is managed and max systems=999

            This query works in ePO 4.6.2 and should work with other version.

            I hope this is what you are looking for.

            Cut and paste the xml below in a <filename>.xml , then in Query do and import definitions

             

            <queries>

            <query>

              <name language="en">managed systems with ASE ver lt 8.7 (max 999 systems)</name>

              <description language="en"></description>

              <property name="target">EPOLeafNode</property>

              <property name="tableURI">query:table?orion.table.limit=999&amp;orion.table.order=asc&amp ;orion.table.order.by=EPOLeafNode.NodeName&amp;orion.table.columns=EPOLeafNode.N odeName%3AEPOProdPropsView_ANTISPYWARE.productversion%3AEPOProdPropsView_VIRUSCA N.productversion%3AEPOLeafNode.LastUpdate</property>

              <property name="conditionURI">query:condition?orion.condition.sexp=%28+where+%28+and+%28+ version_lt+EPOProdPropsView_ANTISPYWARE.productversion+%228.7%22+%29+%28+stateEq +EPOLeafNode.ManagedState+%22managed%22+%29+%29+%29</property>

              <property name="summaryURI">query:summary?orion.sum.query=false&amp;orion.query.type=tabl e.table</property>

            </query>

            </queries>

            1 of 1 people found this helpful
            • 3. Re: Query to find Antispyware module

              I think i need to update my epo from 4.6.0 to 4.6.2.  I get: The query could not be imported because the uploaded file is either corrupt or in an unexpected format. Click "OK" to return to the "Queries" page.

               

              Thanks for the info and i will update my epo server.

              • 4. Re: Query to find Antispyware module
                andrep1

                Here's the original file...

                • 5. Re: Query to find Antispyware module

                  I probably need to upgrade.  this is what i get:

                  Query Name:managed systems with ASE ver lt 8.7 (max 999 systems)
                  Result Type:Managed Systems
                  Chart Type:Table
                  New name:

                  The query could not be imported: The table for a query criteria column does not exist: EPOProdPropsView_ANTISPYWARE.productversion.

                   


                  Thanks though, i will use it as soon as i upgrade.  Thanks again! you are awesome

                  • 6. Re: Query to find Antispyware module

                    Ok, so i am upgrading everything from VSE 8.7i to VSE 8.8.  I keep seeing the antispyware module going down on installs and did not see a newer version of the Antispyware out on the site.  I was getting slightly concerned by this and the reason why i want the query to find the machines that need it to focus my push of antispyware.

                     

                    Finally just called support and antispyware is already built into VSE 8.8 and will not show up seperately.  Thus, i have wasted DAYS of my time trying to figure this out.

                     

                    Since i am getting rid of all VSE 8.7, antispyware module is useless for me LOL

                    1 of 1 people found this helpful