9 Replies Latest reply on Mar 29, 2012 1:03 AM by chris_itk

    Extension and ScanVirus installation problem

      Hello guys,

       

      a few days ago I have started my epo 4.6 career.

       

      I have afew question and/or problems as follows:

       

      I want to update my Software, Extensions...

       

       

      Extension installed:

      VIRUSSCAN8800 8.8.0.169

      VIRUSSCANREPORTS 1.2.0.136

       

      I want to update to VIRUSSAN8800 8.8.0.191, but receiving the following error:

      ExtensionError.JPG

       

      And our Clients have the following config:

      Agent 4.5.0.1852

      Virus Scan 8.8.0.777

       

      Agent Update to 4.6.0.2292 is working fine with my Deployment Task

      But if want to deploy VirusScan 8.8.0.849 it does not work! Only if I make a sparate Deinstall Task and an InstallTask

      Deinstall Task for 777 ist working, but I have received the following error: Status Failed (instead of this, the ScanVirus is removed) Deinstallation succsessfull <br> EPOAGENT3000 Installation failed <br>HOSTIPS_8000 failed <br>VIRUSSCAN8800 Installation failed

       

      After the deinstall I can deploy the 849, but only if I remove the 777 from the Default Deployment Task (assigned to My Organization)

      Is this normal? Is there a possibility to upgrade without deinstall 777 (eg. cmd...)

       

      Thank you in advance for you help!

      Regards Chris

        • 1. Re: Extension and ScanVirus installation problem
          Laszlo G

          Hi chris_itk, I think you cannot install full version of virusscan over an existing one if it's same version (even if repost patch is different), that's why you need to remove 777 before istalling 849.

           

          Instead of this you need to deploy only patch 1 for virusscan 8.8 (it upgrades from 777 to 849)

           

          As for this extension you have first to have a look under e:\Program Files\McAfee\ePolicy Orchestrator\Server\Extensions\installed\VIRUSCANREPORTS and se how many folders you have there

          1 of 1 people found this helpful
          • 2. Re: Extension and ScanVirus installation problem

            In my Repository I have the following Patch, last line (Evaluation Folder), but I can't choose them in my Deployment Task:

            ExtensionError3.JPG

            ExtensionError4.JPG

             

             

             

             

            Following Folder in VIRUSSCANREPORTS:

            ExtensionError2.JPG

             

            Thank you for your help

            • 3. Re: Extension and ScanVirus installation problem
              Tristan

              To update VSE 8.8 from patch 0 to patch 1 you need to use an agent 'product update' task not a 'product deployment' task

              update.jpg

              1 of 1 people found this helpful
              • 4. Re: Extension and ScanVirus installation problem

                I have created the Update Task:

                ExtensionError5.JPG

                But I can't choose ScanVirus if I want to run client task now:

                ExtensionError6.JPG

                 

                And do you know a solution for my extension problem, see screenshot two posts below?

                 

                Thank you again for your help

                • 5. Re: Extension and ScanVirus installation problem
                  Tristan

                  How are you checking in the Extensions?

                   

                  Are you doing them manaully by checking in the ZIP file "VIRUSCAN8800(191).zip" or are you using MENU -> SOFTWARE -> SOFTWARE MANAGER in ePO?

                   

                  Also check the contents of

                   

                  e:\Program Files\McAfee\ePolicy Orchestrator\Server\extensions\installed\VIRUSCAN8800

                   

                  Message was edited by: Tristan on 28/03/12 13:38:02 IST
                  • 6. Re: Extension and ScanVirus installation problem

                    I have already tried both solutions, when I'm checking in the ZIP I received the message above in the opening post!

                    If I try the software manager I'm receiving the following message:

                    ExtensionError9.JPG

                    ExtensionError7.JPG

                     

                    Folder in VIRUSSCAN8800

                    ExtensionError8.JPG

                     

                    Should I remove the extension and after that install the new one?

                    • 7. Re: Extension and ScanVirus installation problem
                      Tristan

                      Try removing the old extension before installing the new one (possibly try removing both the VSE and the reports one as well)?

                       

                      If the 8.8.0.169 says that it's installed but you don't get the list of VSE tasks in the 'run task now' screen then it would suggest that the .169 extension is corrupt or only partly installed.

                      • 8. Re: Extension and ScanVirus installation problem

                        Now it is working, I have removed the extension and renamed the Folders in VIRUSSCAN8800 and VIRUSSCANREPORTS

                        After that I have checked in the VSE880LMLRP1.zip

                         

                        The Patch 1 is only working with the Update Task if I move him to the current Repository!

                        Why is that so, is there a possibility to test Update Task  with Patch 1 in the evaluation Respository?

                         

                        Thank you very much for your help and fast answers

                         

                        Kind regards

                        Chris

                        • 9. Re: Extension and ScanVirus installation problem

                          Hello,

                           

                          could somebody tell me why I can only uprgade my extensions if I remove the old ones (including deleting Folder on E:\....extensions)

                           

                          as you can see above, there was the problem with the ScanVirus Extensions installation! They are working but e.g. there is no folder in path E:\Program Files\McAfee\ePolicy Orchestrator\Server\extensions\installed\VIRUSSCAN8800 and \VIRUSSCANREPORTS

                          As you can see on the screenshots there are only the folders I have renamed to run a working installation of VSE880LMLRP1.zip

                          ExtensionError10.JPG

                          ExtensionError11.JPG

                          Should there be no folders for the new extensions (e.g VIRUSSCANREPORTS\1.2.0.136 and VIRUSSCAN8800\8.8.0.191)???

                           

                          And one other Question from above:

                          The ScanVirus Patch 1 is only working with the Update Task if I move him to the current Repository!

                          Why is that so, is there a possibility to test Update Task with Patch 1 in the evaluation Respository?

                           

                          Thank you all in advance for your help!!!