3 Replies Latest reply on Mar 28, 2012 2:07 PM by relayer77

    Problem checking in Viruscanreports extension in 4.5

    relayer77

      We are running  ePO 4.5 patch 3, trying to check in viruscanreports extension version 2.1.0.136.

       

      It's been a long a difficult process of troubleshooting. The extension did not install properly the first time, and it errored out on the 2nd try with a statement that it was already partially installed.

      A look into the server\extensions\installed folder and the server\conf\catalina\localhost\ folder showed that all the folders and files that SHOULD have been there WERE there. (We have another build that is identical and used it to verify this, after successfully installing the extension in the other server).

       

      I came to the forums and found a case where someone had trouble with a partially installed instance of the GSD7reports extension. The correct answer, which solved that problem, was to :

      1) shut down ePO services

      2)run a query in SQL on the ePO db that went like this: 

      DELETE FROM OrionExtensions WHERE Name='GSD7REPORTS'

      Go

       

      3) go the folders I mentioned above and remove the GSD related directories/ files.

       

      So, I adapted this procedure , substituting "VIRUSCANREPORTS' FOR GSD7REPORTS' and I deleted the VSE directories instead of the GSD ones. The query ran successfully , and the removals of folders and files seemed clean.

       

      I then tried to install again, and it spun for 45 minutes and failed. I didn't get the 'partiallly installed' error, but it just didn't install the extension.

       

      I started playing around with services, reboots,  ran the maintenance task in MGMT studio,  even tried backing out stuff out of the extensions in ePO , to include HIPs 7 patch 9 extensions and packages, all for naught.

      I'm stumped.

       

      Any help would be appreciated!

        • 1. Re: Problem checking in Viruscanreports extension in 4.5
          Laszlo G

          Hi relayer77, you should first have a look on what is now installed or not.

           

          Can you see under VirusScan extensions if any report extension is installed?

           

          You should also have a look again at c:\Program Files\McAfee\ePolicy Orchestrator\Server\Extensions\installed\ and see if you have any VIRUSCANREPORTS folder (if it exists then look at folders inside it)

           

          With SQL Management Studio or SQL Management Studio Express have a look at the OrionExtensions table (dbo.OrionExtensions) if you have an entry with VIRUSSCANREPORTS extension and its version (if exists)

          • 2. Re: Problem checking in Viruscanreports extension in 4.5
            relayer77

            Problem solved. It turned out that we had to delete the Viruscan Enterprise queries that existed under menu | queries | Shared Groups | Viruscan Enterprise. For some some reason a (probably corrupt) query was blocking th

            e install.  At this point, i don't think any of the other troubleshooting steps we took were relevant or helpful. I hope this saves someone else some time.  I troubleshot this for about 15 hours, and now I'm ready for a nap.

            • 3. Re: Problem checking in Viruscanreports extension in 4.5
              relayer77

              @ulyses31,


              BTW, yesterday we, too, checked the db table 'orionextensions' and did verify that the requisite entry for viruscanreports was missing. Until we figured out the queries - related solution above, we were trying to figure out if there is a way to take that entry from a different db table and import it. Ever tried that successfully?

              Thanks again for the reply!