6 Replies Latest reply on Apr 9, 2009 8:35 AM by jmaxwell

    McAfee agent not communicating and dats not updating

      I am running ePO 3.6.1 on Win Sever 2003. We have about 200 workstations that connect back to our main office using cisco vpn clients.

      The clients are running MVE 8.0i patch 16 and WinXP SP2 (mostly, some are SP3). Agent version is 3.6.0.603

      I am having problems with a few of the workstations not contacting the ePO server. I have tried forcing uninstall of the agent with

      frminst /forceuninstall

      then reinstall with

      frminst.exe /install=agent /forceinstall /silent /siteinfo=c:\temp\sitelist.xml

      yet I still dont get any communication with the server. When I run "cmdagent /P /E /C " I get:

      Error:***Agent is not available to enforce policy.
      Error:***Agent is not available to enforce policy.
      Error:***Agent is not available to enforce policy.
      Error:***Failed to send command to ePO Agent ***

      On one of these machines, I have even completely uninstalled/reinstalled VSE and the agent with the same result.

      I have windows firewall exceptions setup for the agent and have them enforced via GPO.

      I noticed that the McAfee framework agent does not appear in the running services. When I try to install the agent, as administrator, using

      frminst.exe /install=agent /siteinfo=c:\temp\sitelist.xml
      I get this log file


      20090408093850 I #2116 Setup Ins START [frminst.exe /install=agent /siteinfo=c:\temp\sitelist.xml]
      20090408093850 I #2116 Setup Ins Windows 5.1.2600 Service Pack 2
      20090408093850 I #2116 Setup Ins Attempting to perform a setup operation
      20090408093850 E #2116 MPMutex Ins Error trace:
      20090408093850 E #2116 Thread Ins [Main thread]->
      20090408093850 E #2116 Setup Ins [Attempting to perform a setup operation]->
      20090408093850 E #2116 Cleanup Ins [Prepare for cleanup later]->
      20090408093850 E #2116 MPMutex Ins [CreateMutex,MCAFEE_FRAMEWORK_CLEANUP_INSTANCE]->
      20090408093850 E #2116 MPMutex Ins error 5: Access is denied.
      20090408093850 E #2116 MPMutex Ins Error trace:
      20090408093850 E #2116 Thread Ins [Main thread]->
      20090408093850 E #2116 Setup Ins [Attempting to perform a setup operation]->
      20090408093850 E #2116 Cleanup Ins [Prepare for cleanup later]->
      20090408093850 E #2116 MPMutex Ins [ReleaseMutex,MCAFEE_FRAMEWORK_CLEANUP_INSTANCE]->
      20090408093850 E #2116 MPMutex Ins error 6: The handle is invalid.
      20090408093850 I #2116 UI Ins Starting setup...
      20090408093850 I #2116 UI Ins Validating setup options...
      20090408093850 I #2116 Script Ins HKLM\SOFTWARE\Network Associates\TVD\Shared Components\Framework\Installed Path is not present. Therefore CMA is not installed.
      20090408093850 I #2116 Script Ins HKLM\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent is not present. Therefore the 2.x agent is not installed.
      20090408093850 I #2116 Script Ins Unable to get the FtpSite node from c:\temp\sitelist.xml
      20090408093850 I #2116 Script Ins The state of script is:
      20090408093850 I #2116 Script Ins Installed = FALSE
      20090408093850 I #2116 Script Ins ManagedMode = FALSE
      20090408093850 I #2116 Script Ins InstallFilesAndRegistry = FALSE
      20090408093850 I #2116 Script Ins InstallAgentRegistry = TRUE
      20090408093850 I #2116 Script Ins RemoveFilesAndRegistry = FALSE
      20090408093850 I #2116 Script Ins CleanupFiles = FALSE
      20090408093850 I #2116 Script Ins RemoveAgentRegistry = FALSE
      20090408093850 I #2116 Script Ins IncrementUpdaterRefCount = FALSE
      20090408093850 I #2116 Script Ins DecrementUpdaterRefCount = FALSE
      20090408093850 I #2116 Script Ins PutCmaIntoManagedMode = TRUE
      20090408093850 I #2116 Script Ins RemoveCmaFromManagedMode = FALSE
      20090408093850 I #2116 Script Ins ReplaceNaiRepositories = FALSE
      20090408093850 I #2116 Script Ins ReplaceEpoSite = FALSE
      20090408093850 I #2116 Script Ins ReplaceSiteList = TRUE
      20090408093850 I #2116 Script Ins Remove3xServerTasks = FALSE
      20090408093850 I #2116 Script Ins Remove2xAgent = FALSE
      20090408093850 I #2116 Script Ins RunHigherVersionedRemove = FALSE
      20090408093850 I #2116 Script Ins WaitForCmaToFinish = TRUE
      20090408093850 I #2116 Script Ins RunHigherVersionedSetup = FALSE
      20090408093850 I #2116 Script Ins NumberOfProductsUsingCMA = 0
      20090408093850 I #2116 Script Ins InstalledPath = '?8adString,605e0000,2043'
      20090408093850 I #2116 Script Ins TargetInstalledPath = 'C:\Program Files\Network Associates\Common Framework'
      20090408093850 I #2116 Script Ins DataPath = ''
      20090408093850 I #2116 Script Ins TargetDataPath = 'C:\Documents and Settings\All Users\Application Data\Network Associates\Common Framework'
      20090408093850 I #2116 Script Ins HigherVersionedSetup = ''
      20090408093850 I #2116 Script Ins FrameworkVersion = ''
      20090408093850 I #2116 Script Ins SiteList = 'c:\temp\sitelist.xml'
      20090408093850 I #2116 UI Ins Checking for necessary rights...
      20090408093850 I #2116 UI Ins Stopping processes if necessary...
      20090408093900 I #2116 Exec Ins Disable CMA service
      20090408093900 I #2116 Exec Ins Calculate counters
      20090408093900 I #2116 Exec Ins Set counters
      20090408093900 E #2116 Xml Ins Error trace:
      20090408093900 E #2116 Thread Ins [Main thread]->
      20090408093900 E #2116 Setup Ins [Attempting to perform a setup operation]->
      20090408093900 E #2116 Exec Ins [Setup execution]->
      20090408093900 E #2116 Exec Ins [Set counters]->
      20090408093900 E #2116 Xml Ins [useExistingFile,C:\Documents and Settings\All Users\Application Data\Network Associates\Common Framework\FrameworkManifest.xml,FrameworkManifest,(null),(null)]->
      20090408093900 E #2116 Xml Ins ReadBufferFromFile failed -44
      20090408093900 E #2116 UI Ins Error trace:
      20090408093900 E #2116 Thread Ins [Main thread]->
      20090408093900 E #2116 UI Ins There was an unexpected error during setup execution. See this log file for details: C:\DOCUME~1\superman\LOCALS~1\Temp\NAILogs\FrmInst_<computername>.txt