2 Replies Latest reply on Mar 22, 2012 8:56 AM by iainh

    Notification Message in Webgateway 6.9 - Can someone help please?

    iainh

      Hi folks,

       

      Hope someone can provide some insight into this problem,  I'm very new to this so please be gentle. Setup is as follows, main site has two 6.9 webgateways with one each at smaller sites. We have a PAC file on our main webserver which we point the staff browsers to get info on which servers they can use and which to failover to.

       

      On occasions certain website (we only had a couple) can be accessed but after clicking on links in the site the following message appears:

       

      Internal Requests Only

      You have used the McAfee Web Gateway as a proxy or as a Web server for an arbitrary request. You can only connect directly to McAfee Web Gateway for configuration purposes.

       

      Now if I point the browser to one of the webgateways instead of using the PC file and try again the site works fine.

       

      I'm at a real loss as to whats going on and would appreciate any assistance with this.

       

      Cheers

       

       

       

      Iain

        • 1. Re: Notification Message in Webgateway 6.9 - Can someone help please?

          I can't be sure in your specific instance, and I haven't run into it in a long time, but it may be related to AutoProxyResultCache.

          Then again, it may not. But it's worth exploring.

           

          Automatic proxy caching in Internet Explorer

          Webwasher uses a variety of techniques to control and secure incoming web traffic in the form of page redirection and JavaScript injection and transparent authentication. When using PAC files in conjunction with Internet Explorer, IE internally caches the proxy server's relationship with the destination web site that is being viewed. When Webwasher inserts block pages, coaching pages, advertising image replacements, proactive scanning script mitigation or uses Transparent Authentication with the built-in Authentication server, it hosts the injected files on its own interface on port 9999 (or others) whereas the proxied content is usually delivered via port 9090.

           

          Internet Explorer always uses the proxy server through which the first connection to a specific host name is made, regardless of the settings in the PAC file. If the response from the destination web site has port 9999 included code within the contents, or a transparent authentication does a redirect to 9094, subsequent requests for that site attempt to use that alternate port instead of the proxy port of 9090.

           

          When this condition occurs, the user sees symptoms of broken pages with graphics and style sheets not being loaded and error messages that say "Invalid Proxy Request". Other browsers do not exhibit these symptoms.

           

          This condition can be corrected by turning off the automatic proxy caching feature in IE. This is controlled by a registry entry of:

           

          HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings

           

          Value: EnableAutoproxyResultCache

          Type: REG_DWORD

          Data value: 0 = disable caching; 1 (or key not present) = enable automatic proxy caching (this is the default behavior)

           

          More information can be found here:

          http://support.microsoft.com/kb/271361/

          http://support.microsoft.com/kb/304112/

          • 2. Re: Notification Message in Webgateway 6.9 - Can someone help please?
            iainh

            Brilliant! Worked like a charm. Much appreciated

             

            Kind regards

             

             

            Iain