1 2 Previous Next 11 Replies Latest reply on Mar 20, 2012 3:47 AM by reucht

    FWS crashed - reinstall Agent doesn't work

      Hey all, so here's my story.

       

      A while ago we noticed few of our servers didn't update anymore. When checking one of the servers (let's call it XA1)and clicking "Update Now", it gave an error about how the McAfee Framework Service wasn't started. We checked services and indeed, it wasn't started. When trying to start it, it gives the generic FFFFF @95 error about the FrameworkManifest.xml. I tried deleting it first (after changing the settings in the console) and clicked update again, service still not running, still unable to start the service. Back to start. Then I replaced the manifest with one of a working server, but completely the same story.

       

      Fine, I said, I'll start from scratch. I uninstalled everything from XA1, resynced our AD domain, deleted the reg keys on XA1, removed everything "McAfeeey" and deployed the agent.

       

      Now in the Event Task Log on the EPO-server, it says task completed, but I can't pull up the log and when I look in the C:\Program Files (x86)\McAfee\Common Framework on XA1, all I see are folders LpcRT_xxxxxxx for every time I tried deploying the agent.

       

      I tried it from the EPO server, I tried it locally and manually. The only difference with a local install, is that it actually installs something, but it doesn't work yet.

       

      Anyone has any suggestions? Would be insanely grateful, our 6 server Citrix environment is not updated atm and our users can pull in enough viruses.

       

      Thanks

        • 1. Re: FWS crashed - reinstall Agent doesn't work

          Hi reucht,

           

          have you unistalled the MA via CMD (c:\program files\McAfee\common framewotk\frminst.exe /remove=agent) there is another option we have try to redeploy the McAfee agent from ePO console with the option enable "Install over the existing version"

           

          Pls follow this KB article

           

          https://kc.mcafee.com/corporate/index?page=content&id=kb57884&pmv=print

          • 2. Re: FWS crashed - reinstall Agent doesn't work

            Thanks for the reply, but I already found that KB and tried it like that, but to no avail.

             

            I have tried uninstalling via command line, I deployed agents from EPO with the "force over exisiting installation", no luck.

             

            I also tried deleting the Agent GUID from the registry, hoping that this would make a change, but also no luck.

            • 3. Re: FWS crashed - reinstall Agent doesn't work

              If I install it manually and locally, the Framework Service starts.

               

              But the McAfee icon doesn't show up in the system tray and in the EPO view, the server stays in the unmanaged state.

              • 4. Re: FWS crashed - reinstall Agent doesn't work
                Laszlo G

                Hi reucht, just try to remove existing McAfee Agent with the frminst /forceuninstall command and then download McAfee Agent from the ePO server and install the framepkg again.

                 

                This is located on your ePO server under C:\Program Files\McAfee\ePolicy Orchestrator\DB\Software\Current\EPOAGENT3000\Install\0409

                • 5. Re: FWS crashed - reinstall Agent doesn't work

                  I downloaded the Framepkg.exe from that location, copied it locally and ran it in windows and CMD-line, but the installation fails...

                   

                  I generated a new Framepkg.exe, but that one gives the same result.

                   

                  Message was edited by: reucht on 3/16/12 5:22:39 AM CDT
                  • 6. Re: FWS crashed - reinstall Agent doesn't work

                    The logfile from my last attempt:

                     

                    2012-03-16 11:30:11          I          #3416          Stub          Pkg

                    2012-03-16 11:30:11          I          #3416          Stub          Pkg          START [FramePkg.exe /ForceInstall /Install=Agent /Silent /InstDir="<PROGRAM_FILES_DIR>\McAfee\Common Framework"]

                    2012-03-16 11:30:11          I          #3416          Common          Pkg          CreateDirectory (C:\Windows\TEMP\mfeB125.tmp)

                    2012-03-16 11:30:11          I          #3436          Common          Pkg          CreateProcess (C:\Windows\TEMP\mfeB125.tmp\FrmInst.exe, /ForceInstall /Install=Agent /Silent /InstDir="<PROGRAM_FILES_DIR>\McAfee\Common Framework" /FramePkg /OriginalFramePkg="C:\Windows\FramePkg.exe" /Cleanup="C:\Windows\TEMP\mfeB125.tmp" /LOGDIR="C:\Windows\TEMP\McAfeeLogs" /EmbeddedUsername="" /EmbeddedDomain="" /EmbeddedPassword="")

                    2012-03-16 11:30:11          I          #2576          Setup          Ins          START [/ForceInstall /Install=Agent /Silent /InstDir="<PROGRAM_FILES_DIR>\McAfee\Common Framework" /FramePkg /OriginalFramePkg="C:\Windows\FramePkg.exe" /Cleanup="C:\Windows\TEMP\mfeB125.tmp" /LOGDIR="C:\Windows\TEMP\McAfeeLogs" /EmbeddedUsername="" /EmbeddedDomain="" /EmbeddedPassword=""]

                    2012-03-16 11:30:11          I          #2576          Setup          Ins          Windows 6.1.7601 Service Pack 1

                    2012-03-16 11:30:11          I          #2576          Setup          Ins          Running as System account, therefore no UI

                    2012-03-16 11:30:11          I          #2576          Setup          Ins          Attempting to perform a setup operation

                    2012-03-16 11:30:11          I          #2576          caShrLb          Ins          SOFTWARE\Network Associates\TVD\Shared Components\Framework is not present

                    2012-03-16 11:30:11          I          #2576          Setup          Ins          Legacy installed=0

                    2012-03-16 11:30:11          I          #2576          Setup          Ins          Installing version=4.5.0.1270

                    2012-03-16 11:30:11          I          #2576          Setup          Ins          Higher version installed=0

                    2012-03-16 11:30:11          I          #2576          OptSet          Ins          /forceinstall ignored, the agent is not installed

                    2012-03-16 11:30:11          I          #2576          Setup          Ins          C:\Windows\SysWOW64\msiexec.exe /i "C:\Windows\TEMP\mfeB125.tmp\MFEagent.msi" ADDLOCAL=Main,Agent TRANSFORMS=:1043.mst /q REBOOT=R /l+*v "C:\Windows\TEMP\McAfeeLogs\MFEagent.msi.2012.03.16.11.30.11.log" INSTALLDIR="C:\Program Files (x86)\McAfee\Common Framework" SITEINFO="C:\Windows\TEMP\mfeB125.tmp\SiteList.xml" PRESERVEREPOSITORIES=True FRMINSTLOGFILE="C:\Windows\TEMP\McAfeeLogs\FrmInst_VS-XENAPP1"

                    2012-03-16 11:30:13          I          #3436          Stub          Pkg          Running as a service, therefore not waiting for installation to complete

                    2012-03-16 11:30:13          I          #3416          Stub          Pkg          END 0

                    2012-03-16 11:30:27          E          #2576          Setup          Ins          Error trace:

                    2012-03-16 11:30:27          E          #2576          Thread          Ins           [Main thread]->

                    2012-03-16 11:30:27          E          #2576          Setup          Ins           [Attempting to perform a setup operation]->

                    2012-03-16 11:30:27          E          #2576          Setup          Ins           [Run MSI]->

                    2012-03-16 11:30:27          E          #2576          Setup          Ins            error 1603: Fatal error during installation.

                    2012-03-16 11:30:27          I          #2576          Thread          Ins          Exit program

                    2012-03-16 11:30:27          I          #2576          Setup          Ins          END 1603

                    2012-03-16 11:30:27          I          #5280          Main          Cle

                    2012-03-16 11:30:27          I          #5280          Main          Cle          START [3904 /LOGDIR="C:\Windows\TEMP\McAfeeLogs" "C:\Windows\TEMP\mfeB125.tmp"]

                    2012-03-16 11:30:27          I          #5280          Main          Cle          Delete on reboot: C:\Windows\TEMP\mfeB125.tmp\cleanup.exe

                    2012-03-16 11:30:27          I          #5280          Main          Cle          Delete on reboot: C:\Windows\TEMP\mfeB125.tmp

                    2012-03-16 11:30:27          I          #5280          Main          Cle          END 0

                     

                    I'm running McAfee Agent 4.5.0 Patch 1, supposedly this issue was fixed in version 4.0. Left-overs from previous installations. Only thing I can't delete from the registry are the Legacy GUID's?

                    • 7. Re: FWS crashed - reinstall Agent doesn't work
                      Laszlo G

                      Are you using command line parameters or just double-clicking on the framepkg?

                      • 8. Re: FWS crashed - reinstall Agent doesn't work

                        Hi reucht,

                         

                        Is that XenApp server have you enabled the installation mode

                         

                        change  user /install

                        • 9. Re: FWS crashed - reinstall Agent doesn't work

                          Hi,

                           

                          Could you pls post the  MFEagent.msi.log

                          1 2 Previous Next