1 2 Previous Next 10 Replies Latest reply on Apr 7, 2009 12:03 PM by rdeluca

    VS 8.5i Unable to access Registry Keys

      I am currently using VS enterprise 8.5i, as per my University's requirements for internet access, well I'm trying to use it at least. I am trying to uninstall it and all its components and then reinstall it. It was missing some components, so I figured a repair would fix it. Not so, then I tried to uninstall, and I still continued to fail due to the following issue:

      When i try to uninstall, reinstall, repair, or update in any way McAfee(r) Virus Scan Enterprise Edition 8.5i I get the following error:

      Error 1402.Could not open key:
      HKEY_LOCAL_MACHINE\SOFTWARE\MCAFEE\DESKTOPPROTECTION\TASKS. Verify that you have sufficient access to that key, or contact your support personnel.

      McAfee Virtual Technician did NOTHING to fix the problem either.

      I went into the registry and tried to add permissions to that folder, but it told me Access Denied: That I didn't have permission to GIVE myself permission. I am the adminstrator and only user on my personal laptop computer.

      Oh, and of course I'm running Vista, which makes everything more difficult :rolleyes:
      Any help would be very great.
      Thanks.
        • 1. RE: VS 8.5i Unable to access Registry Keys
          jmaxwell
          It's McAfee itself that's protecting the registery and files - it thinks what you are attempting is similar to some malware - you need to go into the AV and disable the protection on the AV Policy settings.

          Jim
          • 2. RE: VS 8.5i Unable to access Registry Keys


            Ooops.

            Is there any way to do this without going through AV?

            Cause right now that's basically all that's left of McAfee on my computer, those registry files.

            I tried cleaning my registry manually of McAfee, and as far as I can tell that's all that's left...

            Where does it store these policy settings, so I can either duplicate a similar file, or change what's left of it on the registry?

            x-|


            Edit: and I cant RE-install it to change the policies, because of those protected registry files. I done screwed it all up, eh?
            • 3. RE: VS 8.5i Unable to access Registry Keys
              jmaxwell
              Could be - LOL ;)

              You could try following this process and see if you've missed anything....

              https://kc.mcafee.com/corporate/index?page=content&id=KB50602&actp=search&search id=1238064022563

              Jim
              • 4. So frustrated
                Alright -
                Someone give me something to help me here... Please... Maybe give me a .zip file containing any files I might need?

                I can't touch ANYTHING in this registry, but I was able to delete EVERY SINGLE OTHER file that

                https://kc.mcafee.com/corporate/index?page=content&id=KB50602&actp=search&search id=1238064022563

                told me to delete, and take out. BUT I wasn't able to do the commands that it asked me to using VirusScan or McShield (that unfortunately probably were the ones that unprotected the keys i can't delete) because it was already unusable when I started to try to uninstall everything.

                THIS
                # [HKEY_CURRENT_USER\Software\McAfee\DesktopProtection]
                is the only thing left that I can't do anything with.
                Is there some backup or something that you can upload for me, a registry backup for whatever the virusScan registry file that blocks this key being changed?
                Something? Anything?

                Isn't there a big problem somewhere in the system if EVERYTHING can be deleted except that "protection" and that now i can't reinstall the McAfee software because the "Protection" is STOPPING me?

                EDIT: Perusing through the knowledge base I came across this article:

                KB60857
                -----------
                Cause
                VirusScan Enterprise (VSE) Access Protection must be activated when installing VSE.
                Solution

                1. Reinstall VirusScan Enterprise and activate Access Protection.
                2. Install AntiSpyware Enterprise.
                -------------

                That's all well and good, but I CANT install access protection alone, because it throws me the same Error 1402. because it was trying to access the same RegKey
                • 5. RE: So frustrated
                  Or rather than you uploading some files (although that would be preferred, since I dont have immediate access to another computer I can do this with)

                  If I were to install this onto another computer, and then copy files over and change some values so that I may release the protection over those DESKTOPPROTECTION keys?

                  Thanks... sad
                  • 6. RE: So frustrated
                    rdeluca,

                    If the only thing remaining is the registry entry, then it's probably a Vista issue.. Have you disabled User Account Control (UAC)? (Control Panel/Classic Style-User Accounts-Select "Turn User Account Control On or Off".)

                    And once that's done, try changing the permissions by using the "other" registry editor.. First, start in Safe Mode, then in the "Run" line, type "regedt32". Once there, navigate to the "HKEY_LOCAL_MACHINE\SOFTWARE\MCAFEE" folder, RIGHT click on the McAfee folder/key, choose "Permissions", then make sure your user has "Full" permissions. Close the registry editor.

                    Once done, you should be able to delete the problem entry.

                    Hope this helps.

                    Grif
                    • 7. RE: So frustrated



                      Eh, it didn't work, and I was mistaken, it seems though i have some more. x-( I'm going to relook through the article... BUT I can't do a few of the steps...so I'm going to wait for some sort of response...

                      any more advice to uninstall/unprotect those files?
                      SHOULD i just continue through and delete all registry files with McAfee in it?

                      (I did a system restore to before i deleted MOST of the registry things, but I still dont have the ePolicy registry key)

                      I... Is there a faster way for me to talk with someone to help me through this?
                      I just... dont have half the files that half of the KB articles tell me to do something with and I'll post any info you need to help me fix this.

                      Thanks. (sorry for the babbling, it's going on 3 days of trying to fix this and it's driving me a bit nutty)
                      • 8. online supprt
                        IF you have internet access goto http://service.mcafee.com/default.aspx

                        if you have to leave the school netowrk to get online try an internet cafe with a free connection then goto support. they will have the sofware you need or the knowledge to fix you up.

                        Just read the note above about access to technical support ... tech support should be able to point you at the tools you need and/or tell you what to do at the least.

                        you might also check to see if you can use a different mcafee product (trial version) to get access to your school network that has online mcafee support. The trial version will let you know if you have to have that specific software or just that software or better from mcafee.

                        If you can use that different software buy it and away you go.
                        • 9. RE: VS 8.5i Unable to access Registry Keys



                          Okay, I did a partial reinstall by copying over MOST files needed and MOST registry entries from my gf's computer after installing it on there, where are those AV Policy settings exactly?

                          The On-access-scan thing?
                          Or is it in the Virus Scan console - the access protection thing? Because that's disabled on my computer, AND when I enabled it on the other 'test' computer (my gf's computer) the registry files weren't locked (They were still at least VISIBLE, i can't even click on the folder without getting an access denied error) like mine were/still are....)

                          EDIT:
                          Uhm. i suppose i could try gaining permissions again in safe mode, but I'm really really doubtful at this time that THAT is the problem, because at this time I'm still getting the access denied thing when I try to apply permissions too...
                          1 2 Previous Next