1 2 Previous Next 10 Replies Latest reply on Feb 29, 2012 9:57 AM by DeanBaker

    Upgrading to ePO 4.6.2 Problem

    DeanBaker

      Hi All.

       

      I just downloaded and tied installing the new ePO 4.6.2 upgrade but I have hit a problem. At the stage where you enter your SQL logon credentials it fails. I'm using the same user I have for all other upgrades. The user is a domain user as we don't use the sa account. The user I am using is in the dbo user for the DB in SQL 2005. After entering my details and clicking next is says the installer is validating my credentials and then flicks over to a screen saying "The wizard was interrupted before McAfee ePolicy Orchestrator could be completely installed".

       

      Are there any log files I can look at to see whats failing?

       

      Thanks.

      Dean

        • 1. Re: Upgrading to ePO 4.6.2 Problem
          andrep1

          I know this might sound silly but I've had the same problem with 4.6.0 and 4.6.1 and we never found a way to fix it. Repetition is the key, it would eventually work after a few times (4-5). And be sure you run the install as administrator.

           

          On win2k8, install logs will be there if you want to have a look.

          c:\Users\Administrator\AppData\Local\Temp\McAfeeLogs

          Replace administartor with whichever user you were logged in during the install.

           

          I would suggest you raise an SR with McAfee for this one...

          • 2. Re: Upgrading to ePO 4.6.2 Problem
            DeanBaker

            Thanks for the reply Andre.

             

            Well I am on my 11th attempt now and it's still not working. I'm using win2k3 so any idea where the logs would be? I've checked "C:\Documents and Settings\<logged on user>\Local Settings\Temp" and nothing. Also nothing in "C:\WINDOWS\Temp".

             

            The user is a domain admin but I have also tried running as my user (also a domain admin) and the local administrator.

             

            I think ill have to log this with them as you suggested. I'll let you know what the outcome is.

             

            If any one else has any suggestions please reply.

            • 3. Re: Upgrading to ePO 4.6.2 Problem
              andrep1

              You can search your c: drive for EPO460*.* named files

              • 4. Re: Upgrading to ePO 4.6.2 Problem
                DeanBaker

                I just found them by chance. I cleared out the temp folders so anything new would stand out. The logs go to "C:\Documents and Settings\<logged on user>\Local Settings\Temp\1\McAfeeLogs".

                 

                Looking through the logs it looks like it cant find the SQL DB. At first the DB was local but then we moved it to our SQL cluster. The DB name it's looking to connect to is not correct so ill mention that to McAfee when I log the case.

                • 5. Re: Upgrading to ePO 4.6.2 Problem
                  andrep1

                  you can repoint your db by going to /core/config but be aware of the following, they no longer support a database being renamed. so the datbase HAS  to be called ePO4_servername

                  • 6. Re: Upgrading to ePO 4.6.2 Problem
                    DeanBaker

                    Ah that is where my problem is then. The logs show its trying to epo4_<servername> and my DB is called <servername>. McAfee helped me move the DB to the SQL cluster so they chose the DB name.

                     

                    Would you think its best to rename my DB so in future I don't get this sort of problem? I wonder if McAfee will help me out here?

                    • 7. Re: Upgrading to ePO 4.6.2 Problem
                      DeanBaker

                      Andre would you know if its easy to rename the ePO DB? Is it just a case of renaming the DB in SQL Server Management Studio then pointing to the new DB in core/config?

                      • 8. Re: Upgrading to ePO 4.6.2 Problem
                        andrep1

                        Yes, you do need to rename the DB. None of your ePO installs will work for now on. Talk to your customer rep. at McAfee for this, them having you rename the db was a bad call.

                         

                        For you second question, yes, that's pretty much it. Your db files will keep the same names though, unless you rename them but this has no impact on ePO.

                        Bring epo down, put your db in single user mode and rename the db. But please note I'm not an SQL expert.

                        • 9. Re: Upgrading to ePO 4.6.2 Problem
                          DeanBaker

                          Andre thats a great help, thanks for the info. I think I will log a case with them anyway just to see what they say. The last thing I want to do is mess up the ePO server.

                          1 2 Previous Next