2 Replies Latest reply on Mar 1, 2012 12:39 PM by Craig Bryan

    McAfee Security Anti-Malware for Mac not able to get updates online

      Hello All,

      I am deploying a couple iMacs in the office, but am having issues getting McAfee to do the online updates. Here's some info about the software I'm using:

      Name: McAfee Security 1.1.0 (1309), Ant-Malware v9.0.1 (4478)

      Workstation: Apple iMac

      Operating System: OS X Lion 10.7.3

      Network Connection: Wireless

       

      The software installs without any issues, but when you tell it to do updates it just sits there with the update bar spinning. I have left it for about 60min with no progress at all. Using an article that I found in the corporate knowledgebase (KB52575), I was able to download and manually install the latest DAT files (6622). But this is only a temporary fix. I need the program to be able to do online updates.

       

      Any help on this issue would be greatly appreciated. Thx.

        • 1. Re: McAfee Security Anti-Malware for Mac not able to get updates online

          Me too...  unable to update, just keeps spinning.

          • 2. Re: McAfee Security Anti-Malware for Mac not able to get updates online

            OK...after some troubleshooting with McAfee on the phone I found out that the client wasn't installed properly. When you look in the McAfee Preferences under Update, the Repository Names list was not populated. That is why the updates progress bar would just sit there and not do anything, it didn't know where to look for the updates (the Repository Names list should have two entries McAfeeHttp, and McAfeeFtp).

             

            So after a lot of trial and error, I think I found a solution to this issue that works for me:

            1. Log in to the Root account.
            2. Uninstall the client and restart the workstation.
            3. Uninstall the agent from the terminal (sudo /Library/McAfee/cma/uninstall.sh), and restart the workstation.
            4. Place a copy of the client install package (the .dmg file), on the desktop of the Root account. (The agent and the client both have to be installed from the Root account. I was previously installing the agent from the Root account and the client from an admin account.)
            5. Install the client first, then the agent, and then shutdown and restart the workstation. (I tried different combinations of installing, and restarting but this was the only combination that I could get a successful install repeatedly.)
            6. Check the Repository Names list to make sure it's populated.
            7. Let the workstation sit for 20min. (When I tried to do a DAT file update before letting it sit for a while, I would get a message that an update is already in progress).
            8. Do a DAT file update. The update should complete within 5-10min depending on your connection speed.