1 2 3 Previous Next 21 Replies Latest reply on Mar 15, 2012 8:38 PM by gcm_rukawa11

    Failed to deploy EPO Agent 4.6

      I have setup a new EPO Server hit some problems and was resolved by the solutions provided by Tristan and Ulyses31 and down to the last error i hope.

      This is the error log captured from the EPO Server.

       

      Failed to send http request.  Error=12029

      20120208140316 E #06876 NAIMSRV  Failed to download agent PkgCatalog.z from local repository, cannot push agent

      20120208140316 E #06876 NAIMSRV  Failed to download and verify agent install package

      20120208140316 E #06876 NAIMSRV  Push Agent Installation Program to xxxxxxxx failed, will not retry

      20120208140316 I #06876 MCUPLOAD Successfully disabled CA trust options.

       

      Help any1??

        • 1. Re: Failed to deploy EPO Agent 4.6

          Changes that was performed.

           

          1) Change the agent port from 80 to 81 on registry [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Unins tall\{73F1BDB7-11E1-11D5-9DC6-00C04F2FC33B}]

          2) Use Studio Management to update the port, executing the command:

                UPDATE EPOServerInfo

                SET ServerHTTPPort=81

          3) Edit Server.ini and Siteinfo.ini from ...\Program Files\McAfee\ePolicy Orchestrator\DB\

                From HTTPPort=80 to HTTPPort=81

          4) Edit httpd.conf from ...\Program Files\McAfee\ePolicy Orchestrator\Apache2\conf

                From

                Listen 80

                Listen 443

                To

                Listen <IP Address>:81

                Listen <IP Address>:443

          • 2. Re: Failed to deploy EPO Agent 4.6
            hem

            What is the port number, it's showing in EpoServerInfo table? Is it 80 or 81?

            • 3. Re: Failed to deploy EPO Agent 4.6
              tao

              I have use the link below to test network/access issues:

               

              http:// [epo-servername:port#] /Software/Current/VIRUSCAN8700/Install/0000/vse870.msi

              • 4. Re: Failed to deploy EPO Agent 4.6

                Hi Hem,

                 

                It is showing 81.

                3.jpg

                 

                Hi Tao,

                 

                Tested using ur link and I and access the installer.

                4.jpg

                • 5. Re: Failed to deploy EPO Agent 4.6

                  Hi,

                   

                  Anyone has any ideas?

                  • 6. Re: Failed to deploy EPO Agent 4.6
                    Laszlo G

                    Hi gcm_rukawa11, I assume what you are really doing is upgrading an existing agent?

                     

                    If so then it seems that, even after changing your agent-to-server port, this computer is still trying to connect through port 80. If this is true then your computer should not be updating its dats (unless it downloads it from McAfeeHTTP)

                     

                    If this happens with more computers then can you try to create a new framepkg.exe package through ePO and run it on the local machine?

                    • 7. Re: Failed to deploy EPO Agent 4.6

                      Hi Ulyses31,

                       

                      I have another server running ePO4 using port 80 instead of 81.

                      ePO4.6 is installed on a new server with the intention to replace ePO4 and WSUS is running on top as well.

                      Since wsus is using port 80, I made the change on ePO4.6 to use port 81 instead (from the other thread).

                      I have tried pushing the agent on server itself ( with no previous copy of Mcafee agent installed ) but failed.

                      Tried pushing the agent to a couple of machines with the option to "

                       

                      It will be difficult to do a manual installation for a large no. of machines with the package. Will try creating the package and install on a machine to see if that  works.

                      • 8. Re: Failed to deploy EPO Agent 4.6

                        Hi Ulyses31,

                         

                        I have create and install the package to 1 test Server.

                        1 of the policies to install VSE8.8 works, but other policies like scheduled scan and definition updates are not working.

                        Telnet to the server using port 81 and 8081 is ok.

                         

                        Friday, February 17, 2012 10:17:41 AM

                        Info

                        Scheduler

                        Added a new task Install VSE 8.8 to Scheduler's task list

                        Friday, February 17, 2012 10:17:41 AM

                        Info

                        Management

                        Enforcing Policies for VIRUSCAN8800

                        Friday, February 17, 2012 10:17:41 AM

                        Info

                        Management

                        Enforcing Policies for EPOAGENT3000META

                        Friday, February 17, 2012 10:17:41 AM

                        Info

                        Management

                        Enforcing Policies for EPOAGENT3000

                        Friday, February 17, 2012 10:17:41 AM

                        Info

                        Agent

                        Agent finished Enforcing policies

                        Friday, February 17, 2012 10:17:41 AM

                        Info

                        Agent

                        Next policy enforcement in 30 minutes

                        Friday, February 17, 2012 10:17:56 AM

                        Info

                        Scheduler

                        Scheduler: Invoking task [Install VSE 8.8]...

                        Friday, February 17, 2012 10:17:56 AM

                        Info

                        Updater

                        Checking update packages from repository ePO_SERVER.

                        Friday, February 17, 2012 10:17:56 AM

                        Info

                        Updater

                        Initializing update...

                        Friday, February 17, 2012 10:17:56 AM

                        Info

                        Updater

                        Verifying catalog.z.

                        Friday, February 17, 2012 10:17:56 AM

                        Info

                        Updater

                        Extracting catalog.z.

                        Friday, February 17, 2012 10:17:56 AM

                        Info

                        Updater

                        Loading update configuration from: catalog.xml

                        Friday, February 17, 2012 10:17:57 AM

                        Info

                        Updater

                        Verifying VSE880Det.McS.

                        Friday, February 17, 2012 10:17:57 AM

                        Info

                        Updater

                        Verifying VSE880Det.McS.

                        Friday, February 17, 2012 10:17:57 AM

                        Info

                        Updater

                        Update Finished

                        Friday, February 17, 2012 10:18:11 AM

                        Info

                        Scheduler

                        The task Install VSE 8.8 is successful

                        Friday, February 17, 2012 10:18:11 AM

                        Info

                        Scheduler

                        Scheduler: Task [Install VSE 8.8] is finished

                        Friday, February 17, 2012 10:20:01 AM

                        Info

                        Agent

                        Agent is looking for events to upload

                        Friday, February 17, 2012 10:25:01 AM

                        Info

                        Agent

                        Agent is looking for events to upload

                        Friday, February 17, 2012 10:30:01 AM

                        Info

                        Agent

                        Agent is looking for events to upload

                        Friday, February 17, 2012 10:35:01 AM

                        Info

                        Agent

                        Agent is looking for events to upload

                        Friday, February 17, 2012 10:39:52 AM

                        Info

                        Scheduler

                        The Scheduler is shutting down

                        Friday, February 17, 2012 10:39:52 AM

                        Info

                        Scheduler

                        Scheduler is now stopped

                        Friday, February 17, 2012 10:39:52 AM

                        Info

                        Updater

                        Friday, February 17, 2012 10:41:30 AM

                        Info

                        Updater

                        Subsystem started

                        Friday, February 17, 2012 10:41:30 AM

                        Info

                        Scheduler

                        Next time(local) of task Definition Updates: Friday, February 17, 2012 12:00:00 PM

                        Friday, February 17, 2012 10:41:31 AM

                        Info

                        Scheduler

                        Next time(local) of task On-Demand Scan: Sunday, February 19, 2012 3:00:00 PM

                        Friday, February 17, 2012 10:41:31 AM

                        Info

                        Scheduler

                        Next time(local) of task {A14CD6FC-3BA8-4703-87BF-E3247CE382F5}: Friday, February 17, 2012 5:46:00 PM

                        Friday, February 17, 2012 10:41:31 AM

                        Info

                        Scheduler

                        Scheduler is now running

                        Friday, February 17, 2012 10:41:31 AM

                        Info

                        Agent

                        Agent will connect to Server in randomized full ASCI interval : 3600 seconds

                        Friday, February 17, 2012 10:41:31 AM

                        Info

                        Agent

                        Next policy enforcement in 30 minutes

                        Friday, February 17, 2012 10:41:31 AM

                        Info

                        Agent

                        Agent will connect to Server in : 36 minutes and 0 seconds

                        Friday, February 17, 2012 10:46:31 AM

                        Info

                        Agent

                        Agent is looking for events to upload

                        Friday, February 17, 2012 10:51:30 AM

                        Info

                        Agent

                        Agent is looking for events to upload

                        Friday, February 17, 2012 10:56:30 AM

                        Info

                        Agent

                        Agent is looking for events to upload

                        Friday, February 17, 2012 11:01:30 AM

                        Info

                        Agent

                        Agent is looking for events to upload

                        • 9. Re: Failed to deploy EPO Agent 4.6
                          Laszlo G

                          Hi gcm_rukawa11, looks like your agent services had been restarted at 10:39:52 but the agent may have not downloaded new tasks yet. You should first try to send a wake-up call to this computer forcing tasks and policies update, after thois you should see some new info on the agent log

                          1 2 3 Previous Next