8 Replies Latest reply on Jan 13, 2012 1:26 AM by smalldog

    Can't install 8.7 or 8.5 anymore

      Our University (U of Maryland) has a license allowing us to install the McAfee software on our home PCs. I have a Vista PC that I bought a month or so ago, on which I immediately installed 8.5i off of our University's website, followed by the 8.5 patch. It did regular scans, and never found anything.

      All was well until the University updated the download to 8.7i last week. I downloaded this install package and attempted to install it over 8.5. No dice: I got past the Administrator account prompt, but then I get the ff. error msg:

      This installation package could not be opened.
      Verify that the package exists and that you can
      access it, or contact the application vendor to
      verify that this is a valid Windows installer
      package.

      So I then uninstalled my old 8.5, thinking (wrongly) that this was causing the problem. I still got the same error msg. OK, I thought, I'll re-install 8.5 from its download file, which I still had laying around. No--I get the same error msg on the same version that installed OK before!

      Since there didn't seem to be any way to install either the old or the new package, maybe this is a Windows Vista issue. I have of course gotten several updates to Vista in the last month, although it's odd that I don't see anything on this forum from anyone having the same problem from Vista updates.

      Here are the details on the three programs, as reported by 'dir':
      12/17/2008 07:57 PM 34,743,797 mcafee85.exe
      01/09/2009 09:16 AM 56,322,219 mcafee87.exe
      12/17/2008 08:11 PM 16,143,690 mcafee_patch5.exe

      Right now I have the trial version of AVG Internet Security installed, but that only lasts 30 days. (It hasn't detected any viruses either, so I doubt that an infection is causing the problem.)

      So why can't Windows open the McAfee installation program?

      Mike Maxwell
        • 1. (addition to above)
          I also tried running MCPR (downloaded from this McAfee website) to complete the uninstallation of the old (8.5) version. (Why doesn't the uninstall do this???) MCPR (running as admin) chugs for awhile, the progress bar gets maybe 10% of the way, and then it hangs. It ran all night and was still in the same position this morning.

          I have also done numerous re-boots trying to get this to work.

          Finally, after the 8.5 install fails, I get a message box entitled "IDS_Message_Virusscan", with the message "IDS_Message_Reboot_Needed", and two buttons: yes and no. Pressing 'no' does nothing besides dismissing the msg box, and pressing 'yes' reboots the computer. Not the most informative message I've ever seen (and a google search for either term comes up blank).

          Mike Maxwell
          • 2. RE: (addition to above)
            MCPR is for consumer products only, VirusScan 8.5i and 8.7i are Business\Enterprise products.

            I am moving this thread to the Business section where you should be able to get help...
            • 3. move WHERE?
              I appreciate that you moved my message for me, but I had a heck of a time finding where you had moved it to. Your message came with a link that included what appeared to be a thread number, but the link was broken (perhaps because you moved the link?).

              Anyway, the next time someone moves a msg from one forum to another, it would be nice to provide a link to the new position.

              Mike Maxwell
              • 4. ...Safe Mode doesn't fix it, either
                I tried logging in as Administrator in Safe Mode, and neither 8.5 nor 8.7 will install. I was able to run the McAfee Cleanup (MVPR.exe) to completion, however I get numerous msgs of the form
                Error obtaining full permissions for cleanup. Some products
                may not be fully removed.
                But the install programs still fail after reboot.

                I also ran the McAfee Virtual Technician. It of course finds no McAfee products (since I unistalled 8.5). It then scans for other things it thinks might cause problems, and cleans up all the cookies, temp files etc. But 8.5/8.7 still don't install.

                Mike Maxwell
                • 5. logfile
                  After I attempt to run this installer, two log files show up in c:\temp\McAfeeLogs, VSEUninst.log, and VSEInst.log. I think the former is just looking for any installed versions of McAfee, and of course it finds nothing. The latter contains the ff. lines:
                  -----------
                  === Verbose logging started: 1/17/2009 17:59:00 Build type: SHIP UNICODE 4.05.6001.00 Calling process: C:\Windows\SysWOW64\msiexec.exe ===
                  MSI (c) (DC:18) [17:59:00:388]: Resetting cached policy values
                  MSI (c) (DC:18) [17:59:00:388]: Machine policy value 'Debug' is 0
                  MSI (c) (DC:18) [17:59:00:388]: ******* RunEngine:
                  ******* Product: C:\Temp\VSE870.MSI
                  ******* Action:
                  ******* CommandLine: **********
                  MSI (c) (DC:18) [17:59:00:389]: Note: 1: 2203 2: C:\Temp\VSE870.MSI 3: -2147287038
                  MSI (c) (DC:18) [17:59:00:390]: MainEngineThread is returning 2
                  === Verbose logging stopped: 1/17/2009 17:59:00 ===
                  ------------

                  When it gets done, I don't see the file C:\Temp\VSE870.MSI, which is maybe a clue; or maybe it gets automatically deleted, since it's in a temp folder.

                  Mike Maxwell
                  • 6. *partial* success
                    After my preceding posting, I looked around and found (in the Admin user's local temp file) the old VSE850.msi file, left over from my initial successful installation. I tried copying that over to the same dir that the mcafee85.exe file was in, then ran the .exe file; I got the same error msg as before (invalid installation package), and it had deleted the (copied!) .msi file. So I guess that means that mcafee8{5,7}0.exe are supposed to create a VSE8{5,7}.msi file; maybe they're not succeeding in doing so, although I have no idea why.

                    The original install package also left around a readme file, from which I extracted a command line that purports to simply extract the .msi file, not execute it. I can't find this readme now, but the cmd line is something like
                    mcafee85.exe /nos_e /nos_o<tempDir>
                    (The readme actually said to run 'setup.exe' instead of 'mcafee85.exe', but there was no such file.) However, this fails with the same error msg as my installs kept failing with.

                    Finally, I re-copied the VSE850.msi file to my temp dir, then ran
                    msiexec.exe /i VSE850.msi
                    and that worked (at least McAfee is now installed, updates itself, and appears to be working).

                    So the problem appears to be with extracting the .msi file, which is apparently contained inside the .exe file. For some reason it won't extract on my machine.

                    And I *still* can't install version 8.7, since I never got a VSE870.msi file out. And heaven help me if I ever lose the 8.5 .msi file!

                    So: why would it not be possible to extract the .msi file? It doesn't appear to be a case of it being written to the wrong dir (since I couldn't extract it when I have it an explicit temp dir using the /nos_o command line parameter). And I don't think it's a directory permissions issue, since other programs can write to the c:\temp\ dir.

                    Mike Maxwell
                    • 7. Can't install 8.7 or 8.5 anymore

                      try to forceinstall the VSE in command line:

                      SetupVSE.exe /REMOVEINCOMPATIBLESOFTWARE=TRUE /qn

                       

                      I had the same error on a win server 08 and the command line installation worked

                      • 8. Re: Can't install 8.7 or 8.5 anymore
                        smalldog

                        I have same problems with vse8.8 patch 1 on windows server 2008 64bit. When run with command line that show error (see attach). How to fix this? Thanks!