7 Replies Latest reply on Feb 14, 2012 10:48 PM by KatherineYH Hayes

    Print Spooler/printing not working

      my regular virus scan found a virus and removed it and shortly after I started havign problems with my print spooler/printer. I Googled and found people who had the same problem and found solutions but none have worked for me.

      i don't know what the virus was because i couldn't find any details displayed after the scan.

      The virus, after being removed, stopped my print spooler, removed my printers from my list of printers (although 1 solution i tried had them back momentarily), will not allow me to reinstall my printers, does not recognise that the printers are connected (they are both plug & play) & will not allow me to use the scanner function of my printer even though it is still displayed as being available.

      i have had this problem for over a month now and am ready to give up. obviously the when McAfee "removed" th evirus it did not remove it all

        • 1. Re: Print Spooler/printing not working
          Peacekeeper

          Two things the name will be shown in the history and logs section of navigation (top right). Check the threats detected or scans information. Post what the detection was.

           

          Also run Getsusp and malwarebytes and see what they detect. With getsusp add your email to the preferences as it will contact you re detections.

          McAfee Communities: Anti-Spyware, Malware & Hijacker Tools

           

          Moved post to better area

           

          Message was edited by: Peacekeeper on 5/01/12 7:46:32 PM
          1 of 1 people found this helpful
          • 2. Re: Print Spooler/printing not working

            Thanks Tony

             

            Unfortunately, I could not find it in the log because it happened back in November and the log only goes back 1 month. Wish I had of tried this site earlier.

             

            I ran Getsusp and it identified 9 suspicious files, 7 were from Quickbooks, 1 from System32 & 1 from Easy PDF (which I am not familiar with).

             

            Malwarebytes detected:

            Registry Data Items Detected: 2

            HKLM\SOFTWARE\Microsoft\Security Center|AntiVirusDisableNotify (PUM.Disabled.SecurityCenter) -> Bad: (1) Good: (0) -> Quarantined and repaired successfully.

            HKLM\SOFTWARE\Microsoft\Security Center|FirewallDisableNotify (PUM.Disabled.SecurityCenter) -> Bad: (1) Good: (0) -> Quarantined and repaired successfully.

             

            but this still did not fix my printer problems

            • 3. Re: Print Spooler/printing not working
              Peacekeeper

              What was the system32 file name?

               

              Try also www.superantispyware.com the free version. I will see what u post back and if noone replies here will ping a virus tech. Virus removal not my best area.

               

              Message was edited by: Peacekeeper on 6/01/12 7:13:21 PM
              • 4. Re: Print Spooler/printing not working

                C:\WINDOWS\system32NvCpl.dll  ... this is from the Getsusp log

                 

                I will try superantisyware and see how it goes ..... i just tried a system restore from safe mode but the restores always seem to fail after the restart

                • 5. Re: Print Spooler/printing not working
                  Peacekeeper

                  nvcpl.dll is a NVIDIA Display Properties Extension Should be ok check its proteries.

                   

                  See what getsup replies with I hope you added your email addy to the preferences...

                   

                  This is getting a tad messy Maybe you need to try 1 of the hyjack this forums mentioned in that link I gave you. I will ask a virus tech for comment.

                  • 6. Re: Print Spooler/printing not working
                    Peacekeeper

                    Sorry for the delay I contacted a tech re this and this is his reply not an easy fix

                    His solution taken from here

                    http://support.microsoft.com/kb/810894

                     

                    >>>Quote from the Mcafee lab tech

                    once  I Fixed the issue

                     

                    steps performed by me.

                     

                    * Deleted the spool printer and driver files - (Deleted all files under C:\Windows\System32\Spool\Printers  and C:\Windows\System32\Spool\Drivers\w32x86 )

                     

                    Opened  registry-- took a back up

                    checked this location

                    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86

                     

                    In the subkey list, verified that only the following subkeys were there

                    Drivers

                    Print Processors

                     

                    then jumped to

                    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors

                     

                    In the list of subkeys, removed everything except the following subkeys for the default print monitors:

                    BJ Language Monitor

                    Local Port

                    PJL Language Monitor

                    Standard TCP/IP Port

                    USB Monitor

                     

                    removed all lexmark installation via add/remove

                    • removed old JAVA.
                    • rebooted
                    • Installed Printer via CD.
                    • tried Printing a test page-- It worked.
                    • rebooted and got customer to confirm the same.

                    • 7. Re: Print Spooler/printing not working

                      Clean up general corruption and repair/replace any damaged/missing files.

                       

                      Run DiskCleanup - Start - All Programs - Accessories - System Tools - Disk Cleanup

                       

                      Start - type this in Search Box ->  COMMAND   find at top and RIGHT CLICK  -  RUN AS ADMIN

                       

                      Enter this at the prompt - sfc /scannow