8 Replies Latest reply on Jun 11, 2009 5:22 AM by jawuk

    No "M" Icon

      We are running VirusScan Enterprise 8.5.0i, patch 4, with EPO framework 3.6.0.

      The issue is that if an admin logs on to a client server at the local console the M icon will appear in the system tray. When logging in through a remote session the M icon is visible on some servers and the Vshield on others.

      I know the framwork service is running, but it can be confusing.

      Is there a fix for this? I seem to recall some info on it, but can't locate it anymore.

      Thanks in advance,

      Steve
        • 1. RE: No "M" Icon
          tonyb99
          this may be of help

          After installing the McAfee Security Agent
          icon, the single McAfee Security Agent icon
          displays an "i" when a product detects a
          threat or when a configuration has changed.
          When this "i" appears, click the McAfee
          Security Agent icon to see which product icon
          changed from its default state. The McAfee
          Security Agent icon is not supported on
          Windows NT or 64-bit operating systems.
          If a system is not managed by ePolicy
          Orchestrator, or if the agent policy settings
          are defined to hide the agent tray icon, then
          the McAfee Security Agent icon does not
          appear.

          - Disabling and enabling the McAfee Security
          Agent icon at installation
          Two new CMA command line parameters are
          provided to support the McAfee Security Agent
          icon:
          /sti=0 (off)
          /sti=1 (on; default).
          By default, the McAfee Security Agent is
          enabled. To prevent the installation of the
          McAfee Security Agent icon using ePolicy
          Orchestrator, use the "/sti=o" command-line
          option during the installation of the agent.
          For details on installing the agent, see the
          ePolicy Orchestrator online Help.
          - Disabling and enabling the McAfee Security
          Agent icon remotely after installation
          To disable the McAfee Security Agent after
          installation, run
          "MCTRAY.EXE /remove"
          at a command prompt or with a login script.
          To re-enable the McAfee Security Agent, run
          "MCTRAY.EXE /add"
          at a command prompt or with a login script.
          • 2. Have a fix
            It is weird, but on every system where I have opened regedit to view the run keys, the M icon has come back. It could be that there was an issue in the registry that is intermittent and resolves when the key is opened. We have a backup product that is like that. It was missing a string terminator that gets applied when the key is opened for editing.
            • 3. RE: No "M" Icon
              Have you managed to get a solution for this?

              I am having the same issues.
              • 4. RE: No "M" Icon
                The answer from McAfee is that this is normal in my situation. The "M" epo icon is designed to only show up once on a server for the local console only. It is not supposed to appear from RDP sessions. That being said I have found that it does show up on some systems and not others. I just ignore it now.

                If you really want the icon then you could always add "MCTRAY.EXE" to your startup folder.

                • 5. RE: No "M" Icon


                  this is consistent with my experience. using the /console switch the red M is visible, and otherwise it seems to be hit or miss.
                  • 6. RE: No "M" Icon
                    twenden
                    Also having similar issues. I have seen it show up sometimes with RDP. I do have one Windows 2008 server (32 bit) that it won't show up on. It is not a big deal and is something that I also ignore. Too much other stuff to worry about.
                    • 7. RE: No "M" Icon
                      Not a permanent fix . . . but if you're in an RDP session and you simply need to run the McAfee Agent Monitor, a quicker way is:

                      "%ProgramFiles%\McAfee\Common Framework\CmdAgent.exe" /s

                      Switches on the "M" icon, as an aside.
                      • 8. RE: No "M" Icon
                        I too have seen this issue on many a clients site. All windows servers of various versions.

                        Clearly a bug, but in the scheme of bugs i am currently dealing with, its small fry . .:p but annoying none the less

                        J