5 Replies Latest reply on Dec 29, 2011 5:00 PM by SafeBoot

    Updating SDMCFG.ini, black screen at pre-boot

      I had to recently rebuild my database and received a new server key, which is working great when I install EEPC with a new install set.  The problem I am running into is that all my devices that are currently encrypted with an old install set, pointing to an old server and authentication signature need to be updated.  I followed directions by tech support and by article https://kc.mcafee.com/corporate/index?page=content&id=KB67716&actp=search&viewlo cale=en_US&searchid=1324484661123 on how to update the authentication signature in the SDMCFG.ini file to sync the old clients to new server database.

       

      After the signature update, the machines will sync to the new server db with no issues.  The issue begins after a reboot.  Once my machine sync's and updates, I reboot and get to the pre-boot login.  After logging into the preboot screen, the devices go to a black screen and mouse pointer is frozen.  It will never boot into windows.  I need help on how to resolve this issue.  I don't want to use the old database, it is corrupted and doesn't work.  Had to rebuild and start fresh to resolve other issues we were seeing, so please do not suggest this resolution.

       

      From what I can find, this can be a BIOS issue or a video resolution issue.  Updated both and tried different resolutions with no success.  My only work around at the moment is to decrypt the machine and re-encrypt with the new install set.  This takes on average 8 hours per machine, this is not feasible with the amount of machines that need to be transferred to the new database.  Any help would be appreciated!  My tech support contract ran out and i have to wait for the new budget to be approved to call tech support back, and there is no ETA on this. 

       

      Running EEPC/EEM 5.2.9.  Do not want to upgrade since the new versions have not been tested in our environment yet, but on a test it doesn't appear that new versions fix this issue.

      Windows 7.

      Mostly HP elitebook models and a few dell latitude models.

        • 1. Re: Updating SDMCFG.ini, black screen at pre-boot

          do you have a client log you can share? Not sure why you would have needed a new db key - you could have simply used the old one from your original database?

           

          How did you move the machines between the two databases?  And what version were they on prior to you installing again? (upgrading by over installing is actually not supported AFAIK).

           

          There are a lot of fixes in 5.2.11 etc for compatibility with newer hardware.

          • 2. Re: Updating SDMCFG.ini, black screen at pre-boot

            using the key from the old db would not work without restoring the old database, and again this was not a viable solution since the db was corrupted and unusable.  tested this theory and mcafee tech support did not have a resolution why this did not work.  their solution was to update the client machine to the new key rather than restoring the old key on the server side without the database.

             

            when testing, it appears the newer versions of eem/eepc do not resolve the issue with the black scree/frozen cursor problem that I am experiencing. 

             

            I was running version 5.2.9 before rebuilding and running 5.2.9 after rebuilding.  I am trying to move my machines to the new database, they never did sync with the old database, they (laptops that were already encrypted) are all considered "offline installs."  Client log is attached.  The knowledge base has many documents referencing the black screen at preboot, the proposed fixes/work arounds in the knowledge base do not resolve my issue.

            • 3. Re: Updating SDMCFG.ini, black screen at pre-boot

              something is not right here..

               

              first, it's impossible to corrupt the EEM "database" - mainly because it has no intrinsic links within it. It's simply totally impossible to break it. Yes, you could delete it, yes you could corrupt a single object, or a few, but there's no way to break it entirely. It's designed to survive anything.

               

              Secondly, it's totally impossible to get a machine to sync with a new DB - it simply can't be done because the root encryption key is different, so there MUST be some relationship between your "old" and "new" databases, and you MUST have done something to move the machines between them.

               

              So, given that you mention Offline install mode, I guess you are importing the SDB files on your machines into this new DB (unrelated to the DB the install set was created from) - that's really never going to work right as you found - all the file IDs are wrong, the users are wrong, and finally, upgrading, or migrating an active machine by overinstalling is simply not a supported process.

               

              So, I think you are moving down a really bad path - you really need to resurect your original DB and import the machines into that. Offline install mode is exactly that - it's designed for install only. It's not meant to be a permanent mode of operation.

               

              What was so broken about your original DB that you decided to start again, and, do you have professional services people on site helping you through this (if not, I highly recomend it!)

              • 4. Re: Updating SDMCFG.ini, black screen at pre-boot

                since you are not fully comprehending what the issue at hand is, here are some links of knowledge base articles with that are regarding comparable issues:

                 

                https://kc.mcafee.com/corporate/index?page=content&id=KB72619&actp=search&viewlo cale=en_US&searchid=1324559957777

                 

                https://kc.mcafee.com/corporate/index?page=content&id=KB68371&actp=search&viewlo cale=en_US&searchid=1324559957777

                 

                https://kc.mcafee.com/corporate/index?page=content&id=KB69290&actp=search&viewlo cale=en_US&searchid=1324559957777

                 

                https://kc.mcafee.com/corporate/index?page=content&id=KB70065&actp=search&viewlo cale=en_US&searchid=1324559957777

                 

                https://kc.mcafee.com/corporate/index?page=content&id=KB72803&actp=search&viewlo cale=en_US&searchid=1325174783149

                 

                The issue I am expreciencing after syncing a pc to a new database, i can authenticate at preboot, then the screen will go black with a mouse cursor froze on the screen and never boots into windows.  I can do a machine recovery and boot into windows with no issue.  i can decrypt the machine and encrypt with no issue, other than it takes roughly 8 hours per machine.  the issue with the old database is a moot point.  it will not be used and will not be resurrected. end of story.  if the only solution is to reimage the machine and encrypt from scratch or to decrypt then encrypt again, that is the route we will take.  the old database will not be an option.

                 

                now within the knowledge base articles and from the community forums of other users experiencing similar issues,  it appears to either be bad BIOS versions (updates normally fix), or bad graphics drivers (which mcafee doesn't have the specific macafee resolution for our graphics to specify), a USB hand hack (which i shouldn't have to do with the version that i am on), or upgrading mcafee to the newest versions.  none of these solutions have appeared to work.  updated BIOS, updated graphics drivers and tried various preloaded resolution within mcafee, even tried to do the USB handhack with no avail, and upgrading to the newest version doesn't appear to fix within a test environment.  Any help in resolving this issue is appreciated.

                • 5. Re: Updating SDMCFG.ini, black screen at pre-boot

                  Since it's not possible to connect a machine installed using an install set from one DB, to another unrelated DB, I would decrypt and start fresh with everything from your new db.