9 Replies Latest reply on Jan 6, 2012 12:42 PM by PhilM

    Running different versions of Sidewinder Admin Console on one PC/Server

    trevornm

      Hi,

       

      I need to run 2 versions of the Sidewinder admin console to work with 2 different software revisions of Sidewinder firewalls. I need Admin Console V4.05 for Sidewinder V7.0.0.05 and V4.10 for V7.0.1.02. When you access the earlier Sidewinder from the later version of admin console it doesn't run correctly and crashes out.

       

      Anyone know if this is possible at all?

       

      Thanks in advance

       

      Trevor

        • 1. Re: Running different versions of Sidewinder Admin Console on one PC/Server
          PhilM

          Trevor,

           

          The console is version specific (i.e. you can't access a v7 box with the v8 GUI, or vice versa), but it isn't patch-specific. As long as it is the same or newer, you will be OK.

           

          I have access to a large number of customer appliances and with my 4.11 Admin Console (recently updated when I discovered one of my customers had installed 7.0.1.03), I can access it and any other v7 variant older than that - I've just logged into a v7.0.0.07 unit using this GUI without any fuss.

           

          Sounds like you may have something a bit odd going on, possibly caused by trying to run two copies of the same generic Admin Console version (v4). I even have Admin Console installations for Sidewinder 6, Sidewinder 7 and version 8 all running happily together on my PC. It might be a good idea to uninstall the Admin Console, install a fresh copy, connect to the 7.0.1.02 Firewall (this will force the update packages to be installed) and then give the 7.0.0.05 machine a try.

           

          Regards,

          Phil.

          1 of 1 people found this helpful
          • 2. Re: Running different versions of Sidewinder Admin Console on one PC/Server
            trevornm

            Tried this Phil, as soon as the Admin Console is upgraded by accessing the newer Sidewinder, it stops working correctly with the older version, really frustrating and turning into a serious issue. I've finally giot access to the ServicePortal so will raise a support call on it,

             

            Thanks again

            • 3. Re: Running different versions of Sidewinder Admin Console on one PC/Server
              PhilM

              Yes, there seems to be something amiss going on, as I've done this too many times in the past for it to be a fluke.

               

              I replaced my long-standing work PC only a few weeks back, re-installed the 3 generic versions (for v6, v7 & v8 Firewalls), connected each to the newest customer firewall I could think of for each version and let them all update. After that I made sure that I could the connect and log into all the devices I have access to. I've got the same set-up on a laptop which I use when I'm travelling around, and also on my PC at home. All of them work perfectly.

               

              It might be a good idea to connect to the McAfee download site, enter your grant ID and download the latest copy of the Admin Console ISO. If I recall there is a native 7.0.1.02 version (which will be 4.10 of hte Admin Console - sorry for the confusion, I tend to think in Firewall version numbers, rather than Admin Console versions). Based on my own experience I would expect you to be able to fully uninstall all current versions of the Admin Console from your machine, install the 7.0.1.02 admin console and be able to connect to both your 7.0.1.02 and 7.0.0.05 appliances - possibly going for the older on first. The oldest machine I have access to is running 7.0.0.07, so I don't know (given how long since this release was generally available) whether 7.0.0.05, and earlier, needed a specific console version.

               

              Failing that, and to rule out any possible confusion/interference from having to v7 Admin Consoles installed, try installing the 7.0.1.02 console to a different machine, if you are able to.

               

              Phil.

              • 4. Re: Running different versions of Sidewinder Admin Console on one PC/Server

                Hello,

                 

                Phil is absolutely correct that the Admin Console is backward compatible. He is also correct that the version 7 Admin console can only support version 7 firewalls, and version 8 Admin Console can only support version 8 firewalls. Please open a ticket for your issue on the portal and provide the details for what is happening when "it stops working correctly" and we will be able to assist.

                 

                Thanks,

                 

                -Matt

                1 of 1 people found this helpful
                • 5. Re: Running different versions of Sidewinder Admin Console on one PC/Server
                  trevornm

                  Ticket has been raised and all, thanks!

                  • 6. Re: Running different versions of Sidewinder Admin Console on one PC/Server
                    PhilM

                    Trevor, how did you get on with the ticket?

                     

                    I ask as for the first time I've just encountered a scenario which contradicts what I previously said.

                     

                    One of my customer's called requesting some assistance, so the first thing I did was to fire-up my Admin Console GUI and try to connect. As previously mentioned, I had previously connected to another customer's appliance where they had installed patch 7.0.1.03. As far as I was concerned this was the 'latest and greatest' version 7 release and I should therefore have no trouble making my connection to a slightly older v7 appliance.

                     

                    Much to my surprise I was told that there was an outstanding Admin Console patch to be installed. I acknowledged the message and waited for the patch to be downloaded. When prompted to install the patch I acknowledged the request and waited for it to install. All of a sudden it threw up an error:-

                     

                    AdminConsole Error.JPG

                     

                     

                    As you can see, it confirms that I am running Admin Console 4.11, but requires me to be running 4.10 in order to install the patch. The problem is, I can't install the patch, and each time I try to connect to that Firewall it tells me I need to install a patch.

                    • 7. Re: Running different versions of Sidewinder Admin Console on one PC/Server
                      trevornm

                      Hi Phil,

                       

                      I had to uninstall the later version, then install the earlier version and run Admin Console as Administrator so it could load the patches it needed to get to it to v4.05. That restored full access to the Sidewinders running v7.0.0.05. To access the Sidewinder running  version 7.0.1.02 I need to use a different PC with the later version of Admin console on, until we get the earlier Sidewinders upgraded.

                       

                      Probably not much help I'm afraid!

                      • 8. Re: Running different versions of Sidewinder Admin Console on one PC/Server

                        Hello guys,

                         

                        After speaking with coworkers, we remembered that there was a known issue specifically with version 7.0.0.05 causes problems with newer Admin Consoles. Unfortunately the workaround is as Trevor said, to have to PCs to manage the firewalls. This hasnt been a huge issue lately becuase the 7.0.x line is EOL.

                         

                        Phil, I find your issue very interesting. Just did some testing myself and could not reproduce the issue. I have an Admin Console that previously connected to a 7.0.1.03 firewall and connected to other firewalls at previous versions with no issues. Can you tell me what version your customer is at so I can do some further testing?

                         

                        -Matt

                        • 9. Re: Running different versions of Sidewinder Admin Console on one PC/Server
                          PhilM

                          Matt -

                           

                          As I said before, I've never seen the console behave like this before either and I've been working with Sidewinder since 5.x. The nasic premise has always been that if the GUI in question is for the correct generic version of the Firewall (v5, v6, v7 or v8) and that it is patched to at least the level of the Firewall you are trying to connect to, it will work just fine. The customer in question has another 7.0.1.02 Firewall in a different location and I can connect to it with my 4.11 Admin Console without any problems at all.

                           

                          I have raised a ticket (including details from the target Firewall in question). I will PM the ticket number to you so you can take a look at the details.

                           

                          - Phil.