6 Replies Latest reply on Feb 19, 2012 3:51 PM by kalos

    McAfee Service Host error message

      I keep getting the following error message :

      'McAfee Service Host has encountered a problem and needs to close.'

      The Error signiture is :

      szAppName:McSvHost.exe szApp Ver: 2.0.230.o szMod Name: unknown  sz Mod Ver: 0.0.0.0 offset: 05f9f1b0

      I have run the Virtual Technition and it says that it is unable to find the product.

      My question is what is going on and how can it be corrected.

      Thanks

        • 1. Re: McAfee Service Host error message
          k3tg

          Have you contacted Technical Support regarding this issue? You can reach them 24/7 via Useful Links at the top of this page.

          • 2. Re: McAfee Service Host error message

            Have You tried reinstalling it?

            • 3. Re: McAfee Service Host error message

              Hi  I have just had the same problem ,I would be surfing away happily and

               

              then the message comes up that  the service host needed to close ,

               

              At first I would try the update  just for it to tell me the Firewall is at risk and shut down.

               

              So I'd restart the PC and all was fine until next time .  I even tried the Tech download 

               

              but it was always the same outcome even if I tried reinstal of Mcafee.

               

              I get Mcafee free from my  internet provider and noted the problem only came after it

               

              upgraded from 2011 to the 2012 version , The other evening it went wrong again .

               

              So yet again I uninstalled Mcafe security suite , the tech and site advisor  via the

               

              add/remove in the pc's control panel , everything gone or so i thought ....

               

              I now did a simple pc search for any file with the word " Mcafee" in it and a

               

              few results came back .. so I deleted them (some were just empty folders )

               

              and then came back on here to reinstall  and up to yet it has worked fine

               

              I think the problem was an old folder  from the 11 version and a folder from

               

              the 2012 version of Mcafee that were trying to do the same job thus  a bit of

               

              a conflict with the service host .  Well its worked for me ,so far so good .

               

              So next time your pulling your hair out and Mcafee, do a search after its out and

               

              take anything left  out, Delete it .

              • 4. Re: McAfee Service Host error message

                Thanks for the help.

                How did you reinstall after you removed the program from your computer? Did you get it from a disc or website?

                • 5. Re: McAfee Service Host error message

                  Off the Mcafee site ,I get it free via my ISP .

                   

                  Now for the bad news it has come back again I ran the virtual program and it fixed a reg file from the Mcafee my account but it did it again within the hour and when i ran the virtual it said " no problems found "

                   

                  I know for a fact that  the problem only started when Mcafee security suite upgraded its self to the latest newer version. I never had this until that update,,, wish I could go back to the last years version.

                   

                  Time Mcafee did something as I am sure they are aware of it

                  • 6. Re: McAfee Service Host error message

                    The latest update I can give you is the fault is still there

                     

                    I have gone through McAfee support free chat and they got nowhere with it  and

                     

                    put me through to a higher level of technicians who have took copies of my PC

                     

                    via remote assistance and are now handing it to people in Mcafee at an even higher

                     

                    level

                     

                    The statement  from them is  .. " we are aware of this problem  ,it is an ongoing issue

                     

                    and we hope to make an update to fix the problem soon ."

                     

                    In other words you and I are stuck with the problem until they make a fix .

                     

                    I would go through the free chat support and at least you will be among the first in the fix queue

                     

                    Hope this helps

                     

                    Message was edited by: kalos on 19/02/12 15:51:43 CST