2 Replies Latest reply: Nov 23, 2011 1:32 AM by lohr RSS

    Agent Deployment Fails

    lohr

      Hi all,

       

      so it is me again - sorry about that but I am still in learning phase

       

      So here is my problem, when I deploy an agent via the McAfee ePO console, I am getting back the status "Failed". But the strange thing is that the client finally reinstalls the client like it should, please see this client logs:

       

      Tuesday, November 22, 2011 3:35:16 PM stopped retailers server subsystem
      Tuesday, November 22, 2011 3:35:16 PM Agent subsystem detail is stopped ...
      Tuesday, November 22, 2011 3:35:16 PM Agent Detail
      Tuesday, November 22, 2011 3:35:16 PM Info Scheduler Scheduler is shutting down
      Tuesday, November 22, 2011 3:35:16 PM Info Scheduler Scheduler is now stopped
      Tuesday, November 22, 2011 3:35:16 PM Info Updater
      Tuesday, November 22, 2011 3:35:16 PM stopped detail management subsystem
      Tuesday, November 22, 2011 3:35:16 PM Logging Detail
      Tuesday, November 22, 2011 3:35:39 PM Info Updater started subsystem
      Tuesday, November 22, 2011 3:35:39 PM Info Scheduler Next time (local time) of task {A14CD6FC-3BA8-4703-87BF-E3247CE382F5}: Tuesday, 22 November 2011 17:28:00
      Tuesday, November 22, 2011 3:35:39 PM Info Scheduler Scheduler is now running
      Tuesday, November 22, 2011 3:35:39 PM Info Agent Agent is keypair created ...
      Tuesday, November 22, 2011 3:35:40 PM Info Agent Agent ID is created ...
      Tuesday, November 22, 2011 3:35:40 PM Info Agent Next policy enforcement in 5 minutes
      Tuesday, November 22, 2011 3:35:40 PM Info Agent Agent is connecting to servers forth in randomly generated ten-minute intervals
      Tuesday, November 22, 2011 3:35:40 PM Info Agent Agent contacted server in 5 minutes and 49 seconds
      Tuesday, November 22, 2011 3:35:51 PM Info Agent Agent started converting the guidelines
      Tuesday, November 22, 2011 3:35:51 PM Info Management Guidelines for EPOAGENT3000META be enforced
      Tuesday, November 22, 2011 3:35:51 PM Info Management Guidelines for EPOAGENT3000 be enforced
      Tuesday, November 22, 2011 3:35:51 PM Info Management guidelines are enforced for McAfee Agent
      Tuesday, November 22, 2011 3:36:11 PM Info Agent Agent finished converting the guidelines
      Tuesday, November 22, 2011 3:36:11 PM Info Agent Next policy enforcement in 5 minutes

       

      The english above might not be that good, I have used google translator.

      What do you think, is that "Failed" a false positive?

       

      Thanks for your input.

       

      Best regards,

      lohr

       

        • 1. Re: Agent Deployment Fails
          jstanley

          An agent push is essentially a datachannel request and we resolved several datachannel issues in ePO 4.5 P5 so if you are running a version of ePO less than that I would recommend patching up.

           

          It could be that the agent was actually already installed on the client I suppose. To troubleshoot an agent push problem I would need a copy of the server.log from the handler you selected to do the push taken immediatly after the push failed along with the name of the client you attempted to push to. The server..log can be located in <ePO install directory>\DB\Logs.

          • 2. Re: Agent Deployment Fails
            lohr

            Hi jstanley,

             

            thanks for your answer. We are going to upgrade in December to 4.6 so that should resolve the problem as well or?

             

            Yes you are correct, it was a reinstall on my own laptop because I had no client with no Agent installed here.

            Here are all logs which were corresponding to the laptop where I tried the push:

             

            2011-11-23 08:16:38 I #5828 NAIMSRV Received [Event] from MUCL0474:{128BABB7-9A68-4C1A-AA3A-7166340DD90B}

            2011-11-23 08:17:35 I #3448 NAIMSRV Pushing agent install, source:Current/EPOAGENT3000/Install/0409, target system: MUCL0474, target path: <PROGRAM_FILES_DIR>\McAfee\Common Framework

            2011-11-23 08:17:36 I #3448 NAIMSRV Copy C:\WINDOWS\TEMP\mfe-1856593952.tmp\FramePkg.exe to \\MUCL0474\ADMIN$\FramePkg.exe Successfully

            2011-11-23 08:17:38 I #3448 NAIMSRV Push Agent Installation Program to MUCL0474 was successful

             

            So this looks good or?