Skip navigation
McAfee Secure sites help keep you safe from identity theft, credit card fraud, spyware, spam, viruses and online scams
This discussion is archived
109220 Views 364 Replies Latest reply: Jul 4, 2012 11:11 PM by Peacekeeper RSS 1 2 3 ... 37 Previous Next
RoberttheBruce Newcomer 44 posts since
Jan 30, 2007
Currently Being Moderated

Nov 19, 2011 6:59 AM

McAfee Service Host Problem

Very often, and usually just after start-up, a window pops up which tells me 'McAfee Service Host has encountered a problem and needs to close. We are sorry for the inconvenience. If you were in the middle of something, the information you were working on might be lost. Please tell McAfee about this problem. We have created an error report that you can send to us. We will treat this as confidentail and anonymous'. I'm then given two options 'Send Error Report' or 'Don't Send'. Could someone please tell me what the hell this is, what it means and how do I get it to stop ?

  • JaiPrakash Champion 457 posts since
    Nov 5, 2009
    Currently Being Moderated
    1. Nov 21, 2011 10:36 AM (in response to RoberttheBruce)
    Re: McAfee Service Host Problem

    Hi Robert,

    Try to run McAfee Virtual Technician (MVT) this is an automated self-healing tool that can diagnose and fix many problems related to your McAfee product.

    You can download and run McAfee Virtual Technician (MVT) from mvt.mcafee.com

     

    By the way kindly update us with the following information’s:

     

    McAfee Product: Total Protection / Internet Security, etc..?

    Version details of installed McAfee Product:

    (Navigation: Open McAfee product > Click About on the top right)

    • McAfee Security Center:
    • McAfee Virus Scan:

                DAT version:

    • McAfee Personal Firewall:

     

    Version details of Browser: Internet Explorer?


    Thanks,
    Jai Prakash
  • JaiPrakash Champion 457 posts since
    Nov 5, 2009
    Currently Being Moderated
    4. Nov 22, 2011 12:38 PM (in response to RoberttheBruce)
    Re: McAfee Service Host Problem

     

    Hello Robert,

     

    It’s just an incompatibility between one of the software that is installed on the PC which in no way compromises the security of the PC. However we are interested in finding out the incompatible software and getting this fixed for you. Please let us know if you are interested in a call back from our team . If yes, please click on my Avatar image and click on Send Private message and send me your concurrence .

     

     

    Regards,


    Thanks,
    Jai Prakash
  • chappers Newcomer 12 posts since
    Dec 1, 2011
    Currently Being Moderated
    6. Dec 1, 2011 10:09 AM (in response to RoberttheBruce)
    Re: McAfee Service Host Problem

    Hi

     

    I have been having the same problem, an error message saying that McAfee Service Host has encountered a problem and needs to close. The main impact seems to be that it stops my internet browser from working (I am still connected to the internet, but when I try to open a new page, or refresh an already open page, it just hangs).

     

    I am using a Dell PC, operating Windows XP.

    My internet browser is Google Chrome (I tried to open pages in Firefox when it first happened and that was also affected)

     

    My McAfee is through BT NetProtectPlus

    Security Center: v11, build 11.0.623, last update 25/11/11

    Virus Scan v15, build 15.0.294, last update 01/12/11, DAT version 6546

    Personal Firewall v 3.4, build 3.4.0.143, last update 12/09/11

     

    I will try running the MVT as mentioned above, but would love some feedback in the meantime on how to address this!

     

    Many thanks


    Cara Chapman

  • dingdingdingding Newcomer 1 posts since
    Dec 1, 2011
    Currently Being Moderated
    7. Dec 1, 2011 12:36 PM (in response to RoberttheBruce)
    Re: McAfee Service Host Problem

    Hi

     

    The same thing happens to me (McAfee service host has encountered a problem..).  It mostly happens when I'm using VPN (Ivacy), but also randomly. I read up some on the subject and I reinstalled mcaffe - ran the MCPR.exe to clean everything out. Reinstalled. Still same.

     

    Lastly I tried uninstalling the Mcafee siteadvisor which stopped the error message for a while until it popped up again today.

     

    What bugs me the most is that mcAffee security center lets me now that the the firewall has gone down as well due to this error ... and that's not good (for obvious reasons!

     

    I'm running on XP with firefox 8.0.1 and no siteadvisor:)

     

    Pls check in on it since if it closes the firewall it must be a serious bug...

     

    All the best,

     

    Martin

  • Dinz Master 3,223 posts since
    Oct 13, 2009
    Currently Being Moderated
    8. Dec 2, 2011 6:27 AM (in response to RoberttheBruce)
    Re: McAfee Service Host Problem

     

    Hello Robert/Cara & martin,

     

    As Jai said this might be a software incompatibility issue or has a chance of being the fault of a third party software that triggers this error,  When we had this issue reported some months back, we went ahead with calling back the affected users to collect McAfee related logs but then the thread went silent and no body else reported the issue . So we were kindo f stuck there, please let us know since its impacting our machines ,we would require some volunteers here mostly the affected users to provide us the logs that could be analyzed and take this issue further . 

     

    For all three of you I have sent you with an email from Community forums for the call back process, please have it replied so that we could proceed further and nail this down!!!!

     

     

    Regards,


    Dinesh
    Ex Community Admin
  • mgilbert Newcomer 5 posts since
    Dec 7, 2011
    Currently Being Moderated
    9. Dec 7, 2011 2:03 PM (in response to Dinz)
    Re: McAfee Service Host Problem

    Hi, I have started experiencing this problem in the last few days. I have Total Protection running on XP SP3, and I use Chrome browser although IE 8 is installed. No other software has recently been installed (but with all the automatic updates we have thrown at us these days who knows what might have triggered this).

     

    In response to the above, I downloaded the MVT and ran it. It found 5 problems (1 registry error and 4 services not running), it fixed 4 of them but claims it cannot start my personal firewall. This is worrying because Security Centre claims it is up and running. What am I to believe?

     

    Feel free to call on me to help resolve this problem. I am retired so can schedule time as necessary. I want this resolved.

     

    Mike

1 2 3 ... 37 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • Correct Answers - 5 points
  • Helpful Answers - 3 points