2 Replies Latest reply on Dec 20, 2011 9:02 AM by good2go_ia

    VPN Fail

      Does anyone know if the ePO server uses the MAC address to validate a systems identification?

       

      Background information:

       

      I've noticed that when a system is decommissioned, it will still show up in my container. After 30 days of no communication, I delete it. Before the 30 days are up, a new system gets the McAfee agent and communicats with the ePO server no problem even though it is using the same IP address as the one that was recently decommissioned. We recently test another system by ensuring it had good communication with the ePO server. We then changed the IP address of the client and collected and sent props. the ePO server picked up the change with no problems and communication continued with no problems.

       

      The Laptop has an Ethernet NIC that has it's own MAC address. It also has a wireless NIC that has a MAC address. When the Laptop connects to the ePO server via VPN, the VPN connection (CISCO) has it's own MAC address. So which one gets registered with the ePO server???

      The Problem:

       

      We have a bunch of Laptops in remote locations that were on McAfee Agent 4.0 and we migrated them to 4.5. I'm not showing them as managed in my container (Only as unmanaged) and they can't communicate with the ePO server. I've had the user while connected via VPN install the frame package and it installed fine but still no communication with the ePO server. I even had one instance where a help desk person remoted into the system while it was on VPN and installed the package fine but still no ePO communication. We took a problem Laptop and connected it directly to the LAN, installed the Agent and the communication with the ePO server worked fine. We then connected that computer via VPN and no communication with the ePO server. We did this last test because one of the discussion on this forum mentioned connecting it the system on the LAN the first time and it didn't seem to fix it for us. Tomorrow we are going to completely clean the system of all McAfee programs and remnants of it and change the system name and assign it a new IP address. We will also remove it from the ePO Server. We will then connect via VPN and do a fresh install of the McAfee client. I'll post the results of that test tomorrow.

       

      Looking for a good fix for this problem or at least an answer to my first question above.

       

      Thanks for your time...

        • 1. Re: VPN Fail
          JoeBidgood

          Hi...

           

          The most likely cause of this is indeed the MAC address given by the VPN concentrator. If a machine makes its first connection to ePO via VPN, you can get this behaviour. Please see this thread for details:

           

          https://community.mcafee.com/message/105018#105018

           

          HTH -

           

          Joe

          • 2. Re: VPN Fail

            Well, apparently the problem went away by itself. I'm thinking someone outside/above our level might have been messing with group policy. Now, no matter how we install HBSS, either via VPN or directly connected to the network, it works just fine. Changing of the MAC and IP address has no effect on the communication between the agent and server. Thanks Joe for your help.