3 Replies Latest reply on Nov 24, 2011 3:16 AM by mwebb

    EEFF 4.0 & Objectives 8 (EDRMS)

    mwebb

      We've recently deployed the EEFF 4.0 software and have started to experience an issue where users with Objectives installed are not able to save or open files from their network drives.

      With EEFF 4.0 installed, If we stop the Objectives  WinTalkSessionWatcher process then users are able to save their files as usual - but with limited EDRMS functionality.

      If we uninstall EEFF 4.0 from the affected PC's then the users are once again able to save and open files to their network drives.

       

      I have tried to exclude the Objective processes, in the Key Request Exclusion options. There are no network, file or folder encryption policies set. With this set, we are still unable to save or open files to / from network drives.

       

      We have been told that: Objectives WinTalkSessionWatcher works by hooking into the underlying system call when a file is opened and recording details of this file.  This procedure is done in the Microsoft approved way and the original call is redirected back to the correct method. 

       

      We can't uninstall Objectives from the PC's as this is used for the business function of that department and we are expecting it to be used for the entire company in the next year.

       

      Any ideas?

       

      Thanks

       

      Mark

        • 1. Re: EEFF 4.0 & Objectives 8 (EDRMS)

          You should remove Objectives from your key request exclusions list immediately. Doing this tells our software to NEVER provide the EEFF key to that process. This means that it won't be able to encrypt or decrypt files on the fly.

           

          I have not seen this in the field before, so the best I can do is recommend that you open a support ticket on this one.

          • 2. Re: EEFF 4.0 & Objectives 8 (EDRMS)
            mwebb

            Thanks, raising a ticket now with my support provider...

            • 3. Re: EEFF 4.0 & Objectives 8 (EDRMS)
              mwebb

              I was asked to try a couple of things to see if that would help, they were:

               

              • If you are not encrypting folders on shares (thus to using NW encryption) you could easily try to set off the NW encryption by opening the "Network" policy under EEFF and unchecking the "enable encryption" option.

               

                      I hadn't actually turned this feature on, so left it unchecked 

                  

              • Other thing that you can do would be opening the policy called "Encryption Options" and insert the software you are talking about in the blocked processes and see if this helps.

                      I added the processes that Objective uses to the Blocked Processes list, checked that the

                      policy had updated on the PC... same result when attempting to save to network.

               

              I've logged a Product Enhancement Request as I've also been told that Objective has never been QA'd with EEFF. As Objective is a much used product in the public sector I'm hoping something will come of this!