4 Replies Latest reply on Jul 16, 2009 12:06 PM by radman

    Linuxshield Help!!!

      I am running a "stand-alone" virusscanner with RedHat AS 3 update 8 and McAfee LinuxShield 1.5. I am not allowed to connect to the network on this box, (since it is standalone), so I am trying to update the DAT files manually. I downloaded the latest DAT file (.tar format since I am using Linux) and unpacked it in the /opt/NAI/LinuxShield/engine/dat directory. There are 3 files from the initial install that are in that directory, avvscan.dat, avvnames.dat, and avvclean.dat. However if I remove those files and unpack the .tar file (clean.dat, scan.dat, names.dat, and internet.dat, as well as the packing list and a validate.exe file.) the DAT file version never changes. Also, why is there a validate.exe file in a .tar file for a linux box which doesn't use the exe format? Can anyone help me?

      Thanks!
      Jason AKA dummy:confused:
        • 1. Linuxshield Update Help!!!
          Jason you are not a dummy as thoes are the directions given in the documentation that comes with LinuxShield. I am in the same boat. I have a RHEL5 server with LinuxShield on a stand alone network and the manual update procedures do not work. You would think that McAfee would provide support for this product. It is much easyer with Symantecs linux product because the manual update procedure works. However I am mandated to use the McAfee $#!^ product. If you find a solution to this problem please post it here for all of us.
          • 2. RE: Linuxshield Update Help!!!
            andyross
            I'm just wondering if you point the auto-update to point at a directory, and you untar the files into that directory, does it update?
            • 3. RE: Linuxshield Update Help!!!
              I will try it. I am new to McAfee so I will have to look around to find out how to do it. I hope the directions are in the manuals sent with LinuxShield.
              • 4. Problem Solved
                Ok I talked to support, don't ask me who I finaly ended up with but they finaly came up with the answer. The trick is to get the download that has the correct files. It is in the form of avvdat-5678.zip


                1) Download the avvdat-nnnn.zip located here:
                ftp://ftp.mcafee.com/commonupdater/

                2) Extract the contents to /opt/NAI/LinuxShield/engine/dat

                3) Then run CHMOD 750 or 777 against the extracted files

                4) Finally, restart the nails service

                I didn't do step 3 and it still worked for me.