3 Replies Latest reply on Nov 10, 2011 3:47 PM by landmissle

    Problems installing ePO agent onto Linux systems from ePO console

        Hi folks,

       

        I'm able to manually install the install.sh ePO installer package onto a LInux system (RHEL 5) and then push down the Policy Auditor agent down via policy shortly thereafter. However I have not been able to deploy the client from the ePO console. Looking at the security log on the client, I see the following;

       

       

      Nov  7 17:35:55 xevious sshd[3560]: Connection from X.X.X.X port 54383

      Nov  7 17:35:55 xevious sshd[3560]: Accepted password for root from X.X.X.X port 54383 ssh2

      Nov  7 17:35:55 xevious sshd[3560]: pam_unix(sshd:session): session opened for user root by (uid=0)

      Nov  7 17:35:55 xevious sshd[3560]: subsystem request for sftp

      Nov  7 17:35:57 xevious sshd[3560]: Connection closed by X.X.X.X

      Nov  7 17:35:57 xevious sshd[3560]: pam_unix(sshd:session): session closed for user root

      Nov  7 17:35:57 xevious sshd[3560]: Closing connection to X.X.X.X

      Nov  7 17:35:57 xevious sshd[3583]: Connection from X.X.X.X port 54386

      Nov  7 17:35:57 xevious sshd[3583]: Accepted password for root from X.X.X.X port 54386 ssh2

      Nov  7 17:35:57 xevious sshd[3583]: pam_unix(sshd:session): session opened for user root by (uid=0)

      Nov  7 17:35:57 xevious sudo:     root : sorry, you must have a tty to run sudo ; TTY=unknown ; PWD=/root ; USER=root ; COMMAND=./install.sh -i

      Nov  7 17:35:58 xevious sshd[3583]: Connection closed by X.X.X.X

      Nov  7 17:35:58 xevious sshd[3583]: pam_unix(sshd:session): session closed for user root

      Nov  7 17:35:58 xevious sshd[3583]: Closing connection to X.X.X.X

       

       

      It looks like the problem is that sudo has the reguiretty option set based on the line;

       

      Nov  7 17:35:57 xevious sudo:     root : sorry, you must have a tty to run sudo ; TTY=unknown ; PWD=/root ; USER=root ; COMMAND=./install.sh -i

       

      I don't want to turn off that option for security reasons. Is there another way around this?

       

      I've also tried using non-root credentials with and account that can run any command from sudo, but I still get the same error message.

       

      Having sudo set to requiretty is a pretty common secuirty practice so I'm curious what others have done that have Linux/Unix systems in there environment.

       

      I've had no problems pushing the client out to MacOS X systems which also require a ssh session to be established.

       

      Any suggestions?