9 Replies Latest reply on Oct 24, 2011 5:14 AM by exbrit

    Novice Having Problems - Any Suggestions?

      I am not sure if I have malware or not.

      Windows and McAfee are up to date - everything in the Security Center is green.

      I had done a scan shortly before these problems and everything was clean except for tracking cookies which were cleared.

      Then, after clicking on the "Install Now" button for the daily update, I got a message that Real Time Scanning had been turned off.

      I turned Real Time Scanning back on and did a quick scan.

      It came back and said it had cleaned up 4 trojans, though I'm not sure if this meant for this scan or over its history. Looking at some history led me to believe this was in the past, but this is no longer clear in my mind.

      From here on out Real Time Scanning will keep turning itself back off after I turn it on.

      I tried to do a full scan.
      I got an error message and it said to go back to home and try again.
      Now anything I tried to do would give “Failed to Create iDispatch” error message.

      I disconnected from the internet and Restarted the computer.

      Now I could start the scan, but it gets partway through and errors out. All it says is “An error has occurred” – no descriptive information.
      I tried Restarting again – same problem.

      I tried to run MVT. I would end up trying to run it a number of times because each time I had to reboot and start over and would go back to the website, it would insist on me downloading/running it again before it would let me click on something else. I could not even get the FAQ link to respond. One time on reboot it hung on Initializing for 20 minutes before I stopped the task and ran from the version already on my computer. When it would run I would get the error:

      McAfee Virtual Technician Application has stopped working. A problem caused the progrm to stop working correctly. Windows will close the program and notify you if a solution is available. Then nothing.

      I watched the video on the Realtime Scanning. No help. When I clicked on the oas-disabled-fix link I got:
      pushd "%CommonProgramFiles%\McAfee/VSCore"
      mfehidin -i -x vscore.xml oas firecore scriptscan
      popd

      I checked the list of incompatible programs and did not have any installed.

      I made numerous attempts to run a scan and it still bombed out rather early on, just telling me there is an error. I do not get a chance to see what file it is checking when it bombs. Is there a log somewhere that you can look at?

      At this point I was rather frustrated, especially with trying to use the McAfee website. As already mentioned it tries to be too smart to force you to go through the steps it wants you to go through.

      Getting to the file with the incompatibilities list required finding my way back to the video on Real Time Scanning, because typing in the link, or searching on the site would tell me the document did not exist. Only by clicking on that link in the video could I get to it.

      I followed the instructions for checking for malware. I booted in safe mode and ran the scan and then sniper. Neither one turned up anything. I ran sniper the 2nd time with heuristics set to very high and it didn't turn up anything.

      I then rebooted back in normal mode. I was able to run a quick scan but as soon as it finished the iDispatch error popped up. The only way I can do a second thing in McAfee is to reboot.

      I rebooted and am trying to do a full scan. The full scan can has been running for hours and is only at 31%, which is typical, so I am not sure if it will run to completion this time – it has gotten further than it was getting before. However, I imagine I will still have the iDispatch error problem. I am not sure about the switching out of real time scanning. It has not done that since rebooting out of safe mode.

      Another notice to update came in while all of this was going on and I did the install. Maybe it helped a little, but things are still not right.

      My inclination is to uninstall and reinstall McAfee. I don't have a disk. I downloaded my initial copy. Do I just go through Program Files and Remove, and then go to my account and Download? Are there any tricks to make sure I get it fully uninstalled? Is there some other faster/better way to solve these problems? Do you think I do have a virus and if so, how to find it?

       

      When the full scan finishes I can retry the MVT - that will be day 4 of this saga. And if it doesn't work ... So, I don't want to wait to post this in case there is something obvious I am missing, and I am just running around in circles. I have followed other links about the iDispatch and Real Time issues and they did not lead me to resolution. Thanks for any help you can give.