2 Replies Latest reply on Oct 4, 2011 10:57 AM by mardes

    MWG coordinator not running after move to new VMware host

    mardes

      Hello!

       

      we moved out MWG 7.1.02. virtual appliance to new VMware host.

      There the service  mwg-coordinator fails to start because it does not find a valid configuration.

       

      I think in the configuration there som part which depends on hardware.

       

      Because mwg-coordinator is not running we have no access to GUI also.

       

      How can we fix this?

       

      Some details:

       

      When starting service mwg-coordinator manually we see

       

      [root@wh00ms1ww01

       

      ]# /etc/init.d/mwg-coordinator start

      Starting McAfee Web Gateway Coordinator: ..................[FAILED]....

      [root@wh00ms1ww01

       

      ]#

       

      or

      [root@wh00ms1ww01 storage]#  /opt/mwg/bin/mwg-coordinator -l "file:out=stdout" -n

      [2011-10-04 13:48:25.834 +02:00] debug logging is switched on with configuration: 'file:out=/dev/stdout;options:file=append,multiline=no,colored=no;threadids:ALL =yes;threadtypes:ALL=yes;plugins:ALL=3;classes:ALL=yes;fields:ALL=yes'.

      Coordinator: [2011-10-04 13:48:25.834 +02:00] [Coordinator] [StartApp] Starting 'McAfee Web Gateway Coordinator version: 7.1.0.2.0 - build: 10666' - 'No FIPS mode'

      [2011-10-04 13:48:25.834 +02:00] [Coordinator] [7448] [main] [Coordinator] [1] [CMainCppBase] >>ERRORS.LOG>> [StartApp] Starting 'McAfee Web Gateway Coordinator version: 7.1.0.2.0 - build: 10666' - 'No FIPS mode'

      [2011-10-04 13:48:25.834 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CMessageServer] sucessfully started message server on: /opt/mwg/.socket/.ipc_cmd_to_coord:0

      will serve: kMTPing kMTShutdown kMTKill kMTRestart kMTDump kMTFeedback kMTStatus kMTDebug kMTSpecialCommand

      [2011-10-04 13:48:25.835 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CApp] initializing OpenSSL...

      [2011-10-04 13:48:25.835 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CApp] initializing CClusterIncidentManager...

      [2011-10-04 13:48:25.835 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CApp] initializing storage.log...

      [2011-10-04 13:48:25.835 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CApp] initializing migration.log...

      [2011-10-04 13:48:25.836 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CApp] initializing update.log...

      [2011-10-04 13:48:25.836 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CApp] initializing message.log...

      [2011-10-04 13:48:25.836 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CApp] initializing scheduledjob.log

      [2011-10-04 13:48:25.836 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CApp] initializing CStorageManager...

      [2011-10-04 13:48:25.836 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CAppPaths] PseudoPath 'active_configuration' requested, reading file content of '/opt/mwg/storage/active_configuration'...

      [2011-10-04 13:48:25.836 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CAppPaths] PseudoPath 'active_configuration' resolves to: '/opt/mwg/storage/default/initial/'

      [2011-10-04 13:48:25.836 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CStorageManager] unable to find the incorrect uuid folder '/opt/mwg/storage/default/initial/global/00000000-0000-0000-0000-000000000000'

      [2011-10-04 13:48:25.836 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CAppPaths] PseudoPath 'active_configuration.save' requested, reading file content of '/opt/mwg/storage/active_configuration.save'...

      [2011-10-04 13:48:25.836 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CAppPaths] PseudoPath 'active_configuration.save' resolves to: '/opt/mwg/storage/default/2011-09-29_12-32-44-627_+0200'

      [2011-10-04 13:48:25.837 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CStorageManager] unable to find a last valid config folder

      Coordinator: [2011-10-04 13:48:25.837 +02:00] [Coordinator] [StorageCannotFindValid] Cannot find a valid configuration.

      [2011-10-04 13:48:25.837 +02:00] [Coordinator] [7448] [main] [Coordinator] [1] [CStorageManager] >>ERRORS.LOG>> [StorageCannotFindValid] Cannot find a valid configuration.

      Coordinator: [2011-10-04 13:48:25.837 +02:00] [Coordinator] [StorageCannotCorrect] Cannot correct storage folder setup.

      [2011-10-04 13:48:25.837 +02:00] [Coordinator] [7448] [main] [Coordinator] [1] [CStorageManager] >>ERRORS.LOG>> [StorageCannotCorrect] Cannot correct storage folder setup.

      Coordinator: [2011-10-04 13:48:25.837 +02:00] [Coordinator] [StartInitWillFail] initialization of main application object will fail because of error: 'CStorageManager'

      [2011-10-04 13:48:25.837 +02:00] [Coordinator] [7448] [main] [Coordinator] [1] [CApp] >>ERRORS.LOG>> [StartInitWillFail] initialization of main application object will fail because of error: 'CStorageManager'

      [2011-10-04 13:48:25.837 +02:00] [Coordinator] [7448] [main] [Coordinator] [3] [CIPCServerBag] requesting shuttdown for mes

       

       

      Best regards,

       

      Michael

        • 1. Re: MWG coordinator not running after move to new VMware host

          Each MWG appliance's configuration (physical or virtual) is dependent on the motherboard's UUID.

          When you perform a move or copy of a virtual system, it will usually change that UUID to a new value.

          Because the actualy UUID of the system has changed, it will no longer be valid and cannot operate.

           

          You may be able to manually change the UUID back to it's original value by editting the .vmx file to it's original settings.

           

          My .vmx file has these manually set:

          uuid.bios = "ee ee ee ee ee ee ee ee-ee ee ee ee ee ee ee ee"

          vc.uuid = "ee ee ee ee ee ee ee ee-ee ee ee ee ee ee ee ee"

           

          This corresponds directly to the settings in the folder:

          Capture.GIF

          If you change your .vmx file to reflect the values MWG already knows, you might have a chance at recovering the configuration and have it work again.

          • 2. Re: MWG coordinator not running after move to new VMware host
            mardes

            Thank you very much,

             

            we set old UUID  in .vmx configuration and set  uuid.action = "keep"

             

            Now all MWG services run normally.

             

            Best regards,

             

            Michael Ardes