3 Replies Latest reply on Oct 1, 2012 3:25 PM by kenobe

    Mcafee Agent setup failed

      I am trying to intall Mcafee Agent on a Win 2008 server.  The Installation is faling with the following error :

       

      "Mcafee agent setup failed"

       

      I have Mcafee version 8.7 on the server ,

      Attached are the logs .

      Plesae help

        • 1. Re: Mcafee Agent setup failed
          JoeBidgood

          Hi...

           

          It looks like the agent is failing to add itself to the Windows firewall.

           

          If you remove VSE and try and install just the agent, does that succeed?

          Make sure you are running framepkg by right-clicking and choosing Run As Administrator, even if you are logged in as an admin.

          Do the same thing happen if you try and install MA 4.6?

           

          Thanks -

           

          Joe

          • 2. Re: Mcafee Agent setup failed
            rackroyd

            Well, the error root seems to be here in the msi log:

             

            CustAct [11:46:55:36] main [I] addToWindowsFirewall START

            CustAct [11:46:55:52] Cmalib [E] Error trace:

            CustAct [11:46:55:52] main [E]  [addToWindowsFirewall START]->

            CustAct [11:46:55:52] Cmalib [E]  [Add CMA to Windows Firewall]->

            CustAct [11:46:55:52] Cmalib [E]   error -2147024894: The system cannot find the file specified.

            CustAct [11:46:55:68] main [I] addToWindowsFirewall END

            CustomAction AddToWindowsFirewall returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

             

            Whether this means an actual failure to add the agent to the firewall exceptions or something else I cannot say.

            There are similar error codes in relation to multiple copies of cryptocme2.dll on host systems (but mainly in relation to ePO rather than MA).

            Still, I suggest you check the McAfee Support knowledge base for cryptocme2.dll as there are articles which tell you how to check for that as a possible issue.

            https://mysupport.mcafee.com/Eservice/Default.aspx

             

            Rgds,

             

            Rob.

            • 3. Re: Mcafee Agent setup failed
              kenobe

              Remove the frame package

              "C:\Program Files (x86)\McAfee\Common Framework\frmisnt.exe" /forceunisntall

               

              Install the new frame package

              Right-click on the framepkg.exe file and choose "Run as Administrator"

               

              Should be done.