3 Replies Latest reply on Sep 23, 2011 7:08 PM by Peter M

    Just in time debug

    tomcleaves

      For the third time in about 3 months I have started getting a Just in Time debug error when McAfee tries to check for updates. The JIT pops up when I start my computers in the morning and during the day each time McAfee checks for updates. This time it is happening on 2 of my 3 computers and seems to be tied to a recent update that required a reboot (probably last Monday or Tuesday Sept 19 or 29). That's when it started. I have turned off Just in Time in IE. I don't used IE - I use Firefox. JIT doesn't seem to be tied to the browser. It pops up even if I have nothing on the screen except my desktop. No browser, no software, nothing.  It's getting very frustrating. The only way I have been able to fix the problem is to reinstall McAfee. And that only lasts until McAfee does a major update. I have been online with McAfee suppport and they can't do anything. Last time I posted a question here. I got a reply from Ex_Brit. He suggested turning off JIT in IE - which I did. He also suggested Visual Studio, which I don't have.

        • 1. Re: Just in time debug
          Hayton

          JIT seems to be associated with Visual Studio, Microsoft .NET, and SQL Server. When an error occurs JIT kicks in where normally you would expect Dr Watson to handle the error debugging. Microsoft have an article on how to re-establish Dr Watson as the default error-handler at http://support.microsoft.com/kb/923827/en-gb.

           

          The relevant section says

          You can re-enable the Dr. Watson program to catch unhandled exceptions. After you do this, the Visual Studio JIT debugger will no longer catch unhandled exceptions. To do this, follow these steps:

          1. Click Start, click Run, type cmd, and then click OK.
          2. Type the following command, and then press ENTER:drwtsn32 -i

           

           

          See if that works.

          • 2. Re: Just in time debug
            Peter M

            Tom, sorry my suggestions didn't help you a month ago.   What operating system and service pack are you using and what version of Internet Explorer is installed?  (Regardless of your default browser setting - many processes use it anyway).

             

            You also mentioned last time that paid Technical Support were no help.   You can obtain free support using online chat and I believe that some phone support is now free too.  If they can't help at the first contact ask them to escalate the issue.

            • 3. Re: Just in time debug
              Peter M

              Another thing to try:

               

              Open the registry (use regedit, Click Start, Run, Regedit).

              Go to this key:

              HKEY_CURRENT_USER\Software\Microsoft\Windows Script\Settings\JITDebug

              Double-click it in the right hand pane

              And set it to 0.

              Click OK

              Close the editor.

               

              (Normally it is set to 0 anyway but something has possibly changed that).

               

              Message was edited by: Ex_Brit on 23/09/11 8:08:28 EDT PM