1 2 Previous Next 10 Replies Latest reply on Oct 1, 2011 11:13 AM by repolew

    Security Center won't display + McSvHost CPU spike

      Two problems simultaneous occuring, new in past 4 days. I don't know if they are related.

      1. Attempted to open Security Center to verify a weekly scheduled scan and cannot get it to open from either the desktop icon for mcagent (double click does nothing) or taskbar icon (right click does nothing). Have not seen related posts for this issue.
      2. Have noticed a large CPU increase by the McSvHost process. Almost continually at 35-50%, sometimes as high as 75%, even when computer is mostly idle. Lots of related posts for this issue.

       

      Numerous restarts including cold boots have not resolved the issues.

      Also tried Virtual Technician but cannot connect to server. (Seen other posts on this one, too.)

      As with most folks, I want to avoid a reinstall mainly because I have custom firewall settings that might be difficult to re-establish.

       

      Any ideas would be welcomed. Thanks.

       

      Brief Specs:

      - WIN XP

      - McAfee AntiVirus Plus 15 (I think - don't know how to verify this without opening Security Center) with automatic updates activated

      - latest DAT is 6465.0 from Sept 10 (hmmmm)

      - anything else that would be helpful??

        • 1. Re: Security Center won't display + McSvHost CPU spike

          Disabling Netguard under Firewall shoud fix the second problem you listed until a proper fix is made. As for the first issue I've not experienced it. My apologies.

          • 2. Re: Security Center won't display + McSvHost CPU spike
            Dinz

             

            Please try the below steps ;

             

            Click on Start > Click on Run

            Type : services.msc

            Please follow the below steps for all McAfee services in this window

            From this window – right click on McAfee services and click on properties  (If you encounter any error in the mid, please skip and move ahead)

            Select the Startup type to be automatic

            Click on the tab – Recovery

            Select all three failures to be Restart the service

            Click on Apply and then hit OK

             

            Restart the computer and then try opening security center through both the icons and let know the status . 

            • 3. Re: Security Center won't display + McSvHost CPU spike

              No improvement today,

               

              Can't access Firewall to disable Netguard due to lack of Security Center.

               

              Updated services, some did not allow changes. Restarted. Security Center still nonresponsive through both icons.

               

              All McAfee services were started except for VirusScan Announcer. It was set to automatic. Attempted to start manually and got error 0x80070006: "The handle is invalid."

               

              Hmmm, while typing this note, just received crash alert from McAfee Service Host. 

              szAppName : McSvHost.exe     szAppVer : 2.0.230.0     szModName : unknown    

              szModVer : 0.0.0.0     offset : 03e90296   

               

              Not sure where I stand now.

              • 4. Re: Security Center won't display + McSvHost CPU spike
                JaiPrakash

                Hi repolew,

                 

                Please try the steps below and keep us posted on the progress;

                Run the McAfee removal tool from here : http://download.mcafee.com/products/licensed/cust_support_patches/MCPR.exe

                Restart the PC

                Run the Mcpreinstall tool : http://download.mcafee.com/products/licensed/cust_support_patches/McPreInstall.e xe

                Open Internet explorer – click on Tools – click on Windows Updates and install any available updates from the  web

                Login to your McAfee account here : http://us.mcafee.com/root/login.asp and reinstall your products.

                 

                Let us know if you the status of security center after the reinstallation !

                 

                 

                Regards

                1 of 1 people found this helpful
                • 5. Re: Security Center won't display + McSvHost CPU spike

                  Before I reinstall, let me pass along these excerpts from some log files. These lines repeat many many times. After each log file reaches 151KB a new file is started with a sequential number suffix such as McSvHost002.log. I will archived all of the logs for future reference.

                   

                  McSvHost log (in MCLOGS\MISP\McSvHost folder)

                   

                  09/16/2011 08:14:25 PM$ -- (Critical)$ [   McSvHost.exe]$ **MCTASKSHD** VALIDATION FAILED. Task: c:\PROGRA~1\mcafee.com\agent\mcupdate.exe. We will reset the next run time.

                  09/16/2011 08:14:25 PM$ -- (Information)$ [   McSvHost.exe]$ **MCTASKSHD** There is an item waiting to be executed in the Q. First checking if user is running a full screen application

                  09/16/2011 08:14:25 PM$ -- (Critical)$ [   McSvHost.exe]$ **MCTASKSHD** VALIDATION FAILED. Task: c:\PROGRA~1\mcafee.com\agent\mcupdate.exe. We will reset the next run time.

                   

                  McSvHost log (in MCLOGS\MPF\McSvHost folder)

                   

                  09/16/2011 08:04:27 PM$ -- (Error)$ [     mpfsvc.dll]$ MfeFire::Register failed: 0x80000003 [FWSTATUS_NOT_INITIALIZED]

                  09/16/2011 08:04:27 PM$ -- (Error)$ [     mpfsvc.dll]$ HidLinkLoadCreate:87

                  09/16/2011 08:04:33 PM$ -- (Error)$ [     mpfsvc.dll]$ MfeFire::Register failed: 0x80000003 [FWSTATUS_NOT_INITIALIZED]

                  09/16/2011 08:04:33 PM$ -- (Error)$ [     mpfsvc.dll]$ HidLinkLoadCreate:87

                  09/16/2011 08:04:40 PM$ -- (Error)$ [     mpfsvc.dll]$ MfeFire::Register failed: 0x80000003 [FWSTATUS_NOT_INITIALIZED]

                  09/16/2011 08:04:40 PM$ -- (Error)$ [     mpfsvc.dll]$ HidLinkLoadCreate:87

                   

                  Explorer log (in MCLOGS\MSC\Explorer folder)

                   

                  09/16/2011 08:04:02 PM$ -- (Error)$ [   mcctxm~1.dll]$ The requested lookup key was not found in any active activation context.

                  09/16/2011 08:04:02 PM$ -- (Error)$ [   mcctxm~1.dll]$ The operation completed successfully.

                  09/16/2011 08:04:33 PM$ -- (Error)$ [   mcctxm~1.dll]$ The requested lookup key was not found in any active activation context.

                  09/16/2011 08:04:33 PM$ -- (Error)$ [   mcctxm~1.dll]$ The operation completed successfully.

                  09/16/2011 08:06:14 PM$ -- (Error)$ [   mcctxm~1.dll]$ The requested lookup key was not found in any active activation context.

                  09/16/2011 08:06:14 PM$ -- (Error)$ [   mcctxm~1.dll]$ The operation completed successfully.

                   

                  McAgent log #1 (in MCLOGS\MISP\McAgent folder)

                   

                  09/16/2011 08:09:37 PM$ -- (Information)$ [    mcagent.exe]$ CMcMainUIModule::moduleRun called. Current thread = 5480

                  09/16/2011 08:09:38 PM$ -- (Error)$ [    mcagent.exe]$ Failed to create MSC CShim interface. ErrorCode: 80070005

                  09/16/2011 08:09:38 PM$ -- (Error)$ [    mcagent.exe]$ Create updateSetting returned:80070005

                  09/16/2011 08:09:38 PM$ -- (Information)$ [    mcagent.exe]$ screen resolution:1280X1024

                  09/16/2011 08:09:38 PM$ -- (Error)$ [    mcagent.exe]$ Error Creating the browser control.

                  09/16/2011 08:09:38 PM$ -- (Error)$ [    mcagent.exe]$ Could not create the main frame window of the Shell. Error: 168109843

                  09/16/2011 08:09:38 PM$ -- (Error)$ [    mcagent.exe]$ There was an error creating the main frame window of the application

                   

                  McAgent log #2

                   

                  09/10/2011 08:00:44 PM$ -- (Error)$ [    McRtMui.dll]$ Boolean check failure.

                  Expression 'pathComponents.size() > 1' of type 'bool' evaluates to false.

                  Invalid argument: expected a full path

                  pwszPath=0x004AA830 L"mcuilib.dll"

                  caller={ module='C:\Program Files\McAfee.com\Agent\mcagent.exe', version=11.0.575.0, offset=0x3687F }

                  Last OS Error: ERROR_BAD_LENGTH (The program issued a command but the command length is incorrect)

                  09/10/2011 09:36:51 PM$ -- (Error)$ [    mcagent.exe]$ dupiclicate LCID=7169 found, failed to insert into map list

                  09/10/2011 09:36:51 PM$ -- (Error)$ [    mcagent.exe]$ dupiclicate LCID=9217 found, failed to insert into map list

                  09/10/2011 09:36:51 PM$ -- (Error)$ [    mcagent.exe]$ dupiclicate LCID=6154 found, failed to insert into map list

                  ... many lines snipped that were identical to below at different times...

                  09/16/2011 08:09:37 PM$ -- (Error)$ [    mcagent.exe]$ dupiclicate LCID=7169 found, failed to insert into map list

                  09/16/2011 08:09:37 PM$ -- (Error)$ [    mcagent.exe]$ dupiclicate LCID=9217 found, failed to insert into map list

                  09/16/2011 08:09:37 PM$ -- (Error)$ [    mcagent.exe]$ dupiclicate LCID=6154 found, failed to insert into map list

                   

                  McSvHost log (in MCLOGS\HomeNet\McSvHost folder)

                   

                  09/15/2011 10:13:30 PM$ -- (Error)$ [    McNASvc.dll]$ FireCore registration failed

                  09/15/2011 10:13:31 PM$ -- (Error)$ [    McNASvc.dll]$ AppControllerThread: can't create instance (clsid{AADB3E19-1DF3-41F9-BB45-9C7DCCE13082}): 0x80070005

                  09/15/2011 10:13:31 PM$ -- (Error)$ [   McNmcSrv.dll]$ CMcNmcProMgr2Itf::initialize - Failed to Launch Protection Manager 2

                  09/15/2011 10:13:31 PM$ -- (Error)$ [   McNmcSrv.dll]$ CMcNmcPearlMSCHandler::_initializeProMgr2Itf - failed to initialize

                  09/15/2011 10:13:31 PM$ -- (Error)$ [   McNmcSrv.dll]$ CMcNmcPearlMSCHandler::initialize - _initializeProMgr2Itf failed

                  09/15/2011 10:13:31 PM$ -- (Error)$ [   McNmcSrv.dll]$ CMcNmcPearlMSCHandler::_getVirusScanInformation - m_coProMgr2Itf is NULL

                  09/15/2011 10:13:31 PM$ -- (Error)$ [   McNmcSrv.dll]$ CMcNmcPearlMSCHandler::_getUpdateInformation - m_coProMgr2Itf is NULL

                  09/15/2011 10:13:31 PM$ -- (Error)$ [   McNmcSrv.dll]$ CMcNmcPearlMSCHandler::_getSubscriptionInformation - m_coProMgr2Itf is NULL

                  09/15/2011 10:13:31 PM$ -- (Error)$ [   McNmcSrv.dll]$ CMcNmcPearlMSCHandler::_getSecurityStatusInformation - m_coProMgr2Itf is NULL

                  09/15/2011 10:13:38 PM$ -- (Error)$ [   McNmcSrv.dll]$  CMcNmcNetworkHandler :CMcNMCFirewallHelper:McCreateInstance2 for McPersonalFirewallConfig Failed hr = 80070005

                  09/15/2011 10:13:38 PM$ -- (Error)$ [   McNmcSrv.dll]$ Update State change from MPF - Unable to get MPF network status - returning

                  09/16/2011 12:22:35 AM$ -- (Error)$ [    McNASvc.dll]$ NAPR: _sendMulticastMessage failed to connect to node a9b4d91a-b106-4e80-9a05-89fcc679ff83 repeatedly. Node must be offline. Resetting. Error code :402784343

                  • 6. Re: Security Center won't display + McSvHost CPU spike
                    JaiPrakash

                    Were you able to get the issue fixed after the reinstall ?

                    • 7. Re: Security Center won't display + McSvHost CPU spike

                      McAfee software is working again after reinstall with no CPU spikes either. Next Sunday is first scheduled scan with new image. If that runs successfully, I'll be back at 100%.

                      • 8. Re: Security Center won't display + McSvHost CPU spike

                        Scheduled scan did not run as defined.  Will follow up by searching other threads.

                        • 9. Re: Security Center won't display + McSvHost CPU spike
                          Dinz

                          Hello repolew,

                           

                          This is something weird happening with McAfee scheduled scan which we are interested to resolve for you . Please check your mail box as I have sent you with one for a  call back from us for this issue

                           

                          Regards,

                          1 2 Previous Next