3 Replies Latest reply on Nov 2, 2011 3:58 AM by dmease729

    Unable to access boot menu to initiate fresh build from bootimage

    dmease729

      Hi,

       

      Major problems with an I3000 device have led me to want to start a fresh build, as per kb55591.  Problem is,

      when trying to follow through 'Solution 2' on this KB, I press F2, and it prompts me to press Esc to enter the boot menu.  If I do not press Esc at this point, the sensor just boots up as normal (starts with 'Initializing the System' etc).  If I do press Esc at this point, I get a screen (screenshot2.jpg,  below) asking which OS to boot.

      How precisely do I get to the boot menu???

       

      Note that when connecting via Hyperterminal or putty, the screen is constantly refreshing, making it difficult to know when exactly to press F2, so I usually have to press it a few times ('press F2' is still displayed when I do), before anything happens...

       

      Could somebody let me know if there is a certain special way of pressing F2 before I go and curl up in a ball in the corner?

       

      cheers,

       

      screenshot2.jpg

        • 1. Re: Unable to access boot menu to initiate fresh build from bootimage
          SGROSSEN

          Dmease,

          You will need to do the netboot via Hyperterminal.  Once you get Hyperterminal connected up and diplaying the Sensor ouput, pull plug on back of Sensor.

          One you plug it back in, start pressing F2 right away.  If you do that, you should drop into the BIOS of the sensor and see what looks like what you might see on a computer BIOS.   Along the top will be a couple menu choices, and you will want to select "Boot Device Priority".   I've cut and pasted the instructions once you have entered setup below... complete instructions and neboot image located here: 

          https://menshen.intruvert.com/image.

           

          If you hit F2 soon enough, you should not get to the screen shot posted above.   Also, make sure keyboard is able to pass F2 command through to Hyperterminal.  It may be a USB keyboard thing... possibly a laptop wth com1 available for Hyperterminal would work

           

          12. Press F2 when prompted to enter Setup.

          Under Boot Device Priority will be a list of boot devices:

          + HardDrive

          Network Boot

          ! Removable Devices

          ! CD-Rom Drive

          eeprom100.Izrom

          Move eepro100.. to the top of the list of Boot Devices by moving the + sign.

          Press ESC twice to return to the main menu.

          13. Select the Fail Safe Boot field and change it to Disable.

          14. Press ESC twice to return to the main menu.

          15. Select Exit, then Save Settings. The Sensor will now reboot.

          16. Connect the Sensor Management port to the local LAN where the TFTP server

          resides.

          The Sensor will prompt for an IP address for itself, enter an IP address that

          is local to the TFTP server address.

          17. Enter the TFTP server IP address at the following Sensor prompt.

          18. The Sensor will now request the Gateway IP address, if a gateway is needed enter

          this address, otherwise press enter.

          19. The Sensor will prompt for the bootfilename.

          Enter the name of the nbi file (including extension) stored in root directory of the

          TFTP server.

          20. The Sensor will now begin the download process. Upon completion of the file

          download, the Sensor will prompt for the default Username and Password, this is:

          admin/admin123.

          IMPORTANT: Do not reboot the Sensor yet.

          21. We must now push a Sensor image to the Sensor via the TFTP server and the

          loadimage command.

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

          • 2. Re: Unable to access boot menu to initiate fresh build from bootimage
            dmease729

            Hi,

             

            As per my original post, I have tried with both Hyperterminal and Putty.  The F2 command must be passed, as I am interrupting the boot sequence, just getting to the wrong screen.

            Your comment regarding hitting F2 'soon enough' intrigues me though - are there two different menus you can get at by pressing F2 at different times in the boot?  I would have thought that if I didnt hit F2 soon enough that the sensor would just boot as normal, which is not the case in the above?

            I already have the netboot process PDF saved from menshen, but I am not getting far enough with F2 at present.  The detailed process is appreciated, however.  If I make any progress on this, I will update this thread.

             

            Cheers,

            • 3. Re: Unable to access boot menu to initiate fresh build from bootimage
              dmease729

              Hi,

               

              After further discussions with McAfee support, I wanted to try every single combination possible, and one of these tests involved using hyperterminal from another laptop (note that on this one I was running windows7 so had to copy across hypertrm.exe and hypertrm.dll from a 2003 server VM) and F2 worked as intended. 

              McAfee support had also suggested using the DB9<->DB9 straight thru cable that comes with the server, instead of USB/serial adapter.  For reference, this did not work with putty but did work with hyperterminal.  I have not yet tested hyperterminal when using the USB/serial connection.

               

              So sgrossen - apologies, your advice is spot on.  What I cannot figure out is why hyperterminal did not work from my older laptop (XP SP3) but did work from Win7 (when hypertrm.X files copied), and also why this does not seem to work with putty at all.

               

              Anyhoo, rebuild complete, and as it turns out in the particular case I am working on, sensor continues to look faulty.  All fun and games!

               

              Cheers,