1 2 Previous Next 17 Replies Latest reply on Jun 27, 2011 10:36 PM by bubblesnout

    Safeboot 4.1 Synchronisation Problem

      Firstly, I'm well aware that SafeBoot 4.1 is old and unsupported. If it was up to me we would ve running a new version, trust me. I've just come on board with a customer who has been using SafeBoot 4.1 so I don't really have much choice. I'm hoping some people here have experience with it.

       

      Basically, we're having an issue where new clients can't synchronise with the server, so any user additions can't be saved to the machine. We've noted that any machines in the organisation that were set up before we came on board are indeed still synchronising fine. Here's what I have done:

       

      1. Created a new installation set by opening up SafeBoot Administrator, going to the 'Machines' tab, right clicking the machine group that all the machines are in and choosing 'Create Installation Set'. I create an 'Online' installation set, using the only database connection available and selecting 'Try the last good connection first'.

      2. I use this installation set on a cleanly imaged laptop, and restart the computer. I am able to log in past the safeboot screen using our default username.

      3. I find the automatically created machine in the SafeBoot Administrator and look at its properties, then add a user to it.

      4. I go back to the laptop and right click the SafeBoot icon and choose 'Synchronise ', then click 'Show Status' to see what is happening.

      5. The activity log shows it get as far as 'Checking for screen saver updates', and it just stays there.

       

      If I manually synchronise again, the activity log doesn't move at all. I can re-synchronise, restart and try again as many times as I want, it just never gets any further than this. I'm totally at a loss, I've spent countless hours trying to figure it out. I've completely disabled antivirus and firewalling on the computer with no luck. I've tried copying all the program files from a computer I know is working across, still no good. Completely run out of ideas. Any help would be much appreciated!

        • 1. Re: Safeboot 4.1 Synchronisation Problem
          rbdudani

          this problem is only on one machine or every new machine you install ?

           

          r u able to telnet both server and client on thier spicific ports (default 5555, 5556) vice-versa ?

           

          could you please post LOGS here (you will get it from) SCMLOG.txt  (in safeboot foldeR)

           

          try  to synchronize after safeboot Client manager service restart

           

          Can you send Snapshot of installation set creation ? (the tab where you are selecting Available Database connection)

           

           

          Message was edited by: rbdudani on 6/26/11 9:06:38 PM CDT

           

          Message was edited by: rbdudani on 6/26/11 9:08:22 PM CDT
          1 of 1 people found this helpful
          • 2. Re: Safeboot 4.1 Synchronisation Problem

            This is on every new machine, not just one.

             

            I can telnet to the server on port 5555, but can't telnet to the local client (127.0.0.1 from the client) on port 5556. Seems strange...

             

            I've attached a SCMLOG.txt from one of these machines. I've just put a clean image on it, and installed SafeBoot on it, so the log isn't very big, but it shows you where it gets stuck.

             

            Here's a screenshot of the database configuration I'm choosing on the installation set creation

            createinstallationset.png

             

            And here's the information of the selected database

            databaseinfo.png

             

            Message was edited by: bubblesnout - Added screenshots on 6/26/11 10:03:20 PM CDT
            • 3. Re: Safeboot 4.1 Synchronisation Problem
              rbdudani

              logs says machines are synching with server.. (so there is no connectivity issue as Machine ID is created)

               

              are you getting any error on server or client when you add users ?

              • 4. Re: Safeboot 4.1 Synchronisation Problem

                When I add a user to a machine on the server, it appears to work fine. If I go back and look at the properties of the machine then I can see it is added fine. The user never actually gets set up on the laptop though. If I try and log in past SafeBoot as the user I have added, it tells me it is an unknown user. The logs should also show a user being added when it is synchronising, which it isn't doing.

                • 5. Re: Safeboot 4.1 Synchronisation Problem
                  rbdudani

                  r u sure you are adding user to right machine ?? for example if we talk about machine for which you posted logs here

                   

                   

                   

                  its machine ID is 000008bc

                   

                   

                   

                  so please croass verfiy that you are adding user to right machine..

                  • 6. Re: Safeboot 4.1 Synchronisation Problem

                    Yes, user is definitely added to right machine. You can see from the logs that although it can connect to the server, it isn't actually synchronising properly. It does the initial synchronisation (where it creates the machine object, etc.) fine, but after that it doesn't. It gets stuck on 'Checking for screen saver updates'. On a computer that works, it shows 'Synchronisation complete', and then 'Automatically synchronising again in 60 minute(s)'. I don't get those entries on the new machines that aren't working.

                     

                    And also like I mentioned earlier, I can't telnet to the client on port 5556, however on the old machines that are still synchronising fine I CAN telnet to them on port 5556. So it's something wrong with the client, just not sure what.

                     

                    Message was edited by: bubblesnout on 6/26/11 11:59:52 PM CDT
                    • 7. Re: Safeboot 4.1 Synchronisation Problem
                      rbdudani

                      hmmmm, got you

                       

                       

                      please send me snap shot of preoperties > Files

                      1. for working

                      2. for not working

                       

                      (Just wanted to know what is selected in file group)

                       

                       

                       

                       

                       

                       

                       

                       

                       

                      and on every not workling machine r u geting same as below logs

                       

                      06/27/11 12:53:46    recovering from power failure 

                       

                      Message was edited by: rbdudani on 6/27/11 12:08:00 AM CDT
                      • 8. Re: Safeboot 4.1 Synchronisation Problem

                        Yes all machines that aren't working are displaying the same behaviour in the logs.

                         

                        Here's the screenshots you asked for:

                         

                        Working:

                        working1.pngworking2.png

                         

                        Not working:

                        notworking1.pngnotworking2.png

                         

                         

                        Thanks for your help so far!

                        • 9. Re: Safeboot 4.1 Synchronisation Problem

                          Here's something interesting... I left this laptop going and on the network last night. Since SafeBoot was only installed yesterday morning, the hard drive was still encrypting. Naturally, it takes a number of hours to finish the encryption. After the encryption had completed, it successfully synchronised. If I now perform a manual synchronisation, it works fine.

                           

                          So basically the behaviour I'm seeing, is that a machine will only synchronise after the hard drive encryption is completed. I have attached the log from this machine I've been testing which verifies this behaviour. Surely this is not by design? Am I missing something?

                          1 2 Previous Next