1 2 Previous Next 11 Replies Latest reply: Oct 23, 2014 2:32 PM by togo1919 RSS

    disable McAfee firewall and enable windows firewall

    dknovak

      Good day,

       

      I'm simply unable to get my Apple Home Sharing to work with the McAfee firewall - but I can't figure out how to enable my Win7 firewall with MCafee disabled.

       

      Is it possible, or do I need to completely uninstall McAfee?

       

      (Yes, I've already tried enabling all the recommended ports - no luck, so I just want it off)

        • 1. Re: disable McAfee firewall and enable windows firewall
          Peacekeeper

          Even disabling Mcafee firewall blocks enabling windows firewall though might work after a reboot. Really I used to see when you tried to uninstall mcafee via add/remove programs or program features in control panel a list pops up giving you a choice of what to uninstall.This might only happen f custom install was used to install Mcafee.

           

          If that list ( and my testing seems to say it is not available) uninstall as per

          http://service.mcafee.com/FAQDocument.aspx?lc=1033&id=TS100507

          reboot and reinstall choosing a custom install without selecting firewall.

           

           

          Actually in XP you can disable the firewall and enable the widows firewall. Unsure if this will work but in win 7 I cannot seem to be able to do it.,

           

          Message was edited by: Peacekeeper on 26/06/11 8:03:42 PM
          • 2. Re: disable McAfee firewall and enable windows firewall
            Dinz

            Hi dknovak,

            Could you please check if you have the netbios port opened ?

            1. Double-click the M icon in your taskbar.
            2. Open the Web and Email Protection drawer and select Firewall.
            3. Open the Ports and System Services drawer.
            4. Select the checkbox beside the Windows File Sharing (NETBIOS) Ports 137-139 option.
            5. Close McAfee SecurityCenter.

            If you still cant access the Apple home sharing , please click on Double-click the M icon in your taskbar.
            Click Navigation.
            Click Firewall.
            Click Turn Off and let us know if you could access the same with McAfee firewall turned off

             

            Regards,

            • 3. Re: disable McAfee firewall and enable windows firewall
              dknovak

              I enabled the Windows file sharing - with no luck.  I previosuly additionally added my own service for TCP Ports 3689 and UDP 5353 as per Apple's recommendations.  I also note that Bonjour services have Full access under Program Permissions.

               

              The only time I'm ever able to share iTunes is when the firewall is completely disabled.  This sort of sucks.... am I the only one?!

              • 4. Re: disable McAfee firewall and enable windows firewall
                thecreator

                dknovak wrote:

                 

                Good day,

                 

                I'm simply unable to get my Apple Home Sharing to work with the McAfee firewall - but I can't figure out how to enable my Win7 firewall with MCafee disabled.

                 

                Is it possible, or do I need to completely uninstall McAfee?

                 

                (Yes, I've already tried enabling all the recommended ports - no luck, so I just want it off)

                 

                Hi dknovak,

                 

                The problem is not with McAfee Firewall. If you uninstalled, you would find out.

                 

                The problem is with Windows 7. Please respond with your correct operating system's version and Service Pack Level and I can tell you exactly what to do.

                • 5. Re: disable McAfee firewall and enable windows firewall
                  dknovak

                  Win7 SP1

                   

                  It (Home Sharing) seems to show up about a second or two after disabling the firewall.  It never seems to last, though.  Sooner or later Home Sharing goes away and I need to cycle the power on the Apple devices to get it to work again (for a short while).

                  I actually re-installed McAfee without the firewall and relied on Win7 firewall alone - didn't really work either  

                  I'm now back to a full McAfee install now and looking for a solution...

                   

                  I've also attempted adding the Apple TV IP to the DMZ section of my wireless router - but that doesnt work either.

                  • 6. Re: disable McAfee firewall and enable windows firewall
                    thecreator

                    dknovak wrote:

                     

                    Win7 SP1

                     

                    It (Home Sharing) seems to show up about a second or two after disabling the firewall.  It never seems to last, though.  Sooner or later Home Sharing goes away and I need to cycle the power on the Apple devices to get it to work again (for a short while).

                    I actually re-installed McAfee without the firewall and relied on Win7 firewall alone - didn't really work either  

                    I'm now back to a full McAfee install now and looking for a solution...

                     

                    I've also attempted adding the Apple TV IP to the DMZ section of my wireless router - but that doesnt work either.

                    Hi dknovak,

                     

                    Win 7 SP1 is a Service Pack. What version of Windows 7 are you running? What Bit also? 32 or 64 Bit? And like I said, McAfee is not the problem!

                    • 7. Re: disable McAfee firewall and enable windows firewall
                      dknovak

                      64 bit Home Premium - geesh.

                      • 8. Re: disable McAfee firewall and enable windows firewall
                        thecreator

                        dknovak wrote:

                         

                        64 bit Home Premium - geesh.

                        Hi dknovak,

                         

                        With Windows 7 Home Premium 64-Bit operating system with Service Pack 1 booted up, click on the Bars Icon in the notification area and click to Open Network and Sharing Center. Once it is open, click to open on the left, Change advance sharing settings.

                         

                        You must go through the Home and Work Profiles. Make sure thar everything but passwords is enabled, unless you use passwords, that should be disabled.

                         

                        You need to determine, what File Encryption Apple uses and select 128-Bit or Use file sharing for devices that uses 40- or 56-bit encryption. Both Home and Work must be set up exacting the same. Click Save Changes. Now close Network and Sharing and now test.

                         

                        I have Windows 7 Home Premium 64-Bit with Service Pack 1 installed. I don't have Apple or Mac.

                         

                        The Windows Firewall is on, but everything is managed by McAfee Personal Firewall.

                        • 9. Re: disable McAfee firewall and enable windows firewall
                          hpytwobme

                          After many hours of work to resolve this problem, I suscessfully manageed to find a fix.  By the way, I'm using Windows 8.

                           

                          In my case, it's wasn't McAfee causing the problem, but instead it was being caused by Windows.

                           

                          First, I disabled McAfee firewall and attempted the connection.  Yes, it was successful, but wasn't something I was completely comfortable with.  It atleast told me the problem was a firewall issue.

                           

                          INSTRUCTIONS:

                          • Turn on Home Sharing on both itunes and the remote device (iphone, ipad....)
                          • Go to Control Panel on your computer
                          • Go to Network and Internet
                          • Go to Network and Sharing
                          • Go to Change Advanced Sharing Settings
                          • Under Private (current profile) select TURN ON NETWORK DISCOVERY and be sure to slect TURN ON AUTOMATIC SETUP OF NETWORK CONNECTED DEVICES.

                           

                          I can now successfully use the Remote App without disabeling the firewall or any other crazy temporary fix that leaves your system vulnerable.

                           

                          Hope it works for you.

                          1 2 Previous Next