1 2 Previous Next 12 Replies Latest reply on Jun 5, 2014 9:59 AM by sveerara

    Firewall blocks Windows 7 homegroup

    gizmagis

      Hi guys,

       

      did anyone figure it out what ports needs to be open in orther to join Windows 7 computer to a homegroup domain. I already opened ports 3587 and 3540 as Microsoft suggest when trying to join homegroup. Well it does not work. The only way is to turn of Firewall which is annoying if you have settings where FW can not be turned off.

       

      Any suggestions ?

       

      Regards,

      Gregor

        • 1. Re: Firewall blocks Windows 7 homegroup
          RaviShankar

          Hi Gregor,

           

          I have read your post. I am not sure which firewall you are referring to.

           

          If it is McAfee's firewall, please follow the given instructions to allow your windows 7 computer to homegroup domain.

           

          Open the McAfee security center using the page www.mcafeeasap.com

          Click on policies on the top and then click on add policy and then select firewall settings on the left pane

          Select administrator configures firewall

          Now you shall get a menu with different options

          Please select the reports option under the firewall protection status

          Now, below you can select the custom settings and click on edit

          You shall get three options to allow printer, file sharing and remote access, please select all the 3

          Click on ok

          Now save and add this policy to your computer.

           

          Please perform the below steps on your computer security center console.

           

          Please give a right click on the M icon near the system clock and select open console.

          In the console please click on the pull down menu that says Action menu

          Select Set connection type

          Select custom and select edit

          Now on the menu try to open the ports like windows file sharing and remote desktop, with ports like 80, 443, 110 and 25

           

          Please let me know if you are still facing the same issue.

           

          Regards,

           

          Ravi

          • 2. Re: Firewall blocks Windows 7 homegroup
            gizmagis

            Hi Ravi,

             

            I am talking about McAfee SaaS Firewall. I already have all those settings you mentioned + opened ports 3587 and 3540 as microsoft suggests for homegroup. The only settings which can not be set is connection type. If connection type is set to custom settings under console it can not be changed in client console, neverthless you are logged on as administrator.

             

            So yes, issue is remaining...

             

            Regards,

            Gregor

            • 3. Re: Firewall blocks Windows 7 homegroup
              Pritish

              Hi Gregor,

               

              I have read your post.

               

              Please be informed that in the online McAfee Console after you select "Administrator Configures Firewall" option, there will be an option that states, "Firewall Protection Mode", if this is set to prompt, then you will not be able to access the "Custom Settings". Please change the firewall protection type to "reports", then access the Custom settings.

               

              Under the Custom setting, you will have a topic that says "Allowed Incoming connection", please select all the 3 under this, file sharing, print sharing and remote desktop.

               

              Now, the next topic would be "Allowed incoming address", please enter the IP range of your HomeGroup. Under the"Add a connection", you can add the port number that is used by the Windows 7 HomeGroup.

               

              After all the above steps, run a manual update from the M icon on the computer.

               

              Please try these steps and get back to us.

               

              Regards

              Pritish P.

              • 4. Re: Firewall blocks Windows 7 homegroup
                gizmagis

                Hi Pritish,

                 

                I already have all these settings. Administrator Configures Firewall, Report Firewall protection mode and selected custom settings. Under custom settings all 3 settings (file and print sharing, remote assistance and remote desktop) are checked, Ports, 3587 and 3540 are also defnied (as microsoft suggests) and also under allowed incomming connections I also have defined IP range needed. However this is not the solution...

                 

                I found one article on techet whihc is .... won't say anything... just read it   However I am not satasfied with this....

                 

                Tnx,

                Gregor

                 

                There is however a slight drawback with homegroup if you have anti virus and or security software installed on your pc then homegroup is forever unable to function and becomes useless so you have a choice to make either you use homegroup and forever be ridden with virus, spyware and all that or your protect your pc and suffer the *** the homegroup was designed to solve.

                The only workaround is if your using security software you can use dell network assistant as an easy way to share your files as nothing can overcome the lockout that security software puts on homegroups, i have tried everything i looked up a list of udp and tcp ports that if unblocked are supposed to let you access homegroup but having unlocked those ports using mcafee on both my windows 7 pv's homegroup still wouldnt work so the problem is so far unsolvable.

                • 6. Re: Firewall blocks Windows 7 homegroup

                  Hi Gregor,

                   

                  Thank you for the article which has provided us an glance of secuirty drawbacks on Homegroup.However I would like you to give a try out on the below mentioned steps which may possibly resolve the issue.

                   

                  After you allow the port 3587 and 3540.

                   

                  Make sure that the Network Discovery is enabled and Restart the DNS client & the Startup type should be Automatic.

                   

                  Also reset the HomeGroup by removing it and recreating it.

                   

                   

                  Regards

                  Geetha P

                  • 7. Re: Firewall blocks Windows 7 homegroup
                    gizmagis

                    Hi Gita,

                     

                    Network Discovery is already enabled, also sharing files, folders, printers etc. is enabled. I tried to recreate HomeGroup, restarted DNS client, set to automatic, however it did not solve the problem...

                     

                    Gregor

                    • 8. Re: Firewall blocks Windows 7 homegroup
                      RaviShankar

                      Hi Gregor,

                       

                      Sorry for the delay in response. But hope this will help you. Please allow the following ports and let me know if you are still facing the same issue.

                       

                      To find other computers running Windows Vista or Windows 7, open these ports:

                             

                      •             UDP 3702         
                      •             UDP 5355         
                      •             TCP 5357         
                      •             TCP 5358 

                       

                      To find network devices, open these ports:

                             

                      •             UDP 1900         
                      •             TCP 2869         
                      •             UDP 3702         
                      •             UDP 5355         
                      •             TCP 5357         
                      •             TCP 5358         

                             

                      To make HomeGroup work correctly between computers running Windows 7, open these ports:

                             

                      •             UDP 137         
                      •             UDP 138         
                      •             TCP 139         
                      •             TCP 445         
                      •             UDP 1900         
                      •             TCP 2869         
                      •             UDP 3540         
                      •             TCP 3587         
                      •             UDP 3702         
                      •             UDP 5355         
                      •             TCP 5357         
                      •             TCP 5358         

                       

                      Regards,

                       

                      Ravi

                      • 9. Re: Firewall blocks Windows 7 homegroup

                        Does McAfee understand that it should detect Windows 7, 8, Vista and open the homegroup ports. Most people I know have not gotten homegroup to work. I suspect all the firewall options (e.g. Microsoft itself, McAfee and even Norton) can't figure out how to automate usage. Too many users have to be internals intelligent to use these products. No wonder there is so much stress in todays world.

                         

                        And MAC, although more user friendly, is too expensive and does not play with Office files very well.

                        1 2 Previous Next