7 Replies Latest reply on Aug 26, 2011 8:46 AM by sam_76

    Cisco AnyConnect VPN Issues

      I can't make a VPN connection with the latest Cisco AnyConnect Client version 3.0.2052. I have heard that there can be issues with the McAfee Antivirus Plus software that can cause this to happen. Has anyone had a similar problem and if so what recommendations do your have to resolve the the issue.

        • 2. Re: Cisco AnyConnect VPN Issues

          Thanks for the tip. I tried it, but is seems the VPN server is smart enough that it randomly configures my VPN adaptor. I cannot see any pattern in the IP and DNS entries it comes up with from one log-on attempt to the next.

          • 3. Re: Cisco AnyConnect VPN Issues
            exbrit

            Then I'm stumped as the only other references I see are all to do with Enterprise products, of which I know nothing, and all I can find on the internet is one reference stating to uninstall and reinstall McAfee, but the result was never reported so I can't guarantee that working.

             

            Perhaps you should contact Technical Support Chat  (Useful Links at top of this page).

            • 4. Re: Cisco AnyConnect VPN Issues
              Dinz

              Hi jlcavor,

              Could you please let us know if there arises any specific error messages while connecting to your VPN client.

              Also, let us know the below details ;

              What is the version of McAfee Personal Firewall ?

              Since when are you facing the connection issues ? Is it after any McAfee update ?

               

               

              Thanks,

              • 5. Re: Cisco AnyConnect VPN Issues

                The problem is solved. I uninstalled the Cisco VPN client, then uninstalled McAfee, then reinstalled the VPN client, then reinstalled McAfee. Now the VPN client works as it should.

                 

                Message was edited by: jlcavor on 6/21/11 6:05:01 PM PDT
                • 6. Re: Cisco AnyConnect VPN Issues
                  exbrit

                  Glad you found a solution, sorry we didn't.

                  • 7. Re: Cisco AnyConnect VPN Issues

                    Hi everybody,

                     

                    for your information, Cisco has notified this bug, number:  CSCti16453

                     

                    You can read:

                     

                    AnyConnect cannot connect when installed after McAfee Internet Security

                    Symptom:

                    If installed after 3rd party personal firewall/AV product, AnyConnect will fail to connect. EventViewer will report inability to change the interface name for virtual adapter.

                     

                    Conditions:

                    If installed after 3rd party personal firewall/AV product, AnyConnect will fail to connect

                     

                    Workaround:

                    Disable all the features of personal firewall/AV, make a small change on AnyConnect virtual adapter and connect.

                     

                    Further problem description

                    The AnyConnect virtual adapter (VA) driver is not properly installed due to the McAfee Internet Security self-protection mechanism denying certain registry operations. The McAfee log file McSvHost000.log includes multiple entries resembling the following:

                    (Information)$ [ naiann.dll]$ NewInfection [AnnounceType: BBRuleViolation][ThreadID: 3452][WinStationID: 0][EventID: 1092][Action: 3][Location: \REGISTRY\MACHINE\SYSTEM\ControlSet001\Services\mfendisk\Parameters\Adapters\Nd isWanIp\UpperBindings][Process C:\Program Files\Cisco\Cisco AnyConnect VPN Client\VACon.exe][Rule: G_060_CommonOn:Prevent modification of McAfee files and settings]

                    (Note that the UpdateDriverForPlugAndPlayDevices Windows API, used to install the driver does not return an error, therefore AnyConnect assumes successful installation.)

                     

                    As a result, even after enabling the VA via the Device Manager Management Console (devmgmt.msc), the virtual adapter is not listed by the Windows ipconfig command. Similarly, vpnagent fails to identify the VA connection name (due to the GetAdaptersAddresses native API not returning the AnyConnect virtual adapter) leading to the VPN connection failure.

                     

                    Note that the VA installation works fine with McAfee VirusScan Enterprise installed. The problem only happens if the AnyConnect installation is performed with McAfee Internet Security installed.

                     

                     

                    Now my question:

                    does Mcafee will resolve this problem?

                     

                    I have, in my university, some users that uses McAfee Internet Security. And when we're upgrading the client Anyconnect, McAfee Internet security denies certain registry operations and the Anyconnect VPN client is not correctly installed.  After, the solution is the same that solution of jlcavor, we must uninstall the Cisco VPN client, then uninstalled McAfee, then reinstalled the VPN client, then reinstalled McAfee.

                     

                    Thank you for your respond

                    Best regards

                     

                    Sam

                     

                     


                     

                    Ce message a été modifié par: sam_76 on 26/08/11 08:46:36 CDT