4 Replies Latest reply on Jun 17, 2011 11:31 AM by SafeBoot

    SDMCFG merged ini issue

      Hi,

       

      before upgrading from safeboot 4.2 (.12)  to EE 5.2 on a new server, I'm trying to update the SDMCFG.ini and SCM.ini using the merge function.

      I put my new DB param in the SDMCFG like that in a new file group:

       

      [Databases]

      Database2=testsrv2

      [Database2]

      Description=testDB2

      IsLocal=No

      Authenticate=Yes

      Port=5555

      ServerKey=12345.....000069

      ExtraInfo=00000...000

       

      on my updated clients, I open the file and it is like that:

       

      [Databases]

      Database2=testsrv2

      [Database2]

      Description=testDB2

      IsLocal=No

      Authenticate=Yes

      Port=5555

      ServerKey=12345.....000

      ExtraInfo=00000...000

       

       

      Three characters are missing, I tried several times on different servers on different subnets and the issue is still here.

       

      Any help please ?

        • 1. Re: SDMCFG merged ini issue

          After more testing, I can say that there are too much characters in my "ServerKey" field in the SDMCFG.ini file. The problem does not exist with EE 5.

          I really need to update this file before migration because of the famous IP instead of DNS.

          Are there other solution Or can I solve this bug ?

          Should I update entirely the SDMCG file without merging ?

          Or should I desactivate the authentication in the file ?

           

          Ce message a été modifié par: gco on 17/06/11 03:21:05 CDT
          • 2. Re: SDMCFG merged ini issue

            1. you can copy a new sdmcfg.ini file into place using some external system - like a login script or something?

            2. you can turn auth off for this new connection, but this adds vulnerabilities and stability concerns to your environment?

            • 3. Re: SDMCFG merged ini issue

              thanks for you're reply.

              I'm surprised to be the only one encountering that bug.

              For the moment I think I'm gonna turn off auth but I'd prefer to solve that bug.

              • 4. Re: SDMCFG merged ini issue

                You're using a 2005 version of the product unfortunately - most people upgraded long before this forum became active. There's not even any support for v4 anymore.