3 Replies Latest reply: Jun 11, 2011 6:04 PM by Peacekeeper RSS

    no programs work after uninstalling mcafee

      Hi.  I'm really hoping that someone can help me.  I have a Dell studio XPS running windows 7.  McAfee came installed.  The subscription is coming up, so I bought a more recent version of the program to update it.  I went to uninstall the old version of the program so that I could install the newer version by using the Add/Remove programs.  Things seemed to go well until it said it was time to reboot.  Upon rebooting, the computer would come up with the screen saying that it had been shut down incorrectly and give me options of either booting in safe mode or normally.  I chose normally initially, and then the computer would crash (blue screen), and go back to the screen saying it had shut down incorrectly.  I chose safe mode, and once there used system restore to go back to a point before I tried to uninstall the program.  I then spent some time online researching uninstalling McAfee, and on their site (as well as many others) saw instructions to use MCPR.exe.  I followed McAfee document ID: TS100507 instructions for Windows 7, and tried again.  The same thing happened, except after the system restore my computer will no longer run ANY of my programs (e.g. word, Excel, powerpoint, internet explorer).  All of my files are still there, but none of the programs work (the computer still recognizes that the programs are there as the files created by the program show the correct type, but if you try to open one it gives a message saying that there was a problem locating the program).  I've tried going directly to the program folders and executing them from there, but nothing happens.  So, now I find myself with a computer that, for all practical purposes, has no programs, BUT STILL HAS MCAFEE.  I'm assuming I need to get rid of McAfee and then reload all of the programs, but can't find anything about what to do.  PLEASE HELP!!!!

        • 1. Re: no programs work after uninstalling mcafee
          Peacekeeper

          Are you sure you haven't a trojan on the PC? Some exhibit this no exe program works issue and hide folders.

           

          Run both these if necessary try the exe fix below  first

          Then  Run the free Mcafee Stinger program from http://vil.nai.com/vil/stinger/ -

            Also run Malwarebytes

           

           

           

          The blue screen thingy is I feel a network driver issue ie it is an atheros driver lower than 238 and reacts with Mcafee

          Steps to check Version of network Adaptor:

          Open Device manager

          Right click on Computer

          click on manage

          In the left hand panel click on Device Manager

          Right click on network adaptor

          Click on property

          Make sure if its WLAN Atheros  driver Version  8.0.0.238

          If not update the driver and make sure we get the latest.

          If it’s not getting update check with OEM Website (system manufacture) or call your System vendor to get it updated.

           

          EXE fix

          http://www.winhelponline.com/blog/file-asso-fixes-for-windows-7/

          • 2. Re: no programs work after uninstalling mcafee

            Tony,

             

            At this point I'm not sure about anything.  However, before I started this the computer was working fine.  McAfee had never identified any significant problems as far as Trojans / worms etc, all programs worked, and computer didn't exhibit any of the classic signs of infection (e.g. sluggishness). 

             

            Since I posted last night I tried booting in safe mode.  This improved a number of things.  First, I was able to see a number of different system restore points.  I tried to restore to a point from about a week ago, and was given the following error message:  "rstrui.exe Application Error: The instruction at 0xfb40ca53 referenced memory at 0x003990a0.  The memory could not be read.  Click on OK to terminate program."  So I tried to restore to the last available restore point.  This time it attempted to restore, then gave me the error message that it couldn't.  When I acknowledged that it couldn't, it restarted the computer.  I again went into safe mode, at which time it said that the restore was successful.  I don't know if it truely did restore, however at least I can now access programs.  

             

            Since I can now actually get the Device Manager to open (it wouldn't before), I checked the network adapters.  Initially there were three are listed:

             

            1.  Broadcom Netlink (TM) Gigabit Ethernet (with a Braodcom driver, vs. 12.2.2.2)

            2.  DW1525 (802.11n) WLAN PCIe Card (Atheros, vs. 8.0.0.144)

            3.  Microsoft Virtual WiFi Miniport Adapter (Microsoft).  This has the error message "this device is not working properly because Windows cannot load the drivers required for this device (Code 31)"

             

            I went to the Dell site, and for my service tag number, asked for network driver updates.  Choose the DW1525, downloaded and installed the update.  Now the device manager only shows the first two network adaptors (the third was for bluetooth which I don't have so guess this is OK), but gives the following error message for the DW1525 "Windows cannot verify the digital signature for thedirvers required for this device.  A recent hardware of software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source (Code 52)"  It shows the version as 8.0.0.376.

             

            I'm afraid to try and restart the computer normally just yet.  I want to make sure that all my files are saved (I save automatically to a server and manually to an external drive, but want to check that everything was working as designed).

             

            I'll post back as soon as I can and let you know if the restore/driver update worked.  If the comuter is able to restart normally, do I then try to uninstall McAfee through the add/uninstall programs again?

            • 3. Re: no programs work after uninstalling mcafee
              Peacekeeper

              Ok that initial blue screen was the atheros issue that I am sure of. The others could have been a corruption of a restore point but I would still run the stinger and MWB links.