5 Replies Latest reply on Oct 11, 2008 2:24 PM by mrksmith

    How to uninstall Framework services of VSE8.5

      Hi,
      I have uninstalled a trial VSE8.5 from my system to install Total protection 2007 plus.

      After installed Total protection I noticed the following:
      - the directory of Mcafee Framework services was not removed from My system, so I deleted it manually.
      - the framework services was not removed from my system. Too late I undestood that the directory was not deleted because the service was not removed.

      There is a way to remove the services without uninstall total protection, install again VSE8.5 and remove it again deactivating the prevention system.
      Thank in adavance for your help

      Maurizio
        • 1. RE: How to uninstall Framework services of VSE8.5
          have you an ePO agent on the machine? That would require the framework service.
          • 2. RE: How to uninstall Framework services of VSE8.5

            I don't know, how can check this?

            Thanks
            Maurizio
            • 3. RE: How to uninstall Framework services of VSE8.5
              Tried This?

              How To Uninstall McAfee ePO and Common Framework

              Machines With VirusScan 8.5i Installed:

              1. Open a command window:
              2. At the C: prompt, type: cd Program Files\McAfee\Common Framework Then press the "Enter" key.
              3. Then type: frminst /forceuninstall Then press the "Enter" key and let the program finish.

              Then again, it may uninstall your other program also..

              Hope this helps.

              Grif
              • 4. hi
                hi,
                i have installed epo 3.6.1 and mcafee 8.5 but i cant able to install framwork packages in client systems. pls help me. i copied what error i am getting.



                20080421145652 I #1012 Stub Pkg
                20080421145652 I #1012 Stub Pkg START ["C:\Documents and Settings\testingclient\Desktop\frampackage\FramePkg.exe" ]
                20080421145652 I #1012 Common Pkg CreateDirectory (C:\DOCUME~1\TESTIN~1\LOCALS~1\Temp\unz43.tmp)
                20080421145653 I #1012 Stub Pkg System=0
                20080421145653 I #1012 Common Pkg CreateProcess (C:\DOCUME~1\TESTIN~1\LOCALS~1\Temp\unz43.tmp\FrmInst.exe, /CreateService="C:\Documents and Settings\testingclient\Desktop\frampackage\FramePkg.exe" /LOGDIR="C:\DOCUME~1\TESTIN~1\LOCALS~1\Temp\NAILogs" /Cleanup2="C:\DOCUME~1\TESTIN~1\LOCALS~1\Temp\unz43.tmp" /EmbeddedUsername="<administrator>" /EmbeddedDomain="<ismarthyddc>" /EmbeddedPassword="************************************************************ ****" /Install=Agent)
                20080421145654 I #1012 Common Pkg WaitForSingleObject (C:\DOCUME~1\TESTIN~1\LOCALS~1\Temp\unz43.tmp\FrmInst.exe, -1)
                20080421145656 I #384 naCmnLib Ins Random seed = 0xe22f****
                20080421145656 I #384 Setup Ins START [/CreateService="C:\Documents and Settings\testingclient\Desktop\frampackage\FramePkg.exe" /LOGDIR="C:\DOCUME~1\TESTIN~1\LOCALS~1\Temp\NAILogs" /Cleanup2="C:\DOCUME~1\TESTIN~1\LOCALS~1\Temp\unz43.tmp" /EmbeddedUsername="<administrator>" /EmbeddedDomain="<ismarthyddc>" /EmbeddedPassword="************************************************************ ****" /Install=Agent]
                20080421145656 I #384 Setup Ins Windows 5.1.2600 Service Pack 2
                20080421145656 I #384 Setup Ins Restarting as a service to get System rights
                20080421145656 I #384 Setup Ins This package seems to be created by ePO 3.5 or higher
                20080421145656 E #384 LgOnUsr Ins Error trace:
                20080421145656 E #384 Thread Ins [Main thread]->
                20080421145656 E #384 Setup Ins [Restarting as a service to get System rights]->
                20080421145656 E #384 Setup Ins [Possibly impersonate]->
                20080421145656 E #384 LgOnUsr Ins [AcceptSecurityContext]->
                20080421145656 E #384 LgOnUsr Ins error -2146893044: The logon attempt failed
                20080421145656 E #384 UI Ins Error trace:
                20080421145656 E #384 Thread Ins [Main thread]->
                20080421145656 E #384 UI Ins There was an unexpected error during setup execution. See this log file for details: C:\DOCUME~1\TESTIN~1\LOCALS~1\Temp\NAILogs\FrmInst_MOHANRAJ.txt
                20080421145658 I #384 Thread Ins Exit program
                20080421145658 I #384 Setup Ins END 1603
                20080421145659 I #1012 Stub Pkg END 1603
                • 5. Cannot uninstall framework service
                  I tried running frminst /forceuninstall in a command prompt to remove Framework Service from my computer, but I am receiving an error:

                  "Cannot start service 'McAfee Framework"
                  Cannot stop service "McAfee Framework

                  I would like to get rid of McAfee from my machine, but I wasn't able to fully do so.

                  I found the Manual uninstall instructions worked from here:

                  https://knowledge.mcafee.com/SupportSite/dynamickc.do?sliceId=SAL_Public&command =show&forward=nonthreadedKC&externalId=9611891

                  See solution #4.