4 Replies Latest reply on May 24, 2011 8:13 AM by dstraube

    Web Gateway device - Overload detected

      For the last few weeks we have had an issue with our Mcafee Web Gateways where they would stop processing HTTP traffic and users were given a blank page when trying to access the Internet. We have two of the devices running and the users connect via bluecoats using round robin. When I look at the devices I see on the 'URL Executive Summary graph' traffic goes from 4.5k to 0. When I look at the error logs I find this (below)

       

      Looking at the Memory usage of the devices over the last 6 months they seems to be constantly using 3.7Gb of the 4Gb available. Is this normal for these devices?

       

      [19/May/2011:07:26:02 +0100] Pool of Sophos engines is full now.

      [19/May/2011:08:04:35 +0100] overload detected: memory usage 2624651264

      [19/May/2011:08:05:21 +0100] overload timeout: memory usage still 2604888064, action is accept and send http 503

      [19/May/2011:08:59:37 +0100] Starting Version 6.8.7 (9396) in SP

      [19/May/2011:08:59:38 +0100] Secure Web Cache: Reinitializing cache database.

      [19/May/2011:08:59:38 +0100] Secure Web Cache: disk storage enabled (size=841060712448, block=4096, init=1, tmpfs=1, ndb=17)

       

      Any help/advise greatly appreciated

       

      Thanks

       

      Stu

        • 1. Re: Web Gateway device - Overload detected

          Ran the MPClusterSetup.sh script from within the bin folder as advised by McAfee. This enables multi processing, which seems to have made the system alot more stable...

          • 2. Re: Web Gateway device - Overload detected
            cestrada

            So question now remains...is multiprocessing not enabled until you run this script then? 

             

            We had this problems when we first received the appliances and we were consistently informed it was our DNS overloaded.   Nice to finally know what it was.

             

            We are on 7.1.x....is this something we should run to enable multi-processing or is this now fixed in version 7??

            • 3. Re: Web Gateway device - Overload detected

              Not sure why it wasn't set at install - looking at the install notes McAfee does not  recommend enabling multiprocessing if your device has less than 4GB of RAM, Ours are 4Gb so I guess however installed decided it was boarderline so didnt bother.

               

              We are still stuck in version 6.7.2, but if you ssh to the device and navigate to /opt/webwasher-csm/bin and run this script ( ./ to run) MPClusterSetup.sh this does not change anything but tells you if the function is currrently enabled or disabled and give you the option to enable/disable

               

              You can also tell if you look at the CPU load report under system. Ours now shows four processors in the left axis whereas before there was just the one

               

              Hope that helps

               

              1 of 1 people found this helpful
              • 4. Re: Web Gateway device - Overload detected
                dstraube

                Hello cestrada,

                So question now remains...is multiprocessing not enabled until you run this script then? 

                 

                 

                You manually have to enable the Multi-Process mode by executing the script once. It's not enabled per default, as it's not suitable for all appliances.

                 

                 We had this problems when we first received the appliances and we were consistently informed it was our DNS overloaded.   Nice to finally know what it was. 

                 

                We are on 7.1.x....is this something we should run to enable multi-processing or is this now fixed in version 7??

                 

                MWG 7.x has no Multi-Process feature, as the architecture is different.

                 

                Regards,

                 

                Dirk